summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-05-17 12:50:57 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-05-17 12:50:57 +0000
commitff49202c6c50effa017d058ab5e1510f9e11921a (patch)
tree8ea275041ea892b55999a36062cdd8f039a69218 /games-arcade/opentyrian/files/20110517-datapath.diff
parentVersion bump (diff)
downloadgentoo-2-ff49202c6c50effa017d058ab5e1510f9e11921a.tar.gz
gentoo-2-ff49202c6c50effa017d058ab5e1510f9e11921a.tar.bz2
gentoo-2-ff49202c6c50effa017d058ab5e1510f9e11921a.zip
Bump to new snapshot, as requested by Torsten Kaiser in bug #333011. Port to EAPI=3.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/opentyrian/files/20110517-datapath.diff')
-rw-r--r--games-arcade/opentyrian/files/20110517-datapath.diff26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-arcade/opentyrian/files/20110517-datapath.diff b/games-arcade/opentyrian/files/20110517-datapath.diff
new file mode 100644
index 000000000000..6d7f52cd6bd6
--- /dev/null
+++ b/games-arcade/opentyrian/files/20110517-datapath.diff
@@ -0,0 +1,26 @@
+diff -uNr opentyrian.ORIG//Makefile opentyrian/Makefile
+--- opentyrian.ORIG//Makefile 2011-05-17 11:26:17.030004857 +0100
++++ opentyrian/Makefile 2011-05-17 11:26:52.595004876 +0100
+@@ -39,6 +39,10 @@
+ ALL_LDFLAGS += $(LDFLAGS)
+ LDLIBS += $(EXTRA_LDLIBS) $(SDL_LDLIBS)
+
++ifneq ($(DATA_PATH), )
++ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
++endif
++
+ # RULES ####################################################
+
+ .PHONY : all release clean
+diff -uNr opentyrian.ORIG//src/file.c opentyrian/src/file.c
+--- opentyrian.ORIG//src/file.c 2011-05-17 11:26:17.020004860 +0100
++++ opentyrian/src/file.c 2011-05-17 11:26:52.595004876 +0100
+@@ -34,7 +34,7 @@
+ #ifdef TARGET_MACOSX
+ tyrian_game_folder(),
+ #endif
+- "/usr/share/opentyrian/data"
++ DATA_PATH
+ };
+
+ static const char *dir = NULL;