summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-03-18 18:16:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-03-18 18:16:23 +0000
commitb23f4cca3be3c0f52ebc59cfe54ac11cd478b6e3 (patch)
tree7ac553bb9ec5fc696b68faf0bea7717dc8528aa6 /games-action
parentRemove old. (diff)
downloadgentoo-2-b23f4cca3be3c0f52ebc59cfe54ac11cd478b6e3.tar.gz
gentoo-2-b23f4cca3be3c0f52ebc59cfe54ac11cd478b6e3.tar.bz2
gentoo-2-b23f4cca3be3c0f52ebc59cfe54ac11cd478b6e3.zip
old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/super-hexagon/ChangeLog7
-rw-r--r--games-action/super-hexagon/super-hexagon-15.ebuild85
2 files changed, 5 insertions, 87 deletions
diff --git a/games-action/super-hexagon/ChangeLog b/games-action/super-hexagon/ChangeLog
index 404b42f98b90..0d94563dc60f 100644
--- a/games-action/super-hexagon/ChangeLog
+++ b/games-action/super-hexagon/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/super-hexagon
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/ChangeLog,v 1.6 2013/08/18 00:30:09 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/ChangeLog,v 1.7 2014/03/18 18:16:23 mr_bones_ Exp $
+
+ 18 Mar 2014; Michael Sterrett <mr_bones_@gentoo.org> -super-hexagon-15.ebuild:
+ old
18 Aug 2013; Julian Ospald <hasufell@gentoo.org> super-hexagon-16.ebuild:
stable amd64, x86 wrt #480814
diff --git a/games-action/super-hexagon/super-hexagon-15.ebuild b/games-action/super-hexagon/super-hexagon-15.ebuild
deleted file mode 100644
index 5183bb39296d..000000000000
--- a/games-action/super-hexagon/super-hexagon-15.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/super-hexagon-15.ebuild,v 1.5 2013/05/10 18:46:38 hasufell Exp $
-
-# we use bundled glew, cause slotting 1.6 does not give us
-# much benefit for one consumer
-
-EAPI=5
-
-inherit eutils unpacker games
-
-DESCRIPTION="A minimal action game by Terry Cavanagh, with music by Chipzel"
-HOMEPAGE="http://www.superhexagon.com/"
-SRC_URI="${PN}-linux-${PV}-bin"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="bundled-libs"
-RESTRICT="bindist fetch splitdebug"
-
-MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
-QA_PREBUILT="${MYGAMEDIR#/}/x86/*
- ${MYGAMEDIR#/}/x86_64/*"
-
-DEPEND="app-arch/unzip"
-RDEPEND="
- virtual/glu
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libxcb
- x11-libs/libXdmcp
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libXxf86vm
- !bundled-libs? (
- media-libs/freeglut
- media-libs/libogg
- media-libs/libvorbis
- media-libs/openal
- )"
-
-S=${WORKDIR}/data
-
-pkg_nofetch() {
- einfo "Please buy & download ${SRC_URI} from:"
- einfo " ${HOMEPAGE}"
- einfo "and move it to ${DISTDIR}"
- einfo
-}
-
-src_unpack() {
- unpack_zip ${A}
-}
-
-src_prepare() {
- einfo "removing ${ARCH} unrelated files"
- rm -r $(usex amd64 "x86" "x86_64") || die
-
- if ! use bundled-libs ; then
- einfo "removing bundled-libs..."
- cd $(usex amd64 "x86_64" "x86") || die
- rm libglut.so* libogg.so* libopenal.so* libstdc++.so* \
- libvorbis.so* libvorbisfile.so*
- fi
-}
-
-src_install() {
- local myarch=$(usex amd64 "x86_64" "x86")
-
- insinto "${MYGAMEDIR}"
- doins -r data ${myarch}
-
- dodoc Linux.README
-
- newicon SuperHexagon.png ${PN}.png
- make_desktop_entry ${PN}
- games_make_wrapper ${PN} "./${myarch}/superhexagon.${myarch}" "${MYGAMEDIR}" "${MYGAMEDIR}/${myarch}"
-
- fperms +x "${MYGAMEDIR}/${myarch}/superhexagon.${myarch}"
- prepgamesdirs
-}