summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-06-06 20:08:03 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-06-06 20:08:03 +0000
commit91b518dff7188c12d04622a1c7bde22272c2881e (patch)
tree52e44f122c591941df511d0ecca0d495474420f6 /games-action
parentAdded ~ppc, bug #134717 (diff)
downloadgentoo-2-91b518dff7188c12d04622a1c7bde22272c2881e.tar.gz
gentoo-2-91b518dff7188c12d04622a1c7bde22272c2881e.tar.bz2
gentoo-2-91b518dff7188c12d04622a1c7bde22272c2881e.zip
Version bump. Ebuild provided by Paul Bredbury <brebs@sent.com>. Closing bug #129441.
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/bzflag/ChangeLog8
-rw-r--r--games-action/bzflag/bzflag-2.0.8.ebuild87
-rw-r--r--games-action/bzflag/files/digest-bzflag-2.0.83
3 files changed, 97 insertions, 1 deletions
diff --git a/games-action/bzflag/ChangeLog b/games-action/bzflag/ChangeLog
index 3dc2cb425e89..466598c8d252 100644
--- a/games-action/bzflag/ChangeLog
+++ b/games-action/bzflag/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/bzflag
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.25 2006/04/13 19:40:07 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.26 2006/06/06 20:08:03 wolf31o2 Exp $
+
+*bzflag-2.0.8 (06 Jun 2006)
+
+ 06 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org> +bzflag-2.0.8.ebuild:
+ Version bump. Ebuild provided by Paul Bredbury <brebs@sent.com>. Closing bug
+ #129441.
13 Apr 2006; Chris Gianelloni <wolf31o2@gentoo.org>
bzflag-2.0.4.20050930-r1.ebuild:
diff --git a/games-action/bzflag/bzflag-2.0.8.ebuild b/games-action/bzflag/bzflag-2.0.8.ebuild
new file mode 100644
index 000000000000..2518cf73ffbb
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.0.8.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.0.8.ebuild,v 1.1 2006/06/06 20:08:03 wolf31o2 Exp $
+
+inherit eutils flag-o-matic games
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="http://www.bzflag.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated sdl"
+
+UIDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-image
+ || (
+ (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm )
+ virtual/x11 )"
+
+DEPEND=">=net-misc/curl-7.15.0
+ sys-libs/ncurses
+ net-dns/c-ares
+ sdl? ( ${UIDEPEND} )
+ !sdl? ( !dedicated? ( ${UIDEPEND} ) )"
+
+pkg_setup() {
+ # Only do the libsdl checks for !dedicated - bug #107792
+ use dedicated || GAMES_USE_SDL="nojoystick"
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i configure \
+ -e 's:^CFLAGS=.*::' \
+ -e 's:^CXXFLAGS=.*::' \
+ -e 's:-mcpu=$host_cpu::' \
+ -e 's:-mcpu=k8::' \
+ -e 's:-mtune=$host_cpu::' \
+ -e 's:-mtune=k8::' \
+ || die "sed failed"
+ filter-flags -fno-default-inline
+}
+
+src_compile() {
+ local myconf
+
+ if use dedicated && ! use sdl ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf="--disable-client --without-SDL"
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ ${myconf} \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS TODO ChangeLog BUGS PORTING DEVINFO NEWS README* RELNOTES
+
+ if use sdl || ! use dedicated ; then
+ doicon "data/bzflag-48x48.png"
+ make_desktop_entry ${PN} "BZFlag" ${PN}-48x48.png
+ fi
+
+ prepgamesdirs
+}
diff --git a/games-action/bzflag/files/digest-bzflag-2.0.8 b/games-action/bzflag/files/digest-bzflag-2.0.8
new file mode 100644
index 000000000000..bc42796b238f
--- /dev/null
+++ b/games-action/bzflag/files/digest-bzflag-2.0.8
@@ -0,0 +1,3 @@
+MD5 7963cc1de7144e76a9426b6f23d7c2c8 bzflag-2.0.8.tar.bz2 11330988
+RMD160 8458df60f23b0192885835f6ac6d01e4d57b7d80 bzflag-2.0.8.tar.bz2 11330988
+SHA256 8d120aef46ad92d2699e582b32c44daac76bd274cf30c8be72223210cbdd9a20 bzflag-2.0.8.tar.bz2 11330988