summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commitf199057b8679cd2eed424fccb45361c89a133d31 (patch)
treee6ec41e59db82809cd99452c53c9efe67a3985e3 /games-action/xpilot/xpilot-4.5.4.ebuild
parentgames action and arcade (diff)
downloadgentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.tar.gz
gentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.tar.bz2
gentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.zip
action games !
Diffstat (limited to 'games-action/xpilot/xpilot-4.5.4.ebuild')
-rw-r--r--games-action/xpilot/xpilot-4.5.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-action/xpilot/xpilot-4.5.4.ebuild b/games-action/xpilot/xpilot-4.5.4.ebuild
new file mode 100644
index 000000000000..b99973266eae
--- /dev/null
+++ b/games-action/xpilot/xpilot-4.5.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/xpilot-4.5.4.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+DESCRIPTION="A multi-player 2D client/server space game"
+HOMEPAGE="http://www.xpilot.org/"
+SRC_URI="http://xpilot.org/pub/xpilot/${P}.tar.gz"
+
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="x11-base/xfree
+ >=sys-apps/sed-4"
+
+src_compile() {
+ sed -i \
+ -e "s:/usr/local:/usr:" \
+ -e "s:/man/man:/share/man/man:" \
+ Local.config || die "sed Local.config failed"
+
+ # the stuff xpilot puts it /usr/lib should go
+ # in /usr/share , but I'm leaving it for now.
+
+ xmkmf || die "xmkmf Makefile creation failed"
+ make Makefiles || die "Makefiles problem"
+ local f
+ for f in `find . -type f -regex .*Makefile`; do
+ sed -i -e "s:CDEBUGFLAGS = -O:CDEBUGFLAGS = ${CFLAGS}:" $f ||
+ die "sed $f failed"
+ done
+ make includes || die "includes problem"
+ make depend || die "depend problem"
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install problem"
+ make DESTDIR=${D} install.man || die "install.man problem"
+}