summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-11-03 08:56:15 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-11-03 08:56:15 +0000
commitd9952df3a356a06e93b7b993e5148bca9f8465d2 (patch)
tree4bb78b3de87cc065721e41d680cad3133dbc90d7 /games-action/supertuxkart
parentherd corrected in metadata (diff)
downloadgentoo-2-d9952df3a356a06e93b7b993e5148bca9f8465d2.tar.gz
gentoo-2-d9952df3a356a06e93b7b993e5148bca9f8465d2.tar.bz2
gentoo-2-d9952df3a356a06e93b7b993e5148bca9f8465d2.zip
Fix overflow. Bug #339107
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'games-action/supertuxkart')
-rw-r--r--games-action/supertuxkart/ChangeLog6
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.6.2-ovflfix.patch11
-rw-r--r--games-action/supertuxkart/supertuxkart-0.6.2.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/games-action/supertuxkart/ChangeLog b/games-action/supertuxkart/ChangeLog
index a54d21eaa368..8198ec1cbe16 100644
--- a/games-action/supertuxkart/ChangeLog
+++ b/games-action/supertuxkart/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/supertuxkart
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.20 2010/09/16 17:51:16 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.21 2010/11/03 08:56:15 tupone Exp $
+
+ 03 Nov 2010; Alfredo Tupone <tupone@gentoo.org> supertuxkart-0.6.2.ebuild,
+ +files/supertuxkart-0.6.2-ovflfix.patch:
+ Fix overflow. Bug #339107 by flameeyes@gentoo.org
16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org>
supertuxkart-0.6.2.ebuild:
diff --git a/games-action/supertuxkart/files/supertuxkart-0.6.2-ovflfix.patch b/games-action/supertuxkart/files/supertuxkart-0.6.2-ovflfix.patch
new file mode 100644
index 000000000000..5352683d67d3
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-0.6.2-ovflfix.patch
@@ -0,0 +1,11 @@
+--- src/gui/display_res_confirm.cpp.old 2010-11-03 09:35:21.000000000 +0100
++++ src/gui/display_res_confirm.cpp 2010-11-03 09:35:49.000000000 +0100
+@@ -107,7 +107,7 @@
+ if (m_counter > 1)
+ {
+ m_counter--;
+- snprintf(m_count, MAX_MESSAGE_LENGTH, _("Confirm Resolution Within %d Seconds"), m_counter);
++ snprintf(m_count, sizeof(m_count), _("Confirm Resolution Within %d Seconds"), m_counter);
+ widget_manager->setWgtText( WTOK_TITLE, m_count );
+ }
+ else
diff --git a/games-action/supertuxkart/supertuxkart-0.6.2.ebuild b/games-action/supertuxkart/supertuxkart-0.6.2.ebuild
index 07b86f5a5570..ce892e2768b7 100644
--- a/games-action/supertuxkart/supertuxkart-0.6.2.ebuild
+++ b/games-action/supertuxkart/supertuxkart-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.6.2.ebuild,v 1.8 2010/09/16 17:51:16 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.6.2.ebuild,v 1.9 2010/11/03 08:56:15 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -58,6 +58,7 @@ src_prepare() {
data/Makefile.am \
|| die "sed failed"
rm -rf src/enet
+ epatch "${FILESDIR}"/${P}-ovflfix.patch
eautoreconf
}