summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-08-24 10:16:49 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-08-24 10:16:49 +0000
commitaad23be7f95b1226cd057e6a684bf93c5b9d49ef (patch)
tree40be92f2996f9f780a4eded29e19f15db2e9e0fc /games-action/lugaru-demo
parentInitial commit. (diff)
downloadgentoo-2-aad23be7f95b1226cd057e6a684bf93c5b9d49ef.tar.gz
gentoo-2-aad23be7f95b1226cd057e6a684bf93c5b9d49ef.tar.bz2
gentoo-2-aad23be7f95b1226cd057e6a684bf93c5b9d49ef.zip
Version bump, bug #282401
(Portage version: 2.2_rc39/cvs/Linux x86_64)
Diffstat (limited to 'games-action/lugaru-demo')
-rw-r--r--games-action/lugaru-demo/ChangeLog9
-rw-r--r--games-action/lugaru-demo/lugaru-demo-1.0b.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/games-action/lugaru-demo/ChangeLog b/games-action/lugaru-demo/ChangeLog
index d73446d51937..cdce3dc2873a 100644
--- a/games-action/lugaru-demo/ChangeLog
+++ b/games-action/lugaru-demo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/lugaru-demo
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/lugaru-demo/ChangeLog,v 1.8 2008/02/29 18:06:13 carlo Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/lugaru-demo/ChangeLog,v 1.9 2009/08/24 10:16:49 nyhm Exp $
+
+*lugaru-demo-1.0b (24 Aug 2009)
+
+ 24 Aug 2009; Tristan Heaven <nyhm@gentoo.org> +lugaru-demo-1.0b.ebuild:
+ Version bump, bug #282401
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> lugaru-demo-1.0.ebuild:
Remove icon extension from desktop entry to match Icon Theme Specification.
diff --git a/games-action/lugaru-demo/lugaru-demo-1.0b.ebuild b/games-action/lugaru-demo/lugaru-demo-1.0b.ebuild
new file mode 100644
index 000000000000..8d828450911b
--- /dev/null
+++ b/games-action/lugaru-demo/lugaru-demo-1.0b.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/lugaru-demo/lugaru-demo-1.0b.ebuild,v 1.1 2009/08/24 10:16:49 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="3D arcade with unique fighting system and antropomorphic characters"
+HOMEPAGE="http://www.wolfire.com/lugaru"
+SRC_URI="http://cdn.wolfire.com/games/lugaru-linux-x86-${PV}.bin"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/glibc
+ amd64? ( app-emulation/emul-linux-x86-xlibs )
+ x86? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )"
+
+S=${WORKDIR}/data
+
+src_unpack() {
+ tail -c +193061 "${DISTDIR}"/${A} > ${A}.zip
+ unpack ./${A}.zip
+ rm -f ${A}.zip
+
+ # Duplicate file and can't be handled by portage, bug #14983
+ rm -f "${S}/Data/Textures/Quit.png "
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/lugaru
+
+ insinto "${dir}"
+ doins -r Data *.png *.txt || die "doins failed"
+
+ exeinto "${dir}"
+ doexe lugaru lib*so* xdg-open || die "doexe failed"
+ games_make_wrapper lugaru ./lugaru "${dir}" "${dir}"
+
+ doicon lugaru.png
+ make_desktop_entry lugaru Lugaru lugaru
+
+ prepgamesdirs
+}