summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-30 04:37:47 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-30 04:37:47 +0000
commit3eb719a3b8a13ef7af77b2aa214e520f3bb02eb5 (patch)
tree9ec60994bd0f60c636abd72eec676701c48fdd22 /games-action/gltron/files
parentinitial import (diff)
downloadgentoo-2-3eb719a3b8a13ef7af77b2aa214e520f3bb02eb5.tar.gz
gentoo-2-3eb719a3b8a13ef7af77b2aa214e520f3bb02eb5.tar.bz2
gentoo-2-3eb719a3b8a13ef7af77b2aa214e520f3bb02eb5.zip
Fix CFLAGS breakage and sync some mismatched prototypes.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-action/gltron/files')
-rw-r--r--games-action/gltron/files/gltron-0.70-configure.patch24
-rw-r--r--games-action/gltron/files/gltron-0.70-prototypes.patch24
2 files changed, 48 insertions, 0 deletions
diff --git a/games-action/gltron/files/gltron-0.70-configure.patch b/games-action/gltron/files/gltron-0.70-configure.patch
new file mode 100644
index 000000000000..91414b3956ec
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-configure.patch
@@ -0,0 +1,24 @@
+configure.in is written poorly so it just stomps all over CFLAGS
+
+--- configure
++++ configure
+@@ -2805,7 +2805,7 @@
+ RANLIB="$ac_cv_prog_RANLIB"
+ fi
+
+-CFLAGS="-DSEPARATOR=\"'/'\""
++CFLAGS="$CFLAGS -DSEPARATOR=\"'/'\""
+
+ # Check whether --enable-warn or --disable-warn was given.
+ if test "${enable_warn+set}" = set; then
+@@ -2852,10 +2852,6 @@
+ else
+ enable_optimize=s
+ fi;
+-if test "x$enable_optimize" ; then
+- CFLAGS="$CFLAGS -O$enable_optimize"
+- CXXFLAGS="$CXXFLAGS -O$enable_optimize"
+-fi
+
+ # Check whether --with-sdl-prefix or --without-sdl-prefix was given.
+ if test "${with_sdl_prefix+set}" = set; then
diff --git a/games-action/gltron/files/gltron-0.70-prototypes.patch b/games-action/gltron/files/gltron-0.70-prototypes.patch
new file mode 100644
index 000000000000..d697f1ad59ac
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-prototypes.patch
@@ -0,0 +1,24 @@
+scripting.h declares these params as const so make sure they're the same.
+
+--- nebu/scripting/scripting.c
++++ nebu/scripting/scripting.c
+@@ -169,16 +169,16 @@
+ return status;
+ }
+
+-void scripting_RunFile(char *name) {
++void scripting_RunFile(const char *name) {
+ lua_dofile(L, name);
+ }
+
+-void scripting_Run(char *command) {
++void scripting_Run(const char *command) {
+ /* fprintf(stderr, "[command] %s\n", command); */
+ lua_dostring(L, command);
+ }
+
+-void scripting_RunFormat(char *format, ... ) {
++void scripting_RunFormat(const char *format, ... ) {
+ char buf[4096];
+ va_list ap;
+ va_start(ap, format);