summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-11 15:08:07 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-11 15:08:07 +0000
commit5ae303cb909c12d4905541dd2b1352e4cedb12a5 (patch)
treee613101366ec6305dbb6b6150d8dc0cf461f8b4c /eclass/gnome2.eclass
parentUpdate to support selinux USE flag (blame spb). (diff)
downloadgentoo-2-5ae303cb909c12d4905541dd2b1352e4cedb12a5.tar.gz
gentoo-2-5ae303cb909c12d4905541dd2b1352e4cedb12a5.tar.bz2
gentoo-2-5ae303cb909c12d4905541dd2b1352e4cedb12a5.zip
QA: Apply whitespace checks from repoman to eclasses.
Diffstat (limited to 'eclass/gnome2.eclass')
-rw-r--r--eclass/gnome2.eclass17
1 files changed, 7 insertions, 10 deletions
diff --git a/eclass/gnome2.eclass b/eclass/gnome2.eclass
index 7d84068da725..fc85bb1578f7 100644
--- a/eclass/gnome2.eclass
+++ b/eclass/gnome2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gnome2.eclass,v 1.52 2005/07/06 20:36:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gnome2.eclass,v 1.53 2005/07/11 15:08:06 swegener Exp $
#
# Authors:
# Bruce A. Locke <blocke@shivan.org>
@@ -17,7 +17,7 @@ USE_DESTDIR="" # use make DESTDIR=${D} install rather than einstall
IUSE="debug doc"
use debug && G2CONF="${G2CONF} --enable-debug=yes"
-DEPEND="${DEPEND} >=sys-apps/sed-4"
+DEPEND=">=sys-apps/sed-4"
gnome2_src_configure() {
@@ -82,7 +82,7 @@ gnome2_gconf_install() {
then
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
export GCONF_CONFIG_SOURCE=`${ROOT}/usr/bin/gconftool-2 --get-default-source`
- einfo "Installing GNOME 2 GConf schemas"
+ einfo "Installing GNOME 2 GConf schemas"
grep "obj /etc/gconf/schemas" ${ROOT}/var/db/pkg/*/${PF}/CONTENTS | sed 's:obj \([^ ]*\) .*:\1:' | while read F; do
if [ -e "${F}" ]; then
# echo "DEBUG::gconf install ${F}"
@@ -99,7 +99,7 @@ gnome2_gconf_uninstall() {
then
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
export GCONF_CONFIG_SOURCE=`${ROOT}/usr/bin/gconftool-2 --get-default-source`
- einfo "Uninstalling GNOME 2 GConf schemas"
+ einfo "Uninstalling GNOME 2 GConf schemas"
cat ${ROOT}/var/db/pkg/*/${PN}-${PVR}/CONTENTS | grep "obj /etc/gconf/schemas" | sed 's:obj \([^ ]*\) .*:\1:' |while read F; do
# echo "DEBUG::gconf install ${F}"
${ROOT}/usr/bin/gconftool-2 --makefile-uninstall-rule ${F} 1>/dev/null
@@ -113,18 +113,18 @@ gnome2_omf_fix() {
# workaround/patch against omf.make or omf-install/Makefile.in
# in order to remove redundant scrollkeeper-updates.
# - <liquidx@gentoo.org>
-
+
local omf_makefiles
omf_makefiles="$@"
[ -f ${S}/omf-install/Makefile.in ] \
&& omf_makefiles="${omf_makefiles} ${S}/omf-install/Makefile.in"
-
+
# FIXME: does this really work? because omf.make only gets included
# when autoconf/automake is run. You should directly patch
# the Makefile.in's
-
+
[ -f ${S}/omf.make ] \
&& omf_makefiles="${omf_makefiles} ${S}/omf.make"
@@ -169,8 +169,5 @@ gnome2_pkg_postrm() {
}
-
#EXPORT_FUNCTIONS src_compile src_install pkg_postinst pkg_prerm pkg_postrm
EXPORT_FUNCTIONS src_compile src_install pkg_postinst pkg_postrm
-
-