summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2015-03-13 04:56:35 +0000
committerPatrick McLean <chutzpah@gentoo.org>2015-03-13 04:56:35 +0000
commitc9e3c2979b64e70f8efb9534349dade7e94a9b7e (patch)
treeb2a98acf11b81b4dff7b8be67231421fe80b5b4f /dev-vcs
parentEAPI=5 (diff)
downloadgentoo-2-c9e3c2979b64e70f8efb9534349dade7e94a9b7e.tar.gz
gentoo-2-c9e3c2979b64e70f8efb9534349dade7e94a9b7e.tar.bz2
gentoo-2-c9e3c2979b64e70f8efb9534349dade7e94a9b7e.zip
Version bump, install example configs from contrib.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tig/ChangeLog9
-rw-r--r--dev-vcs/tig/tig-2.1.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index 9bfdecb750e7..c5c91a1a7ae8 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tig
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.36 2014/11/08 04:56:25 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.37 2015/03/13 04:56:35 chutzpah Exp $
+
+*tig-2.1 (13 Mar 2015)
+
+ 13 Mar 2015; Patrick McLean <chutzpah@gentoo.org> +tig-2.1.ebuild:
+ Version bump, install example configs from contrib.
08 Nov 2014; Tim Harder <radhermit@gentoo.org> -tig-1.2.1.ebuild,
-tig-2.0.2.ebuild:
diff --git a/dev-vcs/tig/tig-2.1.ebuild b/dev-vcs/tig/tig-2.1.ebuild
new file mode 100644
index 000000000000..943aee0c68a7
--- /dev/null
+++ b/dev-vcs/tig/tig-2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-2.1.ebuild,v 1.1 2015/03/13 04:56:35 chutzpah Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="unicode"
+
+DEPEND="sys-libs/ncurses[unicode?]
+ sys-libs/readline:0"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_prepare() {
+ # pre-generated manpages are in the root directory
+ sed -i '/^MANDOC/s#doc/##g' Makefile || die
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_test() {
+ # workaround parallel test failures
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dohtml manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+
+ docinto examples
+ dodoc contrib/*.tigrc
+}