summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVikraman Choudhury <vikraman@gentoo.org>2014-04-19 19:05:57 +0000
committerVikraman Choudhury <vikraman@gentoo.org>2014-04-19 19:05:57 +0000
commit4e3760ac883ec0a31665fbacf645cf0d6f92482c (patch)
tree8e856a41a23c50657f83e465be6ae617ea3fb651 /dev-vcs
parentre-sign commit (diff)
downloadgentoo-2-4e3760ac883ec0a31665fbacf645cf0d6f92482c.tar.gz
gentoo-2-4e3760ac883ec0a31665fbacf645cf0d6f92482c.tar.bz2
gentoo-2-4e3760ac883ec0a31665fbacf645cf0d6f92482c.zip
Bump to version 1.12.0, fix tests
(Portage version: 2.2.10_p15/cvs/Linux i686, signed Manifest commit with key B0A72FD2)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hub/ChangeLog8
-rw-r--r--dev-vcs/hub/hub-1.11.0.ebuild13
-rw-r--r--dev-vcs/hub/hub-1.11.1.ebuild13
-rw-r--r--dev-vcs/hub/hub-1.12.0.ebuild38
4 files changed, 67 insertions, 5 deletions
diff --git a/dev-vcs/hub/ChangeLog b/dev-vcs/hub/ChangeLog
index 4150a82ce378..f811f5d1f5ed 100644
--- a/dev-vcs/hub/ChangeLog
+++ b/dev-vcs/hub/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/hub
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/ChangeLog,v 1.8 2014/01/23 18:31:20 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/ChangeLog,v 1.9 2014/04/19 19:05:57 vikraman Exp $
+
+*hub-1.12.0 (19 Apr 2014)
+
+ 19 Apr 2014; Vikraman Choudhury (vikraman) <vikraman@gentoo.org>
+ +hub-1.12.0.ebuild, hub-1.11.0.ebuild, hub-1.11.1.ebuild:
+ Bump to version 1.12.0, fix tests
23 Jan 2014; Sébastien Fabbro <bicatali@gentoo.org> hub-1.11.1.ebuild:
Keyworded amd64-linux, x86-linux
diff --git a/dev-vcs/hub/hub-1.11.0.ebuild b/dev-vcs/hub/hub-1.11.0.ebuild
index 0f8fbc5234d6..b76809544e9e 100644
--- a/dev-vcs/hub/hub-1.11.0.ebuild
+++ b/dev-vcs/hub/hub-1.11.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/hub-1.11.0.ebuild,v 1.3 2014/01/17 17:25:16 vikraman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/hub-1.11.0.ebuild,v 1.4 2014/04/19 19:05:57 vikraman Exp $
EAPI="5"
@@ -10,7 +10,12 @@ RUBY_FAKEGEM_EXTRADOC="README.md"
inherit readme.gentoo ruby-fakegem
-ruby_add_bdepend "test? ( dev-ruby/webmock dev-util/cucumber )"
+ruby_add_bdepend "
+ test? (
+ dev-ruby/webmock
+ dev-util/cucumber
+ virtual/ruby-minitest
+ )"
DESCRIPTION="command-line wrapper for git that makes you better at GitHub"
HOMEPAGE="https://github.com/github/hub"
@@ -23,6 +28,10 @@ RDEPEND="dev-vcs/git"
DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
+all_ruby_prepare() {
+ sed -i -e 's/Minitest/MiniTest/g' test/*.rb
+}
+
src_install() {
ruby-ng_src_install
readme.gentoo_create_doc
diff --git a/dev-vcs/hub/hub-1.11.1.ebuild b/dev-vcs/hub/hub-1.11.1.ebuild
index 93d988c074a3..0d53d4487853 100644
--- a/dev-vcs/hub/hub-1.11.1.ebuild
+++ b/dev-vcs/hub/hub-1.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/hub-1.11.1.ebuild,v 1.3 2014/01/23 18:31:20 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/hub-1.11.1.ebuild,v 1.4 2014/04/19 19:05:57 vikraman Exp $
EAPI="5"
@@ -10,7 +10,12 @@ RUBY_FAKEGEM_EXTRADOC="README.md"
inherit readme.gentoo ruby-fakegem
-ruby_add_bdepend "test? ( dev-ruby/webmock dev-util/cucumber )"
+ruby_add_bdepend "
+ test? (
+ dev-ruby/webmock
+ dev-util/cucumber
+ virtual/ruby-minitest
+ )"
DESCRIPTION="command-line wrapper for git that makes you better at GitHub"
HOMEPAGE="https://github.com/github/hub"
@@ -23,6 +28,10 @@ RDEPEND="dev-vcs/git"
DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
+all_ruby_prepare() {
+ sed -i -e 's/Minitest/MiniTest/g' test/*.rb
+}
+
src_install() {
ruby-ng_src_install
readme.gentoo_create_doc
diff --git a/dev-vcs/hub/hub-1.12.0.ebuild b/dev-vcs/hub/hub-1.12.0.ebuild
new file mode 100644
index 000000000000..1573852e791d
--- /dev/null
+++ b/dev-vcs/hub/hub-1.12.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/hub-1.12.0.ebuild,v 1.1 2014/04/19 19:05:57 vikraman Exp $
+
+EAPI="5"
+
+USE_RUBY="ruby18 ruby19"
+RUBY_FAKEGEM_TASK_DOC=
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit readme.gentoo ruby-fakegem
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/webmock
+ dev-util/cucumber
+ virtual/ruby-minitest
+ )"
+
+DESCRIPTION="command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="https://github.com/github/hub"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+RDEPEND="dev-vcs/git"
+
+DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
+
+all_ruby_prepare() {
+ sed -i -e 's/Minitest/MiniTest/g' test/*.rb
+}
+
+src_install() {
+ ruby-ng_src_install
+ readme.gentoo_create_doc
+}