summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-03-06 15:58:48 +0000
committerUlrich Müller <ulm@gentoo.org>2010-03-06 15:58:48 +0000
commitabb4f04457e554b61968a5d13064a59d7607427f (patch)
tree0e14707d6a6eb64aa443a8f94cd567667043ec9c /dev-vcs/stgit/stgit-0.14.3.ebuild
parentVersion bump (diff)
downloadgentoo-2-abb4f04457e554b61968a5d13064a59d7607427f.tar.gz
gentoo-2-abb4f04457e554b61968a5d13064a59d7607427f.tar.bz2
gentoo-2-abb4f04457e554b61968a5d13064a59d7607427f.zip
Move package from dev-util to dev-vcs, bug 56967.
(Portage version: 2.2_rc63/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'dev-vcs/stgit/stgit-0.14.3.ebuild')
-rw-r--r--dev-vcs/stgit/stgit-0.14.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-vcs/stgit/stgit-0.14.3.ebuild b/dev-vcs/stgit/stgit-0.14.3.ebuild
new file mode 100644
index 000000000000..2797582fd9f7
--- /dev/null
+++ b/dev-vcs/stgit/stgit-0.14.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/stgit/stgit-0.14.3.ebuild,v 1.1 2010/03/06 15:58:48 ulm Exp $
+
+inherit distutils bash-completion
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+SRC_URI="http://homepage.ntlworld.com/cmarinas/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=dev-util/git-1.5"
+DEPEND="$RDEPEND"
+
+src_install() {
+ sed -i -e 's-\(prefix:\) ~-\1 /usr-' setup.cfg
+ distutils_src_install
+ dodir /usr/share/doc/${PF}
+ mv "${D}/usr/share/${PN}/examples" "${D}/usr/share/doc/${PF}"
+ rmdir "${D}/usr/share/doc/${PN}"
+ dobashcompletion contrib/stgit-completion.bash ${PN}
+}
+
+src_test() {
+ export PATH=/usr/libexec/git-core/:$PATH
+ emake -j1 test
+}