summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-02-10 21:35:46 +0000
committerUlrich Müller <ulm@gentoo.org>2011-02-10 21:35:46 +0000
commitbd88981ddb9e0dbcdfb0e5523ef8c75f3a326362 (patch)
tree95d32245cab2ab6e9099c8c0b8126226448e258d /dev-vcs/rapidsvn/rapidsvn-0.12.0.ebuild
parentMove package from dev-util to dev-vcs, bug 56967. (diff)
downloadgentoo-2-bd88981ddb9e0dbcdfb0e5523ef8c75f3a326362.tar.gz
gentoo-2-bd88981ddb9e0dbcdfb0e5523ef8c75f3a326362.tar.bz2
gentoo-2-bd88981ddb9e0dbcdfb0e5523ef8c75f3a326362.zip
Move package from dev-util to dev-vcs, bug 56967.
(Portage version: 2.1.9.39/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-vcs/rapidsvn/rapidsvn-0.12.0.ebuild')
-rw-r--r--dev-vcs/rapidsvn/rapidsvn-0.12.0.ebuild112
1 files changed, 112 insertions, 0 deletions
diff --git a/dev-vcs/rapidsvn/rapidsvn-0.12.0.ebuild b/dev-vcs/rapidsvn/rapidsvn-0.12.0.ebuild
new file mode 100644
index 000000000000..ea85186cb9f8
--- /dev/null
+++ b/dev-vcs/rapidsvn/rapidsvn-0.12.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/rapidsvn/rapidsvn-0.12.0.ebuild,v 1.1 2011/02/10 21:35:46 ulm Exp $
+
+EAPI="2"
+
+WANT_AUTOCONF="2.5"
+WX_GTK_VER=2.8
+inherit versionator confutils libtool autotools wxwidgets flag-o-matic fdo-mime
+
+MY_PV=$(get_version_component_range 1-2)
+MY_REL="1"
+
+DESCRIPTION="Cross-platform GUI front-end for the Subversion revision system."
+HOMEPAGE="http://rapidsvn.tigris.org/"
+SRC_URI="http://www.rapidsvn.org/download/release/${MY_PV}/${P}-${MY_REL}.tar.gz"
+LICENSE="GPL-2 LGPL-2.1 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+COMMON_DEP=">=dev-vcs/subversion-1.5.0
+ x11-libs/wxGTK:2.8[X]
+ >=dev-libs/apr-1.2.10
+ >=dev-libs/apr-util-1.2.10"
+
+DEPEND="${COMMON_DEP}
+ doc? ( dev-libs/libxslt
+ app-text/docbook-sgml-utils
+ app-doc/doxygen
+ app-text/docbook-xsl-stylesheets )"
+
+RDEPEND="${COMMON_DEP}"
+
+RESTRICT=""
+
+S="${WORKDIR}/${P}-${MY_REL}"
+
+pkg_setup() {
+ einfo "Checking for subversion compiled with WebDAV support..."
+ confutils_require_built_with_any \
+ dev-vcs/subversion webdav-serf webdav-neon
+ einfo "Found WebDAV support; continuing..."
+
+ # if you compiled subversion without (the) apache2 (flag) and with the
+ # berkdb flag, you may get an error that it can't find the lib db4
+ # Note: this should be fixed in rapidsvn 0.9.3 and later
+
+ # check for the proper wxGTK support
+ need-wxwidgets unicode
+}
+
+src_prepare() {
+ # Apparently we still need the --as-needed link patch...
+ #export EPATCH_OPTS="-F3 -l"
+ epatch "${FILESDIR}/${PN}-svncpp_link.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ local apr_suffix=""
+
+ if has_version ">dev-libs/apr-util-1"; then
+ apr_suffix="-1"
+ fi
+
+ if use doc; then
+ myconf="--with-manpage=yes"
+ else
+ myconf="--without-xsltproc --with-manpage=no \
+ --without-doxygen --without-dot"
+ fi
+
+ myconf="${myconf} --with-wx-config=${WX_CONFIG}"
+
+ append-flags $( /usr/bin/apr${apr_suffix}-config --cppflags )
+
+ econf --with-svn-lib=/usr/$(get_libdir) \
+ --with-svn-include=/usr/include \
+ --with-apr-config="/usr/bin/apr${apr_suffix}-config" \
+ --with-apu-config="/usr/bin/apu${apr_suffix}-config" \
+ ${myconf} || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ doicon src/res/rapidsvn.ico
+ make_desktop_entry rapidsvn "RapidSVN ${PV}" \
+ "/usr/share/pixmaps/rapidsvn.ico" \
+ "RevisionControl;Development"
+
+ dodoc HACKING.txt TRANSLATIONS
+
+ if use doc ; then
+ dodoc AUTHORS CHANGES NEWS README
+ dohtml "${S}"/doc/svncpp/html/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}