summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Duft <mduft@gentoo.org>2009-11-03 17:09:00 +0000
committerMarkus Duft <mduft@gentoo.org>2009-11-03 17:09:00 +0000
commitffecec4c0a986133cc047a767c118e487d849da9 (patch)
treef9a91e1e552f60c15acea98618954c4101d2a5f3 /dev-util
parents390 stable wrt #279842 (diff)
downloadgentoo-2-ffecec4c0a986133cc047a767c118e487d849da9.tar.gz
gentoo-2-ffecec4c0a986133cc047a767c118e487d849da9.tar.bz2
gentoo-2-ffecec4c0a986133cc047a767c118e487d849da9.zip
added live svn ebuild for upcoming confix-2.2
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/confix/ChangeLog8
-rw-r--r--dev-util/confix/confix-9999.ebuild58
-rw-r--r--dev-util/confix/files/2.2.0/exeext.patch20
-rw-r--r--dev-util/confix/files/2.2.0/ext-ac-archive.patch35
4 files changed, 120 insertions, 1 deletions
diff --git a/dev-util/confix/ChangeLog b/dev-util/confix/ChangeLog
index 6c1f98600912..b0f9a5535d53 100644
--- a/dev-util/confix/ChangeLog
+++ b/dev-util/confix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/confix
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/ChangeLog,v 1.10 2009/10/16 08:18:00 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/ChangeLog,v 1.11 2009/11/03 17:08:59 mduft Exp $
+
+*confix-9999 (03 Nov 2009)
+
+ 03 Nov 2009; Markus Duft <mduft@gentoo.org> +files/2.2.0/exeext.patch,
+ +confix-9999.ebuild, +files/2.2.0/ext-ac-archive.patch:
+ added live ebuild for new confix-2.2
16 Oct 2009; Michael Haubenwallner <haubi@gentoo.org>
confix-2.1.0-r3.ebuild:
diff --git a/dev-util/confix/confix-9999.ebuild b/dev-util/confix/confix-9999.ebuild
new file mode 100644
index 000000000000..ed40c4f5b255
--- /dev/null
+++ b/dev-util/confix/confix-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/confix-9999.ebuild,v 1.1 2009/11/03 17:08:59 mduft Exp $
+
+EAPI=2
+
+inherit distutils subversion
+
+DESCRIPTION="Confix: A Build Tool on Top of GNU Automake"
+HOMEPAGE="http://confix.sourceforge.net"
+
+ESVN_REPO_URI="https://confix.svn.sourceforge.net/svnroot/confix/confix/trunk"
+ESVN_PROJECT="${PN}"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}
+ sys-devel/automake
+ sys-devel/libtool
+ sys-devel/autoconf-archive
+ dev-util/confix-wrapper
+"
+
+PYTHON_MODNAME="libconfix tests"
+
+src_prepare() {
+ # find jni-include dirs on hpux.
+ epatch "${FILESDIR}"/2.1.0/jni-hpux.patch
+ # hack to ignore duplicate files in rescan
+# does not apply to trunk anymore
+# epatch "${FILESDIR}"/2.1.0/CALL_RESCAN_HACK.patch
+ # add .exe extension to TESTS
+ epatch "${FILESDIR}"/2.2.0/exeext.patch
+ # use external autoconf archive
+ epatch "${FILESDIR}"/2.2.0/ext-ac-archive.patch
+ # enable SET_FILE_PROPERTIES(file, { 'PRIVATE_CINCLUDE', 1 })
+# does not apply to trunk anymore
+# epatch "${FILESDIR}"/2.1.0/private-headers.patch
+ # enable fast installation rules.
+# does not apply to trunk anymore
+# epatch "${FILESDIR}"/2.1.0/fast-install.patch
+
+ # need to store repos in exact versioned share/confix-PV/repo
+ sed -i -e "s,'confix2','confix-${PV}'," \
+ libconfix/plugins/automake/repo_automake.py \
+ libconfix/core/machinery/repo.py \
+ || die "cannot adjust repo dir"
+
+ # adjust version-printing to have same version as share/confix-PV/repo,
+ # to ease revdep-rebuild-alike scripts for rebuilding confix-packages.
+ sed -i -e "/^CONFIX_VERSION[ ]*=/s,.*,CONFIX_VERSION = '${PV}'," \
+ libconfix/core/utils/const.py \
+ || die "cannot adjust confix version"
+}
diff --git a/dev-util/confix/files/2.2.0/exeext.patch b/dev-util/confix/files/2.2.0/exeext.patch
new file mode 100644
index 000000000000..98576f5c9f8b
--- /dev/null
+++ b/dev-util/confix/files/2.2.0/exeext.patch
@@ -0,0 +1,20 @@
+diff -ru confix-9999.orig/libconfix/plugins/automake/makefile_am.py confix-9999/libconfix/plugins/automake/makefile_am.py
+--- confix-9999.orig/libconfix/plugins/automake/makefile_am.py 2009-10-30 13:20:42.106291175 +0100
++++ confix-9999/libconfix/plugins/automake/makefile_am.py 2009-10-30 13:23:39.562354663 +0100
+@@ -472,7 +472,15 @@
+
+ # register automatic tests and set their environment
+
+- tests = self.dir_primary('check', 'PROGRAMS') + \
++ test_tmp = self.dir_primary('check', 'PROGRAMS')
++ count = 0
++ for prog in test_tmp:
++ prog += "$(EXEEXT)"
++ test_tmp[count] = prog
++ count += 1
++ pass
++
++ tests = test_tmp + \
+ self.dir_primary('check', 'SCRIPTS')
+ if len(tests):
+ lines.extend(makefile.List(name='TESTS', values=tests, mitigate=True).lines())
diff --git a/dev-util/confix/files/2.2.0/ext-ac-archive.patch b/dev-util/confix/files/2.2.0/ext-ac-archive.patch
new file mode 100644
index 000000000000..32122c95bfe2
--- /dev/null
+++ b/dev-util/confix/files/2.2.0/ext-ac-archive.patch
@@ -0,0 +1,35 @@
+diff -ru confix-9999.orig/libconfix/plugins/automake/bootstrap.py confix-9999/libconfix/plugins/automake/bootstrap.py
+--- confix-9999.orig/libconfix/plugins/automake/bootstrap.py 2009-10-30 13:25:27.962172020 +0100
++++ confix-9999/libconfix/plugins/automake/bootstrap.py 2009-10-30 13:27:14.780605001 +0100
+@@ -16,7 +16,7 @@
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+ # USA
+
+-import autoconf_archive
++#import autoconf_archive
+ import kde_hack
+
+ from libconfix.core.utils.error import Error
+@@ -29,7 +29,7 @@
+
+ def bootstrap(packageroot, use_kde_hack, argv0, path=None):
+ aclocal_incdirs = []
+- aclocal_incdirs.append(autoconf_archive.include_path(argv0))
++ #aclocal_incdirs.append(autoconf_archive.include_path(argv0))
+
+ # if package's configure.ac looks like using libtool, then we
+ # assume that the package must be libtoolize'd.
+diff -ru confix-9999.orig/setup.py confix-9999/setup.py
+--- confix-9999.orig/setup.py 2009-10-30 13:25:27.965360137 +0100
++++ confix-9999/setup.py 2009-10-30 13:26:47.822129311 +0100
+@@ -41,8 +41,8 @@
+ return result
+
+ datafiles = []
+-datafiles.extend(recdir('share/confix/autoconf-archive/m4src', '.m4', []))
+-datafiles.extend(recdir('share/confix/autoconf-archive/htmldoc', '.html', []))
++#datafiles.extend(recdir('share/confix/autoconf-archive/m4src', '.m4', []))
++#datafiles.extend(recdir('share/confix/autoconf-archive/htmldoc', '.html', []))
+
+ # scripts to put in the auxdir.
+ datafiles.extend([('share/confix/kde-hack',