summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 23:38:20 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 23:38:20 +0000
commit7bd5641440dd38315c549bf62f960f47b4f51a2c (patch)
treee4da60047c0ece4bf1b2ff5c022ed28d4927f56a /dev-util
parentNew version for GNOME 2.28. (diff)
downloadgentoo-2-7bd5641440dd38315c549bf62f960f47b4f51a2c.tar.gz
gentoo-2-7bd5641440dd38315c549bf62f960f47b4f51a2c.tar.bz2
gentoo-2-7bd5641440dd38315c549bf62f960f47b4f51a2c.zip
New version for GNOME 2.28.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/anjuta/ChangeLog9
-rw-r--r--dev-util/anjuta/anjuta-2.28.1.0.ebuild110
-rw-r--r--dev-util/anjuta/files/anjuta-2.28.1.0-debug-mode.patch26
-rw-r--r--dev-util/anjuta/files/anjuta-2.28.1.0-symbol-db-optional.patch89
4 files changed, 233 insertions, 1 deletions
diff --git a/dev-util/anjuta/ChangeLog b/dev-util/anjuta/ChangeLog
index 4dc7b1b687fe..95502893eec3 100644
--- a/dev-util/anjuta/ChangeLog
+++ b/dev-util/anjuta/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/anjuta
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.101 2009/10/25 17:37:49 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.102 2009/10/29 23:38:19 eva Exp $
+
+*anjuta-2.28.1.0 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +anjuta-2.28.1.0.ebuild, +files/anjuta-2.28.1.0-debug-mode.patch,
+ +files/anjuta-2.28.1.0-symbol-db-optional.patch:
+ New version for GNOME 2.28.
25 Oct 2009; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove welp from metadata.xml (#141007)
diff --git a/dev-util/anjuta/anjuta-2.28.1.0.ebuild b/dev-util/anjuta/anjuta-2.28.1.0.ebuild
new file mode 100644
index 000000000000..bef97bc26cf2
--- /dev/null
+++ b/dev-util/anjuta/anjuta-2.28.1.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-2.28.1.0.ebuild,v 1.1 2009/10/29 23:38:19 eva Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2 flag-o-matic
+
+DESCRIPTION="A versatile IDE for GNOME"
+HOMEPAGE="http://www.anjuta.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="debug devhelp doc glade sourceview subversion +symbol-db test"
+
+# FIXME: Anjuta has some CRITICAL and WARNINGS messages, that would be nice to fix them and/or report on upstream
+RDEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/gtk+-2.14
+ >=gnome-base/orbit-2.6
+ >=gnome-base/gconf-2.12
+ >=x11-libs/vte-0.13.1
+ >=dev-libs/libxml2-2.4.23
+ >=dev-libs/gdl-2.27.1
+ >=app-text/gnome-doc-utils-0.3.2
+ >=x11-libs/libwnck-2.12
+ >=dev-libs/libunique-1
+ symbol-db? (
+ gnome-extra/libgda:4
+ dev-util/ctags )
+
+ dev-libs/libxslt
+ >=dev-lang/perl-5
+ dev-perl/Locale-gettext
+ sys-devel/autogen
+
+ devhelp? (
+ >=dev-util/devhelp-0.22
+ >=net-libs/webkit-gtk-1 )
+ glade? ( >=dev-util/glade-3.6.0 )
+ sourceview? (
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libgnome-2.14
+ >=x11-libs/gtksourceview-2.4 )
+ subversion? (
+ >=dev-util/subversion-1.5.0
+ >=net-misc/neon-0.28.2
+ >=dev-libs/apr-1
+ >=dev-libs/apr-util-1 )"
+DEPEND="${RDEPEND}
+ !!dev-libs/gnome-build
+ >=sys-devel/gettext-0.14
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.20
+ >=app-text/scrollkeeper-0.3.14-r2
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.4 )
+ test? (
+ ~app-text/docbook-xml-dtd-4.1.2
+ ~app-text/docbook-xml-dtd-4.5 )"
+
+DOCS="AUTHORS ChangeLog FUTURE MAINTAINERS NEWS README ROADMAP THANKS TODO"
+
+pkg_setup() {
+ if ! use symbol-db; then
+ elog "You disabled symbol-db which will disallow using projects."
+ fi
+
+ G2CONF="${G2CONF}
+ --docdir=/usr/share/doc/${PF}
+ $(use_enable debug)
+ $(use_enable devhelp plugin-devhelp)
+ $(use_enable glade plugin-glade)
+ $(use_enable sourceview plugin-sourceview)
+ $(use_enable subversion plugin-subversion)
+ $(use_enable symbol-db plugin-symbol-db)"
+
+ # Conflics wiht -pg in a plugin, bug #266777
+ filter-flags -fomit-frame-pointer
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Make Symbol DB optional
+ epatch "${FILESDIR}/${PN}-2.28.1.0-symbol-db-optional.patch"
+ # Do not force the debugging mode when --disable-debug
+ # is given on the command line.
+ epatch "${FILESDIR}/${P}-debug-mode.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ # Anjuta uses a custom rule to install DOCS, get rid of it
+ gnome2_src_install
+ rm -rf "${D}"/usr/share/doc/${PN} || die "rm failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ebeep 1
+ elog ""
+ elog "Some project templates may require additional development"
+ elog "libraries to function correctly. It goes beyond the scope"
+ elog "of this ebuild to provide them."
+ epause 5
+}
diff --git a/dev-util/anjuta/files/anjuta-2.28.1.0-debug-mode.patch b/dev-util/anjuta/files/anjuta-2.28.1.0-debug-mode.patch
new file mode 100644
index 000000000000..ce8f0bb773fd
--- /dev/null
+++ b/dev-util/anjuta/files/anjuta-2.28.1.0-debug-mode.patch
@@ -0,0 +1,26 @@
+From: Romain Perier <mrpouet@gentoo.org>
+Date: Mon, 26 Oct 2009 11:12:22 +0100
+Subject: [PATCH] Fix the forced debugging mode even if --disable-debug is given on the command line
+
+---
+ configure.in | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 5f4c4bc..611faaa 100644
+--- a/configure.in
++++ b/configure.in
+@@ -80,7 +80,9 @@ AM_CFLAGS="$AM_CFLAGS $WARN_CFLAGS"
+ dnl Enable debugging mode
+ AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],[Enable debug messages]),
+- AM_CFLAGS="$AM_CFLAGS -DDEBUG")
++ [if test "x$enableval" = "xyes"; then
++ AM_CFLAGS="$AM_CFLAGS -DDEBUG"
++ fi])
+ AC_SUBST(AM_CFLAGS)
+
+ ANJUTA_LDFLAGS="-no-undefined"
+--
+1.6.5.1
+
diff --git a/dev-util/anjuta/files/anjuta-2.28.1.0-symbol-db-optional.patch b/dev-util/anjuta/files/anjuta-2.28.1.0-symbol-db-optional.patch
new file mode 100644
index 000000000000..1a7e8aa8f6e4
--- /dev/null
+++ b/dev-util/anjuta/files/anjuta-2.28.1.0-symbol-db-optional.patch
@@ -0,0 +1,89 @@
+From 62ed030d66574884c7d716c436e9e20ce6da829b Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 25 Oct 2009 20:58:15 +0100
+Subject: [PATCH] Allow disabling symbol-db plugin
+
+---
+ configure.in | 32 ++++++++++++++++++++++++++++++--
+ plugins/symbol-db/Makefile.am | 4 ++++
+ 2 files changed, 34 insertions(+), 2 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 197cafd..e7c5445 100644
+--- a/configure.in
++++ b/configure.in
+@@ -230,6 +230,29 @@ fi
+
+ AM_CONDITIONAL(HAVE_PLUGIN_GLADE, [test x$gladeui_found = xyes])
+
++dnl Plugin Symbol DB
++dnl -------------------------------------------------------------
++
++AC_ARG_ENABLE(plugin-symbol-db,
++ AC_HELP_STRING([--disable-plugin-symbol-db],[libgda-4 based symbol DB]),
++ [ if test "$enableval" = "yes"; then
++ user_disabled_symbol_db=1
++ fi ],
++ [ user_disabled_symbol_db=0 ])
++
++AC_MSG_CHECKING(if symbol db plugin is disabled)
++if test "$user_disabled_symbol_db" = 1; then
++ AC_MSG_RESULT(no)
++ symbol_db="yes"
++
++ PKG_CHECK_MODULES(PLUGIN_SYMBOL_DB,
++ [libgda-4.0 >= $GDA_REQUIRED])
++else
++ AC_MSG_RESULT(yes)
++ symbol_db="no"
++fi
++AM_CONDITIONAL(HAVE_PLUGIN_SYMBOL_DB, [test x$symbol_db = xyes])
++
+ dnl Build gtksourceview plugin only on gnome 2.14 and gtk 2.10
+ dnl -------------------------------------------------------------
+
+@@ -255,8 +278,6 @@ fi
+
+ AM_CONDITIONAL(HAVE_PLUGIN_SOURCEVIEW, [test x$sourceview = xyes])
+
+-PKG_CHECK_MODULES(PLUGIN_SYMBOL_DB,
+- [libgda-4.0 >= $GDA_REQUIRED])
+
+ dnl Setup Anjuta Library flags
+ dnl --------------------------
+@@ -862,6 +883,13 @@ else
+ echo " Requires devhelp >= 0.22"
+ fi
+
++if [ test x$symbol_db = xyes ]; then
++ echo "Building Symbol DB plugin: .............................YES"
++else
++ echo "Building Symbol DB plugin: .............................NO"
++ echo " Requires libgda-4"
++fi
++
+ if [ test x$sourceview = xyes ]; then
+ echo "Building GtkSourceView based editor: ...................YES"
+ else
+diff --git a/plugins/symbol-db/Makefile.am b/plugins/symbol-db/Makefile.am
+index 9b94b6d..07aad96 100644
+--- a/plugins/symbol-db/Makefile.am
++++ b/plugins/symbol-db/Makefile.am
+@@ -1,3 +1,5 @@
++if HAVE_PLUGIN_SYMBOL_DB
++
+ SUBDIRS = images benchmark anjuta-tags test-queries
+
+ symbol_db_datadir = $(anjuta_data_dir)
+@@ -82,6 +84,8 @@ libanjuta_symbol_db_la_LIBADD = \
+ prefs_ui_files = anjuta-symbol-db.ui
+ include $(top_srcdir)/scripts/build-schemas.mk
+
++endif
++
+ EXTRA_DIST = \
+ $(plugin_in_files) \
+ $(symbol_db_plugin_DATA) \
+--
+1.6.5.rc1
+