summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2010-04-17 06:01:03 +0000
committerSerkan Kaba <serkan@gentoo.org>2010-04-17 06:01:03 +0000
commit3c1c9ec927d68101429f34eed939e9d58f3075c8 (patch)
treea45d9083f667605fc072ffa51222ca7350495b04 /dev-util
parentFixed eclass usage. Remove call to changelog task to fix bug #315403 (diff)
downloadgentoo-2-3c1c9ec927d68101429f34eed939e9d58f3075c8.tar.gz
gentoo-2-3c1c9ec927d68101429f34eed939e9d58f3075c8.tar.bz2
gentoo-2-3c1c9ec927d68101429f34eed939e9d58f3075c8.zip
Version bump. Fixes bug #295495. Thanks to Marshall Banana <JackyRyan@gmx.net> for the report and the ebuild.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/weka/ChangeLog11
-rw-r--r--dev-util/weka/files/weka-3.6.2-build.xml.patch23
-rw-r--r--dev-util/weka/weka-3.6.2.ebuild68
3 files changed, 100 insertions, 2 deletions
diff --git a/dev-util/weka/ChangeLog b/dev-util/weka/ChangeLog
index 6508a1220193..783405969309 100644
--- a/dev-util/weka/ChangeLog
+++ b/dev-util/weka/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/weka
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/weka/ChangeLog,v 1.33 2009/03/29 16:34:28 serkan Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/weka/ChangeLog,v 1.34 2010/04/17 06:01:02 serkan Exp $
+
+*weka-3.6.2 (17 Apr 2010)
+
+ 17 Apr 2010; Serkan Kaba <serkan@gentoo.org> +weka-3.6.2.ebuild,
+ +files/weka-3.6.2-build.xml.patch:
+ Version bump. Fixes bug #295495. Thanks to Marshall Banana
+ <JackyRyan@gmx.net> for the report and the ebuild.
29 Mar 2009; Serkan Kaba <serkan@gentoo.org>
files/weka-3.6.0-build.xml.patch:
diff --git a/dev-util/weka/files/weka-3.6.2-build.xml.patch b/dev-util/weka/files/weka-3.6.2-build.xml.patch
new file mode 100644
index 000000000000..29310866649c
--- /dev/null
+++ b/dev-util/weka/files/weka-3.6.2-build.xml.patch
@@ -0,0 +1,23 @@
+--- build.xml 2010-04-17 08:12:29.000000000 +0300
++++ build.xml.fixed 2010-04-17 08:37:58.000000000 +0300
+@@ -90,11 +90,6 @@
+ </copy>
+ <rmic base="${build}/classes"
+ classname="weka.experiment.RemoteEngine"/>
+- <unzip src="${lib}/java-cup.jar" dest="${build}/classes">
+- <patternset>
+- <include name="java_cup/runtime/**/*"/>
+- </patternset>
+- </unzip>
+ </target>
+
+ <!-- Make the javadocs -->
+@@ -139,7 +134,7 @@
+ </target>
+
+ <!-- compile the testcases -->
+- <target name="compile_tests" depends="init_tests, compile"
++ <target name="compile_tests" depends="init_tests"
+ description="Compile unit tests into build/testcases">
+ <javac srcdir="${src-test}"
+ fork="yes" memoryMaximumSize="${javac_max_memory}"
diff --git a/dev-util/weka/weka-3.6.2.ebuild b/dev-util/weka/weka-3.6.2.ebuild
new file mode 100644
index 000000000000..33a29462310f
--- /dev/null
+++ b/dev-util/weka/weka-3.6.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/weka/weka-3.6.2.ebuild,v 1.1 2010/04/17 06:01:02 serkan Exp $
+
+EAPI="2"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2 versionator
+
+MY_P="${PN}-$(replace_all_version_separators '-')"
+DESCRIPTION="A Java data mining package"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+HOMEPAGE="http://www.cs.waikato.ac.nz/ml/weka/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ >=dev-java/javacup-0.11a_beta20060608:0"
+RDEPEND=">=virtual/jre-1.5
+ >=dev-java/javacup-0.11a_beta20060608:0"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+EANT_BUILD_TARGET="exejar"
+EANT_DOC_TARGET="docs"
+JAVA_ANT_IGNORE_SYSTEM_CLASSES="true"
+
+weka_get_max_memory() {
+ if use amd64; then
+ echo 512m
+ else
+ echo 256m
+ fi
+}
+
+java_prepare() {
+ unzip -qq "${PN}-src.jar" -d . || die "Failed to unpack the source"
+ rm -v *.jar lib/*.jar || die
+ rm -rf doc || die
+ java-pkg_jar-from --into lib javacup
+ epatch "${FILESDIR}"/${P}-build.xml.patch
+ sed -i -e "s/256m/$(weka_get_max_memory)/g" build.xml || die
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ java-pkg_dolauncher weka --main "${PN}.gui.GUIChooser"
+
+ # Really need a virtual to list all available drivers and pull the ones
+ # instaled
+ java-pkg_register-optional-dependency hsqldb,jdbc-mysql,mckoi-1
+
+ use source && java-pkg_dosrc src/main/java/weka/
+
+ dodoc README || die
+ if use doc; then
+ java-pkg_dojavadoc doc/
+ insinto /usr/share/doc/${PF}
+ doins WekaManual.pdf || die
+ fi
+
+ dodir /usr/share/${PN}/data/
+ insinto /usr/share/${PN}/data/
+ doins data/*
+}