summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-01 05:19:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-01 05:19:54 +0000
commit2cd281190f5633e6ba459a511121bff1ba49d093 (patch)
tree4450cd3f0778fd907a978f8952afa48f9bc1532e /dev-util
parentclean up ebuild (diff)
downloadgentoo-2-2cd281190f5633e6ba459a511121bff1ba49d093.tar.gz
gentoo-2-2cd281190f5633e6ba459a511121bff1ba49d093.tar.bz2
gentoo-2-2cd281190f5633e6ba459a511121bff1ba49d093.zip
clean up and make it better
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git-pasky/files/Makefile.patch6
-rw-r--r--dev-util/git-pasky/git-pasky-0.7.ebuild21
2 files changed, 14 insertions, 13 deletions
diff --git a/dev-util/git-pasky/files/Makefile.patch b/dev-util/git-pasky/files/Makefile.patch
index 039778fb3f22..b4b32c7a740e 100644
--- a/dev-util/git-pasky/files/Makefile.patch
+++ b/dev-util/git-pasky/files/Makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2005-04-22 02:04:53.000000000 +0100
-+++ Makefile 2005-04-22 17:15:05.722557768 +0100
+--- Makefile
++++ Makefile
@@ -12,10 +12,8 @@
# BREAK YOUR LOCAL DIFFS! show-diff and anything using it will likely randomly
# break unless your underlying filesystem supports those sub-second times
@@ -8,7 +8,7 @@
-
# Should be changed to /usr/local
-prefix=$(HOME)
-+prefix=$(DESTDIR)/usr/
++prefix=/usr/
bindir=$(prefix)/bin
diff --git a/dev-util/git-pasky/git-pasky-0.7.ebuild b/dev-util/git-pasky/git-pasky-0.7.ebuild
index 8f8b23745f03..3564aceabbb7 100644
--- a/dev-util/git-pasky/git-pasky-0.7.ebuild
+++ b/dev-util/git-pasky/git-pasky-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git-pasky/git-pasky-0.7.ebuild,v 1.3 2005/04/29 13:49:48 r3pek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git-pasky/git-pasky-0.7.ebuild,v 1.4 2005/05/01 05:19:54 vapier Exp $
inherit eutils
@@ -14,21 +14,21 @@ KEYWORDS="~x86 ~amd64"
IUSE="mozsha1 ppcsha1"
DEPEND="dev-libs/openssl
- sys-libs/zlib
- !dev-util/git
- !dev-util/cogito"
+ sys-libs/zlib
+ !dev-util/git
+ !dev-util/cogito"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/Makefile.patch || die "epatch makefile failed"
- epatch ${FILESDIR}/commit-id.patch || die "epatch commit-id failed"
+ cd "${S}"
+ epatch "${FILESDIR}"/Makefile.patch
+ epatch "${FILESDIR}"/commit-id.patch
}
src_compile() {
- if use mozsha1; then
+ if use mozsha1 ; then
export MOZILLA_SHA1=yes
- elif use ppcsha1; then
+ elif use ppcsha1 ; then
export PPC_SHA1=yes
fi
@@ -36,7 +36,8 @@ src_compile() {
}
src_install() {
- einstall || die "einstall failed"
+ make install DESTDIR="${D}" || die "install failed"
+ dodoc README*
}
pkg_postinst() {