summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-02-15 17:15:58 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-02-15 17:15:58 +0000
commit19a6e3448c9b633504ee9f2fc490fda4651d3ec2 (patch)
tree8e16ffd7720ad12beccf6d2733af8e68bf422f8a /dev-util
parentFix depend on <gd-2.0.34, bug #165460 (diff)
downloadgentoo-2-19a6e3448c9b633504ee9f2fc490fda4651d3ec2.tar.gz
gentoo-2-19a6e3448c9b633504ee9f2fc490fda4651d3ec2.tar.bz2
gentoo-2-19a6e3448c9b633504ee9f2fc490fda4651d3ec2.zip
Adding pre-release versions of catalyst for further testing.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/ChangeLog10
-rw-r--r--dev-util/catalyst/catalyst-2.0.3_pre1.ebuild76
-rw-r--r--dev-util/catalyst/catalyst-2.0.3_pre2.ebuild76
-rw-r--r--dev-util/catalyst/digest-catalyst-2.0.3_pre13
-rw-r--r--dev-util/catalyst/digest-catalyst-2.0.3_pre23
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0.3_pre13
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0.3_pre23
7 files changed, 173 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 93cb453a2ac2..a031ecc46cb2 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/catalyst
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.161 2007/02/15 17:09:14 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.162 2007/02/15 17:15:58 wolf31o2 Exp $
+
+*catalyst-2.0.3_pre2 (15 Feb 2007)
+*catalyst-2.0.3_pre1 (15 Feb 2007)
+
+ 15 Feb 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ +digest-catalyst-2.0.3_pre1, +digest-catalyst-2.0.3_pre2,
+ +catalyst-2.0.3_pre1.ebuild, +catalyst-2.0.3_pre2.ebuild:
+ Adding pre-release versions of catalyst for further testing.
15 Feb 2007; Chris Gianelloni <wolf31o2@gentoo.org> -catalyst-2.0.ebuild,
-catalyst-2.0.1.ebuild:
diff --git a/dev-util/catalyst/catalyst-2.0.3_pre1.ebuild b/dev-util/catalyst/catalyst-2.0.3_pre1.ebuild
new file mode 100644
index 000000000000..2440ca97d7cd
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.3_pre1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.3_pre1.ebuild,v 1.1 2007/02/15 17:15:58 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux official release metatool"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ccache cdr"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ amd64? ( sys-apps/setarch )
+ ppc64? ( sys-apps/setarch )
+ ccache? ( dev-util/ccache )
+ cdr? (
+ virtual/cdrtools
+ ia64? ( sys-fs/dosfstools )
+ app-misc/zisofs-tools
+ >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_install() {
+ insinto /usr/lib/${PN}/arch
+ doins arch/* || die "copying arch/*"
+ insinto /usr/lib/${PN}/modules
+ doins modules/* || die "copying modules/*"
+ insinto /usr/lib/${PN}/livecd/cdtar
+ doins livecd/cdtar/* || die "copying cdtar/*"
+ insinto /usr/lib/${PN}/livecd/files
+ doins livecd/files/* || die "copying files/*"
+ for x in targets/*; do
+ exeinto /usr/lib/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ exeinto /usr/lib/${PN}
+ doexe catalyst || die "copying catalyst"
+ dodir /usr/bin
+ dosym /usr/lib/${PN}/catalyst /usr/bin/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ DOCDESTTREE="." dohtml -A spec,msg,example -r examples files
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/catalyst-2.0.3_pre2.ebuild b/dev-util/catalyst/catalyst-2.0.3_pre2.ebuild
new file mode 100644
index 000000000000..2c3c63204cdd
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.3_pre2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.3_pre2.ebuild,v 1.1 2007/02/15 17:15:58 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux official release metatool"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ccache cdr"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ amd64? ( sys-apps/setarch )
+ ppc64? ( sys-apps/setarch )
+ ccache? ( dev-util/ccache )
+ cdr? (
+ virtual/cdrtools
+ ia64? ( sys-fs/dosfstools )
+ app-misc/zisofs-tools
+ >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_install() {
+ insinto /usr/lib/${PN}/arch
+ doins arch/* || die "copying arch/*"
+ insinto /usr/lib/${PN}/modules
+ doins modules/* || die "copying modules/*"
+ insinto /usr/lib/${PN}/livecd/cdtar
+ doins livecd/cdtar/* || die "copying cdtar/*"
+ insinto /usr/lib/${PN}/livecd/files
+ doins livecd/files/* || die "copying files/*"
+ for x in targets/*; do
+ exeinto /usr/lib/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ exeinto /usr/lib/${PN}
+ doexe catalyst || die "copying catalyst"
+ dodir /usr/bin
+ dosym /usr/lib/${PN}/catalyst /usr/bin/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ DOCDESTTREE="." dohtml -A spec,msg,example -r examples files
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/digest-catalyst-2.0.3_pre1 b/dev-util/catalyst/digest-catalyst-2.0.3_pre1
new file mode 100644
index 000000000000..0be360f40472
--- /dev/null
+++ b/dev-util/catalyst/digest-catalyst-2.0.3_pre1
@@ -0,0 +1,3 @@
+MD5 47ea0f5920fa0ce37c1733ffeb8d995e catalyst-2.0.3_pre1.tar.bz2 783416
+RMD160 1ca91c5d73fd37750a11fb88ff93c43d22152e6b catalyst-2.0.3_pre1.tar.bz2 783416
+SHA256 5e9f9d4513ed9ecbcdf4099b629cf9960cdd92dada7876053861b3c91bcb690b catalyst-2.0.3_pre1.tar.bz2 783416
diff --git a/dev-util/catalyst/digest-catalyst-2.0.3_pre2 b/dev-util/catalyst/digest-catalyst-2.0.3_pre2
new file mode 100644
index 000000000000..9ec148e5b8ad
--- /dev/null
+++ b/dev-util/catalyst/digest-catalyst-2.0.3_pre2
@@ -0,0 +1,3 @@
+MD5 3fee23ceccffc5e98fb6c39162c5b3fa catalyst-2.0.3_pre2.tar.bz2 783205
+RMD160 77fa1e09b4cae21611626a11c8da09c237ab9440 catalyst-2.0.3_pre2.tar.bz2 783205
+SHA256 481f1b04cb64930a2395d39fa67c9b0389e6ee1053c931428962ea7cbc4eeab7 catalyst-2.0.3_pre2.tar.bz2 783205
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0.3_pre1 b/dev-util/catalyst/files/digest-catalyst-2.0.3_pre1
new file mode 100644
index 000000000000..0be360f40472
--- /dev/null
+++ b/dev-util/catalyst/files/digest-catalyst-2.0.3_pre1
@@ -0,0 +1,3 @@
+MD5 47ea0f5920fa0ce37c1733ffeb8d995e catalyst-2.0.3_pre1.tar.bz2 783416
+RMD160 1ca91c5d73fd37750a11fb88ff93c43d22152e6b catalyst-2.0.3_pre1.tar.bz2 783416
+SHA256 5e9f9d4513ed9ecbcdf4099b629cf9960cdd92dada7876053861b3c91bcb690b catalyst-2.0.3_pre1.tar.bz2 783416
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0.3_pre2 b/dev-util/catalyst/files/digest-catalyst-2.0.3_pre2
new file mode 100644
index 000000000000..9ec148e5b8ad
--- /dev/null
+++ b/dev-util/catalyst/files/digest-catalyst-2.0.3_pre2
@@ -0,0 +1,3 @@
+MD5 3fee23ceccffc5e98fb6c39162c5b3fa catalyst-2.0.3_pre2.tar.bz2 783205
+RMD160 77fa1e09b4cae21611626a11c8da09c237ab9440 catalyst-2.0.3_pre2.tar.bz2 783205
+SHA256 481f1b04cb64930a2395d39fa67c9b0389e6ee1053c931428962ea7cbc4eeab7 catalyst-2.0.3_pre2.tar.bz2 783205