summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 12:45:09 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 12:45:09 +0000
commite27c43913c049681679b773f3dbb34ab43f6e209 (patch)
tree6667392b7a863994137178138537c6472535fa94 /dev-util/yacc
parentnew version .. no RC5, sorry (diff)
downloadgentoo-2-e27c43913c049681679b773f3dbb34ab43f6e209.tar.gz
gentoo-2-e27c43913c049681679b773f3dbb34ab43f6e209.tar.bz2
gentoo-2-e27c43913c049681679b773f3dbb34ab43f6e209.zip
A=-fix, try->die, tab-fixes, stylefixes, ...
Diffstat (limited to 'dev-util/yacc')
-rw-r--r--dev-util/yacc/yacc-1.9.1-r1.ebuild30
1 files changed, 12 insertions, 18 deletions
diff --git a/dev-util/yacc/yacc-1.9.1-r1.ebuild b/dev-util/yacc/yacc-1.9.1-r1.ebuild
index 901644f16f89..9451fa77a047 100644
--- a/dev-util/yacc/yacc-1.9.1-r1.ebuild
+++ b/dev-util/yacc/yacc-1.9.1-r1.ebuild
@@ -1,33 +1,27 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/yacc/yacc-1.9.1-r1.ebuild,v 1.5 2000/11/01 04:44:16 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/yacc/yacc-1.9.1-r1.ebuild,v 1.6 2001/11/10 12:45:09 hallski Exp $
-P=yacc-1.9.1
-A=${P}.tar.Z
S=${WORKDIR}/${P}
DESCRIPTION="Yacc"
-SRC_URI="ftp://metalab.unc.edu/pub/Linux/devel/compiler-tools/${A}"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/devel/compiler-tools/${P}.tar.Z"
DEPEND=">=sys-libs/glibc-2.1.3"
src_unpack () {
- unpack ${A}
- cd ${S}
- cp Makefile Makefile.orig
- sed -e "s:-O:${CFLAGS}:" Makefile.orig > Makefile
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O:${CFLAGS}:" Makefile.orig > Makefile
}
src_compile() {
- try make clean
- try make
+ make clean || die
+ make || die
}
src_install() {
- into /usr
- dobin yacc
- doman yacc.1
- dodoc 00README* ACKNOWLEDGEMENTS NEW_FEATURES NO_WARRANTY NOTES README*
+ into /usr
+ dobin yacc
+ doman yacc.1
+ dodoc 00README* ACKNOWLEDGEMENTS NEW_FEATURES NO_WARRANTY NOTES README*
}
-
-
-
-