summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-10-04 16:49:04 +0000
committerSven Wegener <swegener@gentoo.org>2008-10-04 16:49:04 +0000
commit38050a143f2641bb166a54783f5984f86f401f48 (patch)
tree85842fc22cf888a3d86a5ed1497f81e191d65107 /dev-util/systemtap
parentUpdated libcdraw block to <=media-libs/libcdraw-0.1.4 to fix bug 239282. Than... (diff)
downloadgentoo-2-38050a143f2641bb166a54783f5984f86f401f48.tar.gz
gentoo-2-38050a143f2641bb166a54783f5984f86f401f48.tar.bz2
gentoo-2-38050a143f2641bb166a54783f5984f86f401f48.zip
Snapshot bump, bug #238993.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc8 x86_64)
Diffstat (limited to 'dev-util/systemtap')
-rw-r--r--dev-util/systemtap/ChangeLog8
-rw-r--r--dev-util/systemtap/systemtap-0.7.1_pre20080830.ebuild7
-rw-r--r--dev-util/systemtap/systemtap-0.7.1_pre20081004.ebuild56
-rw-r--r--dev-util/systemtap/systemtap-0.7.ebuild7
4 files changed, 71 insertions, 7 deletions
diff --git a/dev-util/systemtap/ChangeLog b/dev-util/systemtap/ChangeLog
index ed8f854d73b1..13a9e208445a 100644
--- a/dev-util/systemtap/ChangeLog
+++ b/dev-util/systemtap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/systemtap
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/systemtap/ChangeLog,v 1.70 2008/09/04 10:44:41 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/systemtap/ChangeLog,v 1.71 2008/10/04 16:49:04 swegener Exp $
+
+*systemtap-0.7.1_pre20081004 (04 Oct 2008)
+
+ 04 Oct 2008; Sven Wegener <swegener@gentoo.org> systemtap-0.7.ebuild,
+ systemtap-0.7.1_pre20080830.ebuild, +systemtap-0.7.1_pre20081004.ebuild:
+ Snapshot bump, bug #238993.
*systemtap-0.7.1_pre20080830 (04 Sep 2008)
diff --git a/dev-util/systemtap/systemtap-0.7.1_pre20080830.ebuild b/dev-util/systemtap/systemtap-0.7.1_pre20080830.ebuild
index 30f9f1eab6bc..d7f7aeb7ffa4 100644
--- a/dev-util/systemtap/systemtap-0.7.1_pre20080830.ebuild
+++ b/dev-util/systemtap/systemtap-0.7.1_pre20080830.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/systemtap/systemtap-0.7.1_pre20080830.ebuild,v 1.1 2008/09/04 10:44:41 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/systemtap/systemtap-0.7.1_pre20080830.ebuild,v 1.2 2008/10/04 16:49:04 swegener Exp $
inherit linux-info eutils
@@ -8,8 +8,9 @@ DESCRIPTION="A linux trace/probe tool"
HOMEPAGE="http://sourceware.org/systemtap/"
if [[ ${PV} = *_pre* ]] # is this a snaphot?
then
- # see configure.ac to see the version of the snapshot
- SRC_URI="ftp://sources.redhat.com/pub/${PN}/snapshots/${PN}-${PV/*_pre/}.tar.bz2"
+ # see configure.ac to get the version of the snapshot
+ SRC_URI="ftp://sources.redhat.com/pub/${PN}/snapshots/${PN}-${PV/*_pre/}.tar.bz2
+ mirror://gentoo/${PN}-${PV/*_pre/}.tar.bz2" # upstream only keeps four snapshot distfiles around
S="${WORKDIR}"/src
else
SRC_URI="ftp://sources.redhat.com/pub/${PN}/releases/${P}.tar.gz"
diff --git a/dev-util/systemtap/systemtap-0.7.1_pre20081004.ebuild b/dev-util/systemtap/systemtap-0.7.1_pre20081004.ebuild
new file mode 100644
index 000000000000..858050bd8f4b
--- /dev/null
+++ b/dev-util/systemtap/systemtap-0.7.1_pre20081004.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/systemtap/systemtap-0.7.1_pre20081004.ebuild,v 1.1 2008/10/04 16:49:04 swegener Exp $
+
+inherit linux-info eutils
+
+DESCRIPTION="A linux trace/probe tool"
+HOMEPAGE="http://sourceware.org/systemtap/"
+if [[ ${PV} = *_pre* ]] # is this a snaphot?
+then
+ # see configure.ac to get the version of the snapshot
+ SRC_URI="ftp://sources.redhat.com/pub/${PN}/snapshots/${PN}-${PV/*_pre/}.tar.bz2
+ mirror://gentoo/${PN}-${PV/*_pre/}.tar.bz2" # upstream only keeps four snapshot distfiles around
+ S="${WORKDIR}"/src
+else
+ SRC_URI="ftp://sources.redhat.com/pub/${PN}/releases/${P}.tar.gz"
+ # use default S for releases
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="sqlite"
+
+DEPEND=">=dev-libs/elfutils-0.122
+ sys-libs/libcap
+ sqlite? ( =dev-db/sqlite-3* )"
+RDEPEND="${DEPEND}
+ virtual/linux-sources"
+
+CONFIG_CHECK="KPROBES ~RELAY ~DEBUG_FS"
+ERROR_KPROBES="${PN} requires support for KProbes Instrumentation (KPROBES) - this can be enabled in 'Instrumentation Support -> Kprobes'."
+ERROR_RELAY="${PN} works with support for user space relay support (RELAY) - this can be enabled in 'General setup -> Kernel->user space relay support (formerly relayfs)'."
+ERROR_DEBUG_FS="${PN} works best with support for Debug Filesystem (DEBUG_FS) - this can be enabled in 'Kernel hacking -> Debug Filesystem'."
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/systemtap-20080119-grsecurity.patch
+}
+
+src_compile() {
+ econf $(use_enable sqlite) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog HACKING NEWS README
+}
+
+pkg_postinst() {
+ elog "If you use a kernel patched with grsecurity (e.g. sys-kernel/hardened-sources)"
+ elog "then please append '-D HAVE_GRSECURITY' to your stap command line."
+}
diff --git a/dev-util/systemtap/systemtap-0.7.ebuild b/dev-util/systemtap/systemtap-0.7.ebuild
index b019ed9cb619..882c59f2036b 100644
--- a/dev-util/systemtap/systemtap-0.7.ebuild
+++ b/dev-util/systemtap/systemtap-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/systemtap/systemtap-0.7.ebuild,v 1.1 2008/07/26 15:20:59 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/systemtap/systemtap-0.7.ebuild,v 1.2 2008/10/04 16:49:04 swegener Exp $
inherit linux-info eutils
@@ -8,8 +8,9 @@ DESCRIPTION="A linux trace/probe tool"
HOMEPAGE="http://sourceware.org/systemtap/"
if [[ ${PV} = *_pre* ]] # is this a snaphot?
then
- # see configure.ac to see the version of the snapshot
- SRC_URI="ftp://sources.redhat.com/pub/${PN}/snapshots/${PN}-${PV/*_pre/}.tar.bz2"
+ # see configure.ac to get the version of the snapshot
+ SRC_URI="ftp://sources.redhat.com/pub/${PN}/snapshots/${PN}-${PV/*_pre/}.tar.bz2
+ mirror://gentoo/${PN}-${PV/*_pre/}.tar.bz2" # upstream only keeps four snapshot distfiles around
S="${WORKDIR}"/src
else
SRC_URI="ftp://sources.redhat.com/pub/${PN}/releases/${P}.tar.gz"