summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamon Conway <kabau@gentoo.org>2001-08-22 04:58:59 +0000
committerDamon Conway <kabau@gentoo.org>2001-08-22 04:58:59 +0000
commit089c2f5bf6509c7e09412b31a22de0d5f6c7f316 (patch)
treefa0785e73add0695c61fb0251e6f19e790692845 /dev-util/pccts
parentfixums, now installs stuff to /boot/grub, and in rc6 we'll configure GRUB (diff)
downloadgentoo-2-089c2f5bf6509c7e09412b31a22de0d5f6c7f316.tar.gz
gentoo-2-089c2f5bf6509c7e09412b31a22de0d5f6c7f316.tar.bz2
gentoo-2-089c2f5bf6509c7e09412b31a22de0d5f6c7f316.zip
Missed that ${A} did not exist in the ebuild file. Also, added the digest
and diff file for this package.
Diffstat (limited to 'dev-util/pccts')
-rw-r--r--dev-util/pccts/files/digest-pccts-1.33.24-r21
-rw-r--r--dev-util/pccts/files/pccts-1.33.24-r2-gentoo.diff49
-rw-r--r--dev-util/pccts/pccts-1.33.24-r2.ebuild5
3 files changed, 53 insertions, 2 deletions
diff --git a/dev-util/pccts/files/digest-pccts-1.33.24-r2 b/dev-util/pccts/files/digest-pccts-1.33.24-r2
new file mode 100644
index 000000000000..8323202acd81
--- /dev/null
+++ b/dev-util/pccts/files/digest-pccts-1.33.24-r2
@@ -0,0 +1 @@
+MD5 c2b9f48b029fdc636c1dd7b1df716478 pccts133mr24.zip
diff --git a/dev-util/pccts/files/pccts-1.33.24-r2-gentoo.diff b/dev-util/pccts/files/pccts-1.33.24-r2-gentoo.diff
new file mode 100644
index 000000000000..6e09ef6aafa2
--- /dev/null
+++ b/dev-util/pccts/files/pccts-1.33.24-r2-gentoo.diff
@@ -0,0 +1,49 @@
+--- pccts/support/genmk/genmk.c Fri Aug 3 17:12:51 2001
++++ pccts/support/genmk/genmk-gentoo.c Fri Aug 3 17:12:14 2001
+@@ -7,6 +7,11 @@
+ * U of MN
+ */
+
++/* modified 20010803 by Peter Kadau
++ * for better fhs-compliance
++ * i.e. from "none" to "hmmm soso" ;-)
++ */
++
+ #include <stdio.h>
+ #include <string.h>
+ #include "pcctscfg.h" /* be sensitive to what ANTLR/DLG call the files */
+@@ -65,7 +70,7 @@
+ static int nondef_comp = 0; /* 1=compiler is non default */
+ static char *compilerCCC="CC";
+ static char *compilerCC="cc";
+-static char *pccts_path="/usr/local/pccts";
++static char *pccts_path="/usr/include/pccts";
+
+ #ifdef __STDC__
+ void help(void);
+@@ -356,7 +361,7 @@
+ { "-cfiles",1,pCFiles, "Additional files in C or C++ to compile"},
+ { "-sor",0,pSor, "Start of sorcerer group"},
+ { "-pccts_path",1,ppccts_path,
+- "Path for $PCCTS directory (default is /usr/local/pccts)"},
++ "Path for $PCCTS directory (default is /usr/include/pccts)"},
+ { "-compiler",1,pCompiler,
+ "Default compiler (default is CC/cc)"},
+ { "*", 0,pFile, "" }, /* anything else is a file */
+@@ -495,13 +500,13 @@
+ else printf("SCAN = %s%s\n", DIR(), dlg_class);
+
+ printf("PCCTS = %s\n",pccts_path);
+- printf("ANTLR_H = $(PCCTS)%sh\n", DirectorySymbol);
++ printf("ANTLR_H = $(PCCTS)\n");
+ if (num_sors>0) {
+- printf("SOR_H = $(PCCTS)%ssorcerer%sh\n", DirectorySymbol, DirectorySymbol);
++ printf("SOR_H = $(PCCTS)%ssorcerer\n", DirectorySymbol);
+ printf("SOR_LIB = $(PCCTS)%ssorcerer%slib\n",
+ DirectorySymbol, DirectorySymbol);
+ }
+- printf("BIN = $(PCCTS)%sbin\n", DirectorySymbol);
++ printf("BIN = %susr%sbin\n", DirectorySymbol, DirectorySymbol);
+ printf("ANTLR = $(BIN)%santlr\n", DirectorySymbol);
+ printf("DLG = $(BIN)%sdlg\n", DirectorySymbol);
+ if (num_sors>0) printf("SOR = $(BIN)%ssor\n", DirectorySymbol);
diff --git a/dev-util/pccts/pccts-1.33.24-r2.ebuild b/dev-util/pccts/pccts-1.33.24-r2.ebuild
index 0fdceabfe956..bc542fe1a740 100644
--- a/dev-util/pccts/pccts-1.33.24-r2.ebuild
+++ b/dev-util/pccts/pccts-1.33.24-r2.ebuild
@@ -1,11 +1,12 @@
# Copyright 2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author: Peter Kadau <peter.kadau@web.de>
-# $HEADER$
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pccts/pccts-1.33.24-r2.ebuild,v 1.2 2001/08/22 04:58:59 kabau Exp $
+A="pccts133mr24.zip"
S=${WORKDIR}/pccts
DESCRIPTION="An embedded C/C++ parser generator"
-SRC_URI="http://www.polhode.com/pccts133mr24.zip"
+SRC_URI="http://www.polhode.com/${A}"
HOMEPAGE="http://www.polhode.com/"
DEPEND="app-arch/unzip"