summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-08-20 19:08:28 +0000
committerMichael Januszewski <spock@gentoo.org>2008-08-20 19:08:28 +0000
commit73b9bba0fa1ba467a8f5df2d6d8bc7db6efd4f58 (patch)
tree0edd333363e0160ca38854dc42d4f28ae62088c0 /dev-util/oprofile
parentamd64/x86 stable, bug #235195 (diff)
downloadgentoo-2-73b9bba0fa1ba467a8f5df2d6d8bc7db6efd4f58.tar.gz
gentoo-2-73b9bba0fa1ba467a8f5df2d6d8bc7db6efd4f58.tar.bz2
gentoo-2-73b9bba0fa1ba467a8f5df2d6d8bc7db6efd4f58.zip
Add a check for CONFIG_OPROFILE in the kernel's .config (bug #235285).
(Portage version: 2.2_rc8/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/ChangeLog5
-rw-r--r--dev-util/oprofile/oprofile-0.9.4.ebuild10
2 files changed, 13 insertions, 2 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 00db7cc274ab..5797c42a0750 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/oprofile
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.51 2008/07/27 21:40:26 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.52 2008/08/20 19:08:28 spock Exp $
+
+ 20 Aug 2008; Michał Januszewski <spock@gentoo.org> oprofile-0.9.4.ebuild:
+ Add a check for CONFIG_OPROFILE in the kernel's .config (bug #235285).
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> oprofile-0.9.3.ebuild,
oprofile-0.9.4.ebuild:
diff --git a/dev-util/oprofile/oprofile-0.9.4.ebuild b/dev-util/oprofile/oprofile-0.9.4.ebuild
index 543779566a8e..1daff42b79c7 100644
--- a/dev-util/oprofile/oprofile-0.9.4.ebuild
+++ b/dev-util/oprofile/oprofile-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.4.ebuild,v 1.2 2008/07/27 21:40:26 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.4.ebuild,v 1.3 2008/08/20 19:08:28 spock Exp $
EAPI=1
@@ -20,6 +20,14 @@ DEPEND=">=dev-libs/popt-1.7-r1
>=sys-libs/glibc-2.3.2-r1
qt3? ( x11-libs/qt:3 )"
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_chkconfig_present OPROFILE; then
+ elog "In order for oprofile to work, you need to configure your kernel"
+ elog "with CONFIG_OPROFILE set to 'm' or 'y'."
+ fi
+}
+
src_compile() {
local myconf=""