summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-04-27 17:32:14 +0000
committerMichael Januszewski <spock@gentoo.org>2005-04-27 17:32:14 +0000
commit4f7d05d697d35b697e5eb2bb4ebf742ea88e174a (patch)
tree14a63adee9c98ccec6e34df797ca477411229f3d /dev-util/oprofile
parentStable ppc-macos (diff)
downloadgentoo-2-4f7d05d697d35b697e5eb2bb4ebf742ea88e174a.tar.gz
gentoo-2-4f7d05d697d35b697e5eb2bb4ebf742ea88e174a.tar.bz2
gentoo-2-4f7d05d697d35b697e5eb2bb4ebf742ea88e174a.zip
Added a patch that fixes compilation issues with 2.4 kernels (bug #89566).
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/ChangeLog6
-rw-r--r--dev-util/oprofile/files/oprofile-0.8.2.patch12
-rw-r--r--dev-util/oprofile/oprofile-0.8.2.ebuild10
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 00b63418f853..ca4a7ea0c83b 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/oprofile
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.13 2005/04/24 13:04:37 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.14 2005/04/27 17:32:14 spock Exp $
+
+ 27 Apr 2005; Michał Januszewski <spock@gentoo.org>
+ +files/oprofile-0.8.2.patch, oprofile-0.8.2.ebuild:
+ Added a patch that fixes compilation issues with 2.4 kernels (bug #89566).
24 Apr 2005; Michael Hanselmann <hansmi@gentoo.org> oprofile-0.8.1.ebuild:
Stable on ppc.
diff --git a/dev-util/oprofile/files/oprofile-0.8.2.patch b/dev-util/oprofile/files/oprofile-0.8.2.patch
new file mode 100644
index 000000000000..e5284b7108a5
--- /dev/null
+++ b/dev-util/oprofile/files/oprofile-0.8.2.patch
@@ -0,0 +1,12 @@
+diff -Naur oprofile-0.8.2/module/oprofile.h oprofile-0.8.2-fixed/module/oprofile.h
+--- oprofile-0.8.2/module/oprofile.h 2003-11-01 19:56:53.000000000 +0100
++++ oprofile-0.8.2-fixed/module/oprofile.h 2005-04-26 20:10:16.000000000 +0200
+@@ -141,7 +141,7 @@
+ * performance counter */
+ extern struct op_int_operations op_rtc_ops;
+
+-void FASTCALL(op_do_profile(uint cpu, long eip, long irq_enabled, int ctr));
++void op_do_profile(uint cpu, long eip, long irq_enabled, int ctr);
+ extern struct _oprof_data oprof_data[NR_CPUS];
+ extern struct oprof_sysctl sysctl_parms;
+ extern int lproc_dointvec(ctl_table *table, int write, struct file *filp, void *buffer, size_t *lenp);
diff --git a/dev-util/oprofile/oprofile-0.8.2.ebuild b/dev-util/oprofile/oprofile-0.8.2.ebuild
index 4f86792f9eb1..c266b292cf5e 100644
--- a/dev-util/oprofile/oprofile-0.8.2.ebuild
+++ b/dev-util/oprofile/oprofile-0.8.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.8.2.ebuild,v 1.2 2005/03/25 21:29:35 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.8.2.ebuild,v 1.3 2005/04/27 17:32:14 spock Exp $
+
+inherit eutils
DESCRIPTION="A transparent low-overhead system-wide profiler"
HOMEPAGE="http://oprofile.sourceforge.net"
@@ -16,6 +18,12 @@ DEPEND=">=dev-libs/popt-1.7-r1
>=sys-libs/glibc-2.3.2-r1
qt? ( >=x11-libs/qt-3.2.1-r2 )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/oprofile-0.8.2.patch
+}
+
src_compile() {
check_KV