summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-06-12 10:32:23 +0000
committerMichael Januszewski <spock@gentoo.org>2005-06-12 10:32:23 +0000
commit04bd46dd40134a786ffba66099646495e1bd662d (patch)
tree67a5fa1134c13c2ffe6d2853ab6e8b2a35adb431 /dev-util/oprofile
parentNew debian patch revision; tidy old ebuilds. (diff)
downloadgentoo-2-04bd46dd40134a786ffba66099646495e1bd662d.tar.gz
gentoo-2-04bd46dd40134a786ffba66099646495e1bd662d.tar.bz2
gentoo-2-04bd46dd40134a786ffba66099646495e1bd662d.zip
Version bump. Marked 0.8.2 stable on x86.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/ChangeLog8
-rw-r--r--dev-util/oprofile/files/digest-oprofile-0.91
-rw-r--r--dev-util/oprofile/oprofile-0.8.2.ebuild4
-rw-r--r--dev-util/oprofile/oprofile-0.9.ebuild80
4 files changed, 90 insertions, 3 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index ca4a7ea0c83b..44b3d4434c26 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/oprofile
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.14 2005/04/27 17:32:14 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.15 2005/06/12 10:32:23 spock Exp $
+
+*oprofile-0.9 (12 Jun 2005)
+
+ 12 Jun 2005; Michał Januszewski <spock@gentoo.org> oprofile-0.8.2.ebuild,
+ +oprofile-0.9.ebuild:
+ Version bump. Marked 0.8.2 stable on x86.
27 Apr 2005; Michał Januszewski <spock@gentoo.org>
+files/oprofile-0.8.2.patch, oprofile-0.8.2.ebuild:
diff --git a/dev-util/oprofile/files/digest-oprofile-0.9 b/dev-util/oprofile/files/digest-oprofile-0.9
new file mode 100644
index 000000000000..a7793a6e13d6
--- /dev/null
+++ b/dev-util/oprofile/files/digest-oprofile-0.9
@@ -0,0 +1 @@
+MD5 ef1abe789209c181877e2ec491f635e7 oprofile-0.9.tar.gz 626963
diff --git a/dev-util/oprofile/oprofile-0.8.2.ebuild b/dev-util/oprofile/oprofile-0.8.2.ebuild
index c266b292cf5e..faea87cd5e66 100644
--- a/dev-util/oprofile/oprofile-0.8.2.ebuild
+++ b/dev-util/oprofile/oprofile-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.8.2.ebuild,v 1.3 2005/04/27 17:32:14 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.8.2.ebuild,v 1.4 2005/06/12 10:32:23 spock Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/oprofile/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="x86 ~ppc ~amd64"
# IUSE: it also needs kernel sources but all gentoo users have them
IUSE="qt"
DEPEND=">=dev-libs/popt-1.7-r1
diff --git a/dev-util/oprofile/oprofile-0.9.ebuild b/dev-util/oprofile/oprofile-0.9.ebuild
new file mode 100644
index 000000000000..c509f56eaa9c
--- /dev/null
+++ b/dev-util/oprofile/oprofile-0.9.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.ebuild,v 1.1 2005/06/12 10:32:23 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="A transparent low-overhead system-wide profiler"
+HOMEPAGE="http://oprofile.sourceforge.net"
+SRC_URI="mirror://sourceforge/oprofile/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+# IUSE: it also needs kernel sources but all gentoo users have them
+IUSE="qt"
+DEPEND=">=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ qt? ( >=x11-libs/qt-3.2.1-r2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/oprofile-0.8.2.patch
+}
+
+src_compile() {
+ check_KV
+
+ local myconf=""
+
+ if use qt
+ then
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+ else
+ myconf="${myconf} --with-qt-dir=/void"
+ fi
+
+ myconf="${myconf} --with-x"
+
+ case $KV in
+ 2.2.*|2.4.*) myconf="${myconf} --with-linux=/usr/src/linux";;
+ 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
+ *) die "Kernel version '$KV' not supported";;
+ esac
+ econf ${myconf} || die "econf failed"
+
+ local mymake=""
+
+ sed -i -e "s,depmod -a,:,g" Makefile
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ local myinst=""
+
+ myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV}"
+ make DESTDIR=${D} ${myinst} install || die "make install failed"
+
+ dodoc ChangeLog* README TODO
+}
+
+pkg_postinst() {
+ # media-video/nvidia-kernel does the following:
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ echo
+ einfo "Now load the oprofile module by running:"
+ einfo " # opcontrol --init"
+ einfo "Then read manpages and this html doc:"
+ einfo " /usr/share/doc/oprofile/oprofile.html"
+ echo
+}