summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-09-09 16:28:00 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-09-09 16:28:00 +0000
commitda03c99fcbdcc314c595076812ef648f01d66f0a (patch)
treee55dc88790a1cda59b72603d30cf8098d3f63822 /dev-util/molecule
parentalpha/ia64/s390/sh/sparc stable wrt #418803 (diff)
downloadgentoo-2-da03c99fcbdcc314c595076812ef648f01d66f0a.tar.gz
gentoo-2-da03c99fcbdcc314c595076812ef648f01d66f0a.tar.bz2
gentoo-2-da03c99fcbdcc314c595076812ef648f01d66f0a.zip
version bump
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/molecule')
-rw-r--r--dev-util/molecule/ChangeLog7
-rw-r--r--dev-util/molecule/molecule-0.9.24.4.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-util/molecule/ChangeLog b/dev-util/molecule/ChangeLog
index 1fe79ad5cdbc..2585c9096445 100644
--- a/dev-util/molecule/ChangeLog
+++ b/dev-util/molecule/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/molecule
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.33 2012/09/05 11:56:52 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.34 2012/09/09 16:28:00 lxnay Exp $
+
+*molecule-0.9.24.4 (09 Sep 2012)
+
+ 09 Sep 2012; Fabio Erculiani <lxnay@gentoo.org> +molecule-0.9.24.4.ebuild:
+ version bump
*molecule-0.9.24.3 (05 Sep 2012)
diff --git a/dev-util/molecule/molecule-0.9.24.4.ebuild b/dev-util/molecule/molecule-0.9.24.4.ebuild
new file mode 100644
index 000000000000..4ecbd0a2c45d
--- /dev/null
+++ b/dev-util/molecule/molecule-0.9.24.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/molecule-0.9.24.4.ebuild,v 1.1 2012/09/09 16:28:00 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+
+inherit python
+
+DESCRIPTION="Release metatool used for creating Sabayon (and Gentoo) releases"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/intltool
+ sys-devel/gettext"
+RDEPEND="net-misc/rsync
+ sys-fs/squashfs-tools
+ sys-process/lsof
+ virtual/cdrtools"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/lib" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install \
+ || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/molecule"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/molecule"
+}