summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-01-17 12:43:50 +0000
committerPacho Ramos <pacho@gentoo.org>2011-01-17 12:43:50 +0000
commit473920ad0821bc360561dd049576814e6cc53fbd (patch)
tree81206abc8ad69f4b141e370b10f465d05312473c /dev-util/gtk-doc
parentVersion bump. (diff)
downloadgentoo-2-473920ad0821bc360561dd049576814e6cc53fbd.tar.gz
gentoo-2-473920ad0821bc360561dd049576814e6cc53fbd.tar.bz2
gentoo-2-473920ad0821bc360561dd049576814e6cc53fbd.zip
Version bump with a lot of upstream bugfixes and including some of our patches like vim-7.3 fix and highlighter selection.
(Portage version: 2.1.9.31/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/gtk-doc')
-rw-r--r--dev-util/gtk-doc/ChangeLog8
-rw-r--r--dev-util/gtk-doc/gtk-doc-1.16.ebuild100
2 files changed, 107 insertions, 1 deletions
diff --git a/dev-util/gtk-doc/ChangeLog b/dev-util/gtk-doc/ChangeLog
index 23fa55e821af..28d9be69c1f8 100644
--- a/dev-util/gtk-doc/ChangeLog
+++ b/dev-util/gtk-doc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/gtk-doc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.141 2011/01/01 15:46:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.142 2011/01/17 12:43:50 pacho Exp $
+
+*gtk-doc-1.16 (17 Jan 2011)
+
+ 17 Jan 2011; Pacho Ramos <pacho@gentoo.org> +gtk-doc-1.16.ebuild:
+ Version bump with a lot of upstream bugfixes and including some of our
+ patches like vim-7.3 fix and highlighter selection.
01 Jan 2011; Raúl Porcel <armin76@gentoo.org> gtk-doc-1.15-r2.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #348269
diff --git a/dev-util/gtk-doc/gtk-doc-1.16.ebuild b/dev-util/gtk-doc/gtk-doc-1.16.ebuild
new file mode 100644
index 000000000000..8fbf360e73b4
--- /dev/null
+++ b/dev-util/gtk-doc/gtk-doc-1.16.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-1.16.ebuild,v 1.1 2011/01/17 12:43:50 pacho Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit eutils elisp-common gnome2 python
+
+DESCRIPTION="GTK+ Documentation Generator"
+HOMEPAGE="http://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~m68k ~mips ~ppc ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="debug doc emacs highlight vim test"
+
+# dev-tex/tex4ht blocker needed due bug #315287
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-lang/perl-5.6
+ >=app-text/openjade-1.3.1
+ dev-libs/libxslt
+ >=dev-libs/libxml2-2.3.6
+ ~app-text/docbook-xml-dtd-4.3
+ app-text/docbook-xsl-stylesheets
+ ~app-text/docbook-sgml-dtd-3.0
+ >=app-text/docbook-dsssl-stylesheets-1.40
+ emacs? ( virtual/emacs )
+ highlight? (
+ vim? ( app-editors/vim )
+ !vim? ( dev-util/source-highlight )
+ )
+ !!<dev-tex/tex4ht-20090611_p1038-r1"
+
+DEPEND="${RDEPEND}
+ ~dev-util/gtk-doc-am-${PV}
+ >=dev-util/pkgconfig-0.19
+ >=app-text/scrollkeeper-0.3.14
+ >=app-text/gnome-doc-utils-0.3.2
+ test? ( app-text/scrollkeeper-dtd )"
+
+SITEFILE=61${PN}-gentoo.el
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+ if use vim; then
+ G2CONF="${G2CONF} $(use_with highlight highlight vim)"
+ else
+ G2CONF="${G2CONF} $(use_with highlight highlight source-highlight)"
+ fi
+ python_set_active_version 2
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove global Emacs keybindings.
+ epatch "${FILESDIR}/${PN}-1.8-emacs-keybindings.patch"
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ use emacs && elisp-compile tools/gtk-doc.el
+}
+
+src_install() {
+ gnome2_src_install
+
+ python_convert_shebangs 2 "${ED}"/usr/bin/gtkdoc-depscan
+
+ # Don't install those files, they are in gtk-doc-am now
+ rm "${ED}"/usr/share/aclocal/gtk-doc.m4 || die "failed to remove gtk-doc.m4"
+ rm "${ED}"/usr/bin/gtkdoc-rebase || die "failed to remove gtkdoc-rebase"
+
+ if use doc; then
+ docinto doc
+ dodoc doc/* || die
+ docinto examples
+ dodoc examples/* || die
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} tools/gtk-doc.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "gtk-doc does no longer define global key bindings for Emacs."
+ elog "You may set your own key bindings for \"gtk-doc-insert\" and"
+ elog "\"gtk-doc-insert-section\" in your ~/.emacs file."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}