summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-09-16 01:37:24 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-09-16 01:37:24 +0000
commitc89a4e1648503d4567f50a49b7a51443461b9c4c (patch)
treeefee443c71065a36de25814ec3205fd66bbdb990 /dev-util/git
parentVersion bump (diff)
downloadgentoo-2-c89a4e1648503d4567f50a49b7a51443461b9c4c.tar.gz
gentoo-2-c89a4e1648503d4567f50a49b7a51443461b9c4c.tar.bz2
gentoo-2-c89a4e1648503d4567f50a49b7a51443461b9c4c.zip
Bug #278738: Do not use FEATURES.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/git')
-rw-r--r--dev-util/git/ChangeLog8
-rw-r--r--dev-util/git/git-1.6.3.1.ebuild4
-rw-r--r--dev-util/git/git-1.6.3.3.ebuild4
-rw-r--r--dev-util/git/git-1.6.3.4.ebuild4
-rw-r--r--dev-util/git/git-1.6.4.1.ebuild4
-rw-r--r--dev-util/git/git-1.6.4.2.ebuild4
-rw-r--r--dev-util/git/git-1.6.4.3.ebuild4
-rw-r--r--dev-util/git/git-1.6.4.ebuild4
-rw-r--r--dev-util/git/git-1.6.5_rc1.ebuild4
9 files changed, 23 insertions, 17 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index cd21c14b3a48..e92018e30225 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/git
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.358 2009/09/16 01:27:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.359 2009/09/16 01:37:24 robbat2 Exp $
+
+ 16 Sep 2009; Robin H. Johnson <robbat2@gentoo.org> git-1.6.3.1.ebuild,
+ git-1.6.3.3.ebuild, git-1.6.3.4.ebuild, git-1.6.4.ebuild,
+ git-1.6.4.1.ebuild, git-1.6.4.2.ebuild, git-1.6.4.3.ebuild,
+ git-1.6.5_rc1.ebuild:
+ Bug #278738: Do not use FEATURES.
16 Sep 2009; Robin H. Johnson <robbat2@gentoo.org> git-1.6.3.1.ebuild,
git-1.6.3.3.ebuild, git-1.6.3.4.ebuild, git-1.6.4.ebuild,
diff --git a/dev-util/git/git-1.6.3.1.ebuild b/dev-util/git/git-1.6.3.1.ebuild
index 2027b1518fc0..4d11feeea2ba 100644
--- a/dev-util/git/git-1.6.3.1.ebuild
+++ b/dev-util/git/git-1.6.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.3.1.ebuild,v 1.2 2009/09/16 01:27:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.3.1.ebuild,v 1.3 2009/09/16 01:37:24 robbat2 Exp $
EAPI=2
@@ -293,7 +293,7 @@ src_test() {
cvs=0
use cvs && let cvs=$cvs+1
- if ! has userpriv "${FEATURES}"; then
+ if [[ ${EUID} -eq 0 ]]; then
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
diff --git a/dev-util/git/git-1.6.3.3.ebuild b/dev-util/git/git-1.6.3.3.ebuild
index 0cf27138f4e6..86018acda4ef 100644
--- a/dev-util/git/git-1.6.3.3.ebuild
+++ b/dev-util/git/git-1.6.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.3.3.ebuild,v 1.8 2009/09/16 01:27:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.3.3.ebuild,v 1.9 2009/09/16 01:37:24 robbat2 Exp $
EAPI=2
@@ -293,7 +293,7 @@ src_test() {
cvs=0
use cvs && let cvs=$cvs+1
- if ! has userpriv "${FEATURES}"; then
+ if [[ ${EUID} -eq 0 ]]; then
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
diff --git a/dev-util/git/git-1.6.3.4.ebuild b/dev-util/git/git-1.6.3.4.ebuild
index c1805d88b2e8..7dccef58fe59 100644
--- a/dev-util/git/git-1.6.3.4.ebuild
+++ b/dev-util/git/git-1.6.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.3.4.ebuild,v 1.2 2009/09/16 01:27:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.3.4.ebuild,v 1.3 2009/09/16 01:37:24 robbat2 Exp $
EAPI=2
@@ -293,7 +293,7 @@ src_test() {
cvs=0
use cvs && let cvs=$cvs+1
- if ! has userpriv "${FEATURES}"; then
+ if [[ ${EUID} -eq 0 ]]; then
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
diff --git a/dev-util/git/git-1.6.4.1.ebuild b/dev-util/git/git-1.6.4.1.ebuild
index e78b22c0f422..95f9522da98f 100644
--- a/dev-util/git/git-1.6.4.1.ebuild
+++ b/dev-util/git/git-1.6.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.4.1.ebuild,v 1.2 2009/09/16 01:27:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.4.1.ebuild,v 1.3 2009/09/16 01:37:24 robbat2 Exp $
EAPI=2
@@ -293,7 +293,7 @@ src_test() {
cvs=0
use cvs && let cvs=$cvs+1
- if ! has userpriv "${FEATURES}"; then
+ if [[ ${EUID} -eq 0 ]]; then
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
diff --git a/dev-util/git/git-1.6.4.2.ebuild b/dev-util/git/git-1.6.4.2.ebuild
index d55cc2bb66a6..3bf546bcbf95 100644
--- a/dev-util/git/git-1.6.4.2.ebuild
+++ b/dev-util/git/git-1.6.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.4.2.ebuild,v 1.2 2009/09/16 01:27:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.4.2.ebuild,v 1.3 2009/09/16 01:37:24 robbat2 Exp $
EAPI=2
@@ -293,7 +293,7 @@ src_test() {
cvs=0
use cvs && let cvs=$cvs+1
- if ! has userpriv "${FEATURES}"; then
+ if [[ ${EUID} -eq 0 ]]; then
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
diff --git a/dev-util/git/git-1.6.4.3.ebuild b/dev-util/git/git-1.6.4.3.ebuild
index dee3b0dbfa63..0755ce797c29 100644
--- a/dev-util/git/git-1.6.4.3.ebuild
+++ b/dev-util/git/git-1.6.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.4.3.ebuild,v 1.2 2009/09/16 01:27:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.4.3.ebuild,v 1.3 2009/09/16 01:37:24 robbat2 Exp $
EAPI=2
@@ -293,7 +293,7 @@ src_test() {
cvs=0
use cvs && let cvs=$cvs+1
- if ! has userpriv "${FEATURES}"; then
+ if [[ ${EUID} -eq 0 ]]; then
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
diff --git a/dev-util/git/git-1.6.4.ebuild b/dev-util/git/git-1.6.4.ebuild
index c324574c0487..ab56127c1544 100644
--- a/dev-util/git/git-1.6.4.ebuild
+++ b/dev-util/git/git-1.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.4.ebuild,v 1.2 2009/09/16 01:27:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.4.ebuild,v 1.3 2009/09/16 01:37:24 robbat2 Exp $
EAPI=2
@@ -293,7 +293,7 @@ src_test() {
cvs=0
use cvs && let cvs=$cvs+1
- if ! has userpriv "${FEATURES}"; then
+ if [[ ${EUID} -eq 0 ]]; then
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
diff --git a/dev-util/git/git-1.6.5_rc1.ebuild b/dev-util/git/git-1.6.5_rc1.ebuild
index 81a16399abc3..856f35853e2e 100644
--- a/dev-util/git/git-1.6.5_rc1.ebuild
+++ b/dev-util/git/git-1.6.5_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.5_rc1.ebuild,v 1.2 2009/09/16 01:27:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.5_rc1.ebuild,v 1.3 2009/09/16 01:37:24 robbat2 Exp $
EAPI=2
@@ -293,7 +293,7 @@ src_test() {
cvs=0
use cvs && let cvs=$cvs+1
- if ! has userpriv "${FEATURES}"; then
+ if [[ ${EUID} -eq 0 ]]; then
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"