summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2008-01-13 22:02:29 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2008-01-13 22:02:29 +0000
commit9a0036dad16856067e271e7e9b560b9baa8d1f72 (patch)
treede43d0256561f29138a91f78cdaf05469445b649 /dev-util/git
parentppc. stable (diff)
downloadgentoo-2-9a0036dad16856067e271e7e9b560b9baa8d1f72.tar.gz
gentoo-2-9a0036dad16856067e271e7e9b560b9baa8d1f72.tar.bz2
gentoo-2-9a0036dad16856067e271e7e9b560b9baa8d1f72.zip
Add a fix for some test cases under subversion 1.4.6
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-util/git')
-rw-r--r--dev-util/git/ChangeLog6
-rw-r--r--dev-util/git/files/git-1.5.3.8-t9101.patch25
-rw-r--r--dev-util/git/git-1.5.3.8.ebuild3
3 files changed, 32 insertions, 2 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index bbd9c23c91a8..c1f7e66cdc2e 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/git
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.248 2008/01/10 11:51:48 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.249 2008/01/13 22:02:28 ferdy Exp $
+
+ 13 Jan 2008; Fernando J. Pereda <ferdy@gentoo.org>
+ +files/git-1.5.3.8-t9101.patch, git-1.5.3.8.ebuild:
+ Add a fix for some test cases under subversion 1.4.6
*git-1.5.3.8 (10 Jan 2008)
diff --git a/dev-util/git/files/git-1.5.3.8-t9101.patch b/dev-util/git/files/git-1.5.3.8-t9101.patch
new file mode 100644
index 000000000000..84db3adaff04
--- /dev/null
+++ b/dev-util/git/files/git-1.5.3.8-t9101.patch
@@ -0,0 +1,25 @@
+commit d99c74e2913ab098953bd5b422b95f39e2dcfb55
+Author: Sam Vilain <sam.vilain@catalyst.net.nz>
+Date: Fri Sep 21 14:02:34 2007 +1200
+
+ git-svn: fix test for trunk svn (transaction out of date)
+
+ Older svn clients did not raise a 'transaction out of date' error here, but
+ trunk does - so 'svn up'.
+
+ Signed-off-by: Sam Vilain <sam.vilain@catalyst.net.nz>
+ Acked-by: Eric Wong <normalperson@yhbt.net>
+ Signed-off-by: Junio C Hamano <gitster@pobox.com>
+
+diff --git a/t/t9101-git-svn-props.sh b/t/t9101-git-svn-props.sh
+index 622ea1c..5aac644 100755
+--- a/t/t9101-git-svn-props.sh
++++ b/t/t9101-git-svn-props.sh
+@@ -140,6 +140,7 @@ test_expect_success 'test show-ignore' "
+ cd test_wc &&
+ mkdir -p deeply/nested/directory &&
+ svn add deeply &&
++ svn up &&
+ svn propset -R svn:ignore 'no-such-file*' .
+ svn commit -m 'propset svn:ignore'
+ cd .. &&
diff --git a/dev-util/git/git-1.5.3.8.ebuild b/dev-util/git/git-1.5.3.8.ebuild
index 6a75e7c47ebc..ec42447a36b3 100644
--- a/dev-util/git/git-1.5.3.8.ebuild
+++ b/dev-util/git/git-1.5.3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.5.3.8.ebuild,v 1.1 2008/01/10 11:51:48 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.5.3.8.ebuild,v 1.2 2008/01/13 22:02:28 ferdy Exp $
inherit toolchain-funcs eutils elisp-common perl-module bash-completion
@@ -79,6 +79,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-1.5.3-symlinks.patch
epatch "${FILESDIR}"/${P}-t9106.patch
+ epatch "${FILESDIR}"/${P}-t9101.patch
sed -i \
-e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \