summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-10-01 17:35:45 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-10-01 17:35:45 +0000
commit3a5f1ebd03c685aab754dc488d377db2cf0da4fe (patch)
treeabff887b93822854c510c62252796c4a18977dca /dev-util/gambas
parentDon't run econf twice by using src_configure. (diff)
downloadgentoo-2-3a5f1ebd03c685aab754dc488d377db2cf0da4fe.tar.gz
gentoo-2-3a5f1ebd03c685aab754dc488d377db2cf0da4fe.tar.bz2
gentoo-2-3a5f1ebd03c685aab754dc488d377db2cf0da4fe.zip
Use src_prepare and src_configure so that we don't run econf twice.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-util/gambas')
-rw-r--r--dev-util/gambas/ChangeLog5
-rw-r--r--dev-util/gambas/gambas-2.8.2.ebuild18
2 files changed, 10 insertions, 13 deletions
diff --git a/dev-util/gambas/ChangeLog b/dev-util/gambas/ChangeLog
index 8dac46aa297e..8eb6832c353c 100644
--- a/dev-util/gambas/ChangeLog
+++ b/dev-util/gambas/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/gambas
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.51 2008/09/27 13:46:58 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.52 2008/10/01 17:35:45 betelgeuse Exp $
+
+ 01 Oct 2008; Petteri Räty <betelgeuse@gentoo.org> gambas-2.8.2.ebuild:
+ Use src_prepare and src_configure so that we don't run econf twice.
27 Sep 2008; Petteri Räty <betelgeuse@gentoo.org> gambas-2.8.2.ebuild:
Use EAPI 2 use dependencies instead of built_with_use.
diff --git a/dev-util/gambas/gambas-2.8.2.ebuild b/dev-util/gambas/gambas-2.8.2.ebuild
index d23573093861..62b2a477cf43 100644
--- a/dev-util/gambas/gambas-2.8.2.ebuild
+++ b/dev-util/gambas/gambas-2.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-2.8.2.ebuild,v 1.3 2008/09/27 13:46:58 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-2.8.2.ebuild,v 1.4 2008/10/01 17:35:45 betelgeuse Exp $
EAPI="2"
@@ -101,10 +101,7 @@ my_examine_components() {
einfo
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
if { ! use qt3; } && use gtk; then
ebegin "Applying sed no-Qt-use-GTK-workaround-patch (EXPERIMENTAL)"
# Gentoo-specific patch/workaround
@@ -204,7 +201,7 @@ src_unpack() {
eautoreconf || die "eautoreconf failed"
}
-src_compile() {
+src_configure() {
local myconf
local myconf_main
local myconf_qt
@@ -255,12 +252,9 @@ src_compile() {
myconf_xml="$(use_enable xml xslt)"
econf --config-cache \
- ${myconf} ${myconf_main} ${myconf_qt} ${myconf_xml} \
- $(use_enable debug) --disable-profiling \
- --docdir=/usr/share/doc/${PF} --htmldir=/usr/share/doc/${PF}/html \
- || die "econf failed"
-
- emake || die "emake failed"
+ ${myconf} ${myconf_main} ${myconf_qt} ${myconf_xml} \
+ $(use_enable debug) --disable-profiling \
+ --docdir=/usr/share/doc/${PF} --htmldir=/usr/share/doc/${PF}/html
}
my_dekstop_and_icon () {