summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-01 23:40:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-01 23:40:50 +0000
commit307f29ff4ec0ca19bd1a4e2d141011c04efad641 (patch)
tree18553495a7723181e4835346b5ca703e3722e1d9 /dev-util/gambas
parentChanged to include cryptfs (diff)
downloadgentoo-2-307f29ff4ec0ca19bd1a4e2d141011c04efad641.tar.gz
gentoo-2-307f29ff4ec0ca19bd1a4e2d141011c04efad641.tar.bz2
gentoo-2-307f29ff4ec0ca19bd1a4e2d141011c04efad641.zip
clean up and mark as amd64 craptastic
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/gambas')
-rw-r--r--dev-util/gambas/gambas-1.0.5.ebuild65
1 files changed, 32 insertions, 33 deletions
diff --git a/dev-util/gambas/gambas-1.0.5.ebuild b/dev-util/gambas/gambas-1.0.5.ebuild
index af5a0d53b190..1975bada5fdb 100644
--- a/dev-util/gambas/gambas-1.0.5.ebuild
+++ b/dev-util/gambas/gambas-1.0.5.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-1.0.5.ebuild,v 1.2 2005/04/23 13:01:34 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-1.0.5.ebuild,v 1.3 2005/06/01 23:40:50 vapier Exp $
inherit eutils
DESCRIPTION="a RAD tool for BASIC"
-HOMEPAGE="http://gambas.sourceforge.net"
+HOMEPAGE="http://gambas.sourceforge.net/"
SRC_URI="http://gambas.sourceforge.net/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
-IUSE="postgres mysql sdl doc curl debug sqlite xml xsl zlib kde"
+KEYWORDS="-amd64 ~x86"
+IUSE="postgres mysql sdl doc curl debug sqlite xml xsl zlib kde bzip2"
-DEPEND=">=sys-devel/automake-1.7.5
- >=x11-libs/qt-3.2
+RDEPEND=">=x11-libs/qt-3.2
kde? ( >=kde-base/kdelibs-3.2 )
sdl? ( media-libs/libsdl media-libs/sdl-mixer sys-libs/gpm )
mysql? ( dev-db/mysql )
@@ -23,7 +22,10 @@ DEPEND=">=sys-devel/automake-1.7.5
sqlite? ( dev-db/sqlite )
xml? ( dev-libs/libxml2 )
xsl? ( dev-libs/libxslt )
- zlib? ( sys-libs/zlib app-arch/bzip2 )"
+ zlib? ( sys-libs/zlib )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.7.5"
src_unpack() {
unpack ${A}
@@ -38,45 +40,42 @@ src_unpack() {
}
src_compile() {
- local myconf
-
- myconf="${myconf} --enable-qt --enable-net --enable-vb"
- myconf="${myconf} `use_enable mysql`"
- myconf="${myconf} `use_enable postgres`"
- myconf="${myconf} `use_enable sqlite`"
- myconf="${myconf} `use_enable sdl`"
- myconf="${myconf} `use_enable curl`"
- myconf="${myconf} `use_enable zlib`"
- myconf="${myconf} `use_enable xml libxml`"
- myconf="${myconf} `use_enable xsl xslt`"
- myconf="${myconf} `use_enable zlib bzlib2`"
- myconf="${myconf} `use_enable kde`"
-
- if use debug ; then
- myconf="${myconf} --disable-optimization --enable-debug --enable-profiling"
- else
- myconf="${myconf} --enable-optimization --disable-debug --disable-profiling"
- fi
-
- econf ${myconf} || die
+ econf \
+ --enable-qt \
+ --enable-net \
+ --enable-vb \
+ $(use_enable mysql) \
+ $(use_enable postgres) \
+ $(use_enable sqlite) \
+ $(use_enable sdl) \
+ $(use_enable curl) \
+ $(use_enable zlib) \
+ $(use_enable xml libxml) \
+ $(use_enable xsl xslt) \
+ $(use_enable bzip2 bzlib2) \
+ $(use_enable kde) \
+ $(use_enable !debug optimization) \
+ $(use_enable debug) \
+ $(use_enable debug profiling) \
+ || die
emake || die
}
src_install() {
export PATH="${D}/usr/bin:${PATH}"
- make DESTDIR="$D" install || die
+ make DESTDIR="${D}" install || die
dodoc README INSTALL NEWS AUTHORS ChangeLog TODO
# only install the API docs and examples with USE=doc
- if use doc; then
- mv ${D}/usr/share/${PN}/help ${D}/usr/share/doc/${PF}/html
- mv ${D}/usr/share/${PN}/examples ${D}/usr/share/doc/${PF}/examples
+ if use doc ; then
+ mv "${D}"/usr/share/${PN}/help "${D}"/usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/${PN}/examples "${D}"/usr/share/doc/${PF}/examples
else
dohtml ${FILESDIR}/WebHome.html
fi
- rm -rf ${D}/usr/share/${PN}/help ${D}/usr/share/${PN}/examples
+ rm -r "${D}"/usr/share/${PN}/help "${D}"/usr/share/${PN}/examples
dosym ../doc/${PF}/html /usr/share/${PN}/help
dosym ../doc/${PF}/examples /usr/share/${PN}/examples
}