summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-05-23 20:13:44 +0000
committerMichael Weber <xmw@gentoo.org>2012-05-23 20:13:44 +0000
commitb55a29b859882c069c114df9d3b9fd4500139bbd (patch)
treecd33d9115825b0644074818fc90d29d7e669cc6a /dev-util/fatrace/fatrace-0.4.ebuild
parentVersion bump (diff)
downloadgentoo-2-b55a29b859882c069c114df9d3b9fd4500139bbd.tar.gz
gentoo-2-b55a29b859882c069c114df9d3b9fd4500139bbd.tar.bz2
gentoo-2-b55a29b859882c069c114df9d3b9fd4500139bbd.zip
Initial import (thanks github.com/lorem-ipsum for the ebuild)
(Portage version: 2.1.10.62/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/fatrace/fatrace-0.4.ebuild')
-rw-r--r--dev-util/fatrace/fatrace-0.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/fatrace/fatrace-0.4.ebuild b/dev-util/fatrace/fatrace-0.4.ebuild
new file mode 100644
index 000000000000..9c0c3ce82f71
--- /dev/null
+++ b/dev-util/fatrace/fatrace-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/fatrace/fatrace-0.4.ebuild,v 1.1 2012/05/23 20:13:44 xmw Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="report file access events from all running processes"
+HOMEPAGE="https://launchpad.net/fatrace"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="powertop"
+
+RDEPEND="powertop? ( =sys-power/powertop-1.13 )"
+DEPEND=""
+
+CONFIG_CHECK="FANOTIFY"
+
+src_prepare() {
+ if use powertop ; then
+ sed -e "s/powertop-1.13/powertop/g" \
+ -i power-usage-report || die
+ fi
+
+ tc-export CC
+}
+
+src_install() {
+ dosbin fatrace
+ use powertop && dosbin power-usage-report
+
+ doman fatrace.1
+ dodoc NEWS
+}