summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-02-22 12:55:49 +0000
committerJeroen Roovers <jer@gentoo.org>2011-02-22 12:55:49 +0000
commit72cd661c9f02b0485866e9cc3e4e9d12e7f4badb (patch)
tree8c04cd0a753db8a2d5bd993f2f333775d06803c9 /dev-util/debootstrap/debootstrap-1.0.28.ebuild
parentversion bump (diff)
downloadgentoo-2-72cd661c9f02b0485866e9cc3e4e9d12e7f4badb.tar.gz
gentoo-2-72cd661c9f02b0485866e9cc3e4e9d12e7f4badb.tar.bz2
gentoo-2-72cd661c9f02b0485866e9cc3e4e9d12e7f4badb.zip
Version bump.
(Portage version: 2.2.0_alpha24/cvs/Linux i686)
Diffstat (limited to 'dev-util/debootstrap/debootstrap-1.0.28.ebuild')
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.28.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/debootstrap/debootstrap-1.0.28.ebuild b/dev-util/debootstrap/debootstrap-1.0.28.ebuild
new file mode 100644
index 000000000000..3575f239242b
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.28.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debootstrap/debootstrap-1.0.28.ebuild,v 1.1 2011/02/22 12:55:49 jer Exp $
+
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="http://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-devel/binutils
+ net-misc/wget
+ >=app-arch/dpkg-1.14.20"
+
+# Version 1.0.23 does not include the version in the directory name
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc TODO debian/changelog
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ elog "To check Release files against a keyring"
+ elog " (--keyring=K), please install app-crypt/gnupg."
+}