summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-24 02:52:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-24 02:52:12 +0000
commit5f2b73c4be597147bda50fb1c8915c7ebb3d7f0e (patch)
tree888be2b72e83bcaaccfea785bd59bc3160f3ff21 /dev-util/cppunit
parentstabilize #106930 (diff)
downloadgentoo-2-5f2b73c4be597147bda50fb1c8915c7ebb3d7f0e.tar.gz
gentoo-2-5f2b73c4be597147bda50fb1c8915c7ebb3d7f0e.tar.bz2
gentoo-2-5f2b73c4be597147bda50fb1c8915c7ebb3d7f0e.zip
fix underquoted definition of AM_PATH_CPPUNIT warning
(Portage version: 2.0.52-r1 http://ronaldmcnightrider.ytmnd.com/ )
Diffstat (limited to 'dev-util/cppunit')
-rw-r--r--dev-util/cppunit/cppunit-1.10.2.ebuild23
-rw-r--r--dev-util/cppunit/files/cppunit-1.10.2-m4.patch11
2 files changed, 25 insertions, 9 deletions
diff --git a/dev-util/cppunit/cppunit-1.10.2.ebuild b/dev-util/cppunit/cppunit-1.10.2.ebuild
index c81f92a5bed3..8ddb4055fd4f 100644
--- a/dev-util/cppunit/cppunit-1.10.2.ebuild
+++ b/dev-util/cppunit/cppunit-1.10.2.ebuild
@@ -1,31 +1,36 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.10.2.ebuild,v 1.9 2005/07/22 14:15:24 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.10.2.ebuild,v 1.10 2005/09/24 02:52:12 vapier Exp $
-IUSE="doc"
+inherit eutils
-DESCRIPTION="CppUnit is the C++ port of the famous JUnit framework for unit testing."
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
HOMEPAGE="http://cppunit.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-
-RESTRICT="maketest"
+IUSE="doc"
+RESTRICT="test"
DEPEND="doc? ( app-doc/doxygen )
media-gfx/graphviz"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-m4.patch
+}
+
src_compile() {
- econf `use_enable doc doxygen` || die "configure failed"
+ econf $(use_enable doc doxygen) || die "configure failed"
emake || die
- #make check || die
}
src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS BUGS COPYING NEWS README THANKS TODO
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README THANKS TODO
# the package automatically puts its docs into /usr/share/cppunit
# move them to the standard location and clean up
mv ${D}/usr/share/cppunit/html ${D}/usr/share/doc/${PF}
diff --git a/dev-util/cppunit/files/cppunit-1.10.2-m4.patch b/dev-util/cppunit/files/cppunit-1.10.2-m4.patch
new file mode 100644
index 000000000000..2d2a9bf1a4fe
--- /dev/null
+++ b/dev-util/cppunit/files/cppunit-1.10.2-m4.patch
@@ -0,0 +1,11 @@
+--- cppunit.m4
++++ cppunit.m4
+@@ -1,7 +1,7 @@
+ dnl
+ dnl AM_PATH_CPPUNIT(MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
+ dnl
+-AC_DEFUN(AM_PATH_CPPUNIT,
++AC_DEFUN([AM_PATH_CPPUNIT],
+ [
+
+ AC_ARG_WITH(cppunit-prefix,[ --with-cppunit-prefix=PFX Prefix where CppUnit is installed (optional)],