summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-13 15:36:01 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-13 15:36:01 +0000
commit16ab852e191ec58f613f1329eea3c99be9c6a359 (patch)
tree00dbd47dbc5bc0aee637599549775779c96472c4 /dev-util/cppunit
parentStable ppc64, bug #431878 (diff)
downloadgentoo-2-16ab852e191ec58f613f1329eea3c99be9c6a359.tar.gz
gentoo-2-16ab852e191ec58f613f1329eea3c99be9c6a359.tar.bz2
gentoo-2-16ab852e191ec58f613f1329eea3c99be9c6a359.zip
Punt older keep only latest stable.
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cppunit')
-rw-r--r--dev-util/cppunit/ChangeLog8
-rw-r--r--dev-util/cppunit/cppunit-1.12.1-r1.ebuild56
-rw-r--r--dev-util/cppunit/files/cppunit-1.10.2-asneeded.patch10
-rw-r--r--dev-util/cppunit/files/cppunit-1.12.1-add_missing_include.patch23
-rw-r--r--dev-util/cppunit/files/cppunit-1.12.1-warnings.patch22
5 files changed, 7 insertions, 112 deletions
diff --git a/dev-util/cppunit/ChangeLog b/dev-util/cppunit/ChangeLog
index 5d2bf0158ef0..044a89e6c098 100644
--- a/dev-util/cppunit/ChangeLog
+++ b/dev-util/cppunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cppunit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.74 2012/09/09 15:00:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.75 2012/09/13 15:36:01 scarabeus Exp $
+
+ 13 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> -cppunit-1.12.1-r1.ebuild,
+ -files/cppunit-1.10.2-asneeded.patch,
+ -files/cppunit-1.12.1-add_missing_include.patch,
+ -files/cppunit-1.12.1-warnings.patch:
+ Punt older keep only latest stable.
09 Sep 2012; Raúl Porcel <armin76@gentoo.org> cppunit-1.13.0.ebuild:
alpha/ia64/sparc stable wrt #431274
diff --git a/dev-util/cppunit/cppunit-1.12.1-r1.ebuild b/dev-util/cppunit/cppunit-1.12.1-r1.ebuild
deleted file mode 100644
index e63a83d39def..000000000000
--- a/dev-util/cppunit/cppunit-1.12.1-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.12.1-r1.ebuild,v 1.11 2012/05/09 19:22:50 mattst88 Exp $
-
-EAPI=4
-
-inherit autotools eutils
-
-DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
-HOMEPAGE="http://cppunit.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples static-libs"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- )"
-
-DOCS=( AUTHORS ChangeLog BUGS NEWS README THANKS TODO doc/FAQ )
-
-src_prepare() {
- epatch \
- "${FILESDIR}/${PN}-1.10.2-asneeded.patch" \
- "${FILESDIR}/${P}-add_missing_include.patch" \
- "${FILESDIR}/${P}-warnings.patch"
- eautoreconf
-}
-
-src_configure() {
- # Anything else than -O0 breaks on alpha
- use alpha && replace-flags "-O?" -O0
-
- econf \
- $(use_enable static-libs static) \
- $(use_enable doc doxygen) \
- $(use_enable doc dot) \
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-
- if use examples ; then
- find examples -iname "*.o" -delete
- insinto /usr/share/${PN}
- doins -r examples
- fi
-}
diff --git a/dev-util/cppunit/files/cppunit-1.10.2-asneeded.patch b/dev-util/cppunit/files/cppunit-1.10.2-asneeded.patch
deleted file mode 100644
index 068414f33580..000000000000
--- a/dev-util/cppunit/files/cppunit-1.10.2-asneeded.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-Index: cppunit-1.10.2/src/cppunit/Makefile.am
-===================================================================
---- cppunit-1.10.2.orig/src/cppunit/Makefile.am
-+++ cppunit-1.10.2/src/cppunit/Makefile.am
-@@ -64,4 +64,5 @@ libcppunit_la_SOURCES = \
- libcppunit_la_LDFLAGS= \
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
- -release $(LT_RELEASE)
-+libcppunit_la_LIBADD = $(LIBADD_DL)
-
diff --git a/dev-util/cppunit/files/cppunit-1.12.1-add_missing_include.patch b/dev-util/cppunit/files/cppunit-1.12.1-add_missing_include.patch
deleted file mode 100644
index 0d71bdd7e3fa..000000000000
--- a/dev-util/cppunit/files/cppunit-1.12.1-add_missing_include.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=271229
-https://sourceforge.net/tracker/?func=detail&aid=2796543&group_id=11795&atid=111795
-
---- config/ax_cxx_gcc_abi_demangle.m4
-+++ config/ax_cxx_gcc_abi_demangle.m4
-@@ -15,6 +15,7 @@
- AC_LANG_CPLUSPLUS
- AC_TRY_COMPILE([#include <typeinfo>
- #include <cxxabi.h>
-+#include <malloc.h>
- #include <string>
-
- template<typename TYPE>
---- src/cppunit/TypeInfoHelper.cpp
-+++ src/cppunit/TypeInfoHelper.cpp
-@@ -6,6 +6,7 @@
- #include <string>
-
- #if CPPUNIT_HAVE_GCC_ABI_DEMANGLE
-+#include <malloc.h>
- #include <cxxabi.h>
- #endif
-
diff --git a/dev-util/cppunit/files/cppunit-1.12.1-warnings.patch b/dev-util/cppunit/files/cppunit-1.12.1-warnings.patch
deleted file mode 100644
index 39e804aff7f0..000000000000
--- a/dev-util/cppunit/files/cppunit-1.12.1-warnings.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- misc/cppunit-1.12.1/include/cppunit/plugin/TestPlugIn.h 2007-01-12 05:54:34.000000000 +0100
-+++ misc/build/cppunit-1.12.1/include/cppunit/plugin/TestPlugIn.h 2009-12-02 15:33:29.639857272 +0100
-@@ -151,9 +151,7 @@
- #include <windows.h>
- #endif
- #define CPPUNIT_PLUGIN_IMPLEMENT_MAIN() \
-- BOOL APIENTRY DllMain( HANDLE hModule, \
-- DWORD ul_reason_for_call, \
-- LPVOID lpReserved ) \
-+ BOOL APIENTRY DllMain( HANDLE, DWORD, LPVOID ) \
- { \
- return TRUE; \
- } \
-@@ -162,7 +160,7 @@
- // Unix
- #elif defined(CPPUNIT_HAVE_UNIX_DLL_LOADER) || defined(CPPUNIT_HAVE_UNIX_SHL_LOADER)
- #define CPPUNIT_PLUGIN_IMPLEMENT_MAIN() \
-- int main( int argc, char *argv[] ) \
-+ int main( int, char *[] ) \
- { \
- return 0; \
- } \