summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-06-10 19:37:04 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-06-10 19:37:04 +0000
commit661b24c3d06eca9c140102e928b824c6f7ff8a82 (patch)
tree1cb3c3f76ba018ea1bd3985ccea9a1e845fae8ee /dev-util/boost-build
parentFixes bug #178866. (diff)
downloadgentoo-2-661b24c3d06eca9c140102e928b824c6f7ff8a82.tar.gz
gentoo-2-661b24c3d06eca9c140102e928b824c6f7ff8a82.tar.bz2
gentoo-2-661b24c3d06eca9c140102e928b824c6f7ff8a82.zip
Boost building boost-build with GCC 4.2, bug #181139.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-util/boost-build')
-rw-r--r--dev-util/boost-build/ChangeLog5
-rw-r--r--dev-util/boost-build/boost-build-1.34.0.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-util/boost-build/ChangeLog b/dev-util/boost-build/ChangeLog
index cef60a9af057..131104dd9332 100644
--- a/dev-util/boost-build/ChangeLog
+++ b/dev-util/boost-build/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/boost-build
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.2 2007/06/06 19:24:04 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.3 2007/06/10 19:37:04 dirtyepic Exp $
+
+ 10 Jun 2007; Ryan Hill <dirtyepic@gentoo.org> boost-build-1.34.0.ebuild:
+ Boost building boost-build with GCC 4.2, bug #181139.
*boost-build-1.34.0 (03 Jun 2007)
diff --git a/dev-util/boost-build/boost-build-1.34.0.ebuild b/dev-util/boost-build/boost-build-1.34.0.ebuild
index 01921fc688d8..2f775eee957b 100644
--- a/dev-util/boost-build/boost-build-1.34.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.34.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.34.0.ebuild,v 1.1 2007/06/06 19:24:04 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.34.0.ebuild,v 1.2 2007/06/10 19:37:04 dirtyepic Exp $
-inherit toolchain-funcs versionator
+inherit flag-o-matic toolchain-funcs versionator
KEYWORDS="~amd64 ~x86"
@@ -52,6 +52,8 @@ src_compile() {
toolset=cc
fi
+ append-flags -fno-strict-aliasing
+
CC=$(tc-getCC) ./build.sh ${toolset} || die "building bjam failed"
}