summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Houser <chouser@gentoo.org>2002-02-07 04:33:06 +0000
committerChris Houser <chouser@gentoo.org>2002-02-07 04:33:06 +0000
commitb21f6385a0af5d9d5a356f16710676d877ad6d7b (patch)
tree9c0689e80abfc8594e501c2e5590a2c30189d9ab /dev-util/arch
parentused SLOT="1" and SLOT="2" instead of "0" and "1" (diff)
downloadgentoo-2-b21f6385a0af5d9d5a356f16710676d877ad6d7b.tar.gz
gentoo-2-b21f6385a0af5d9d5a356f16710676d877ad6d7b.tar.bz2
gentoo-2-b21f6385a0af5d9d5a356f16710676d877ad6d7b.zip
first ebuild
Diffstat (limited to 'dev-util/arch')
-rw-r--r--dev-util/arch/arch-1.0_pre5.ebuild74
-rw-r--r--dev-util/arch/files/digest-arch-1.0_pre51
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/arch/arch-1.0_pre5.ebuild b/dev-util/arch/arch-1.0_pre5.ebuild
new file mode 100644
index 000000000000..d7605f2bf3eb
--- /dev/null
+++ b/dev-util/arch/arch-1.0_pre5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Chris Houser <chouser@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/arch/arch-1.0_pre5.ebuild,v 1.1 2002/02/07 04:33:06 chouser Exp $
+
+P="${P//_/}"
+S="${WORKDIR}/${P}/src/=build"
+DESCRIPTION="revision control system ideal for widely distributed development"
+SRC_URI="ftp://regexps.com/pub/src/arch/${P}.tar.gz"
+HOMEPAGE="http://www.regexps.com/#arch"
+
+DEPEND="sys-apps/diffutils
+ sys-apps/fileutils
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/sh-utils
+ sys-apps/tar
+ sys-apps/textutils
+ sys-apps/util-linux
+ sys-devel/make
+ sys-devel/patch"
+
+src_unpack() {
+ unpack "${A}"
+ mkdir -p "${P}/src/=build"
+
+ # patch the arch command to put /usr/bin at the front of it's PATH
+ # this allows us to survive with the existance of a /bin/arch too
+ # could be done by requiring every user to set their .arch-params/path
+ t="${P}/src/arch/arch/arch.sh.in"
+ cp $t $t.orig
+ sed 's-# Set the PATH.*-&\
+PATH="/usr/bin:$PATH"-' $t.orig > $t
+ assert "Patch failed for $t"
+}
+
+src_compile() {
+ # configure
+ ../configure \
+ --prefix "/usr" \
+ --with-posix-shell "/bin/bash" \
+ || die "configure failed"
+
+ # build
+ emake || die "emake failed"
+}
+
+src_install () {
+ # install
+ make install prefix="${D}/usr" \
+ || die "make install failed"
+
+ # make some symlinks relative instead of absolute
+ find ${D}/usr/libexec/arch/arch -type l \
+ | xargs ls -l \
+ | sed "s:^.*-> ${D}/usr/libexec/arch/::" \
+ | while read ls; do
+ ln -sf "../$ls" "${D}/usr/libexec/arch/arch/${ls#*/}"
+ assert "Fixing symlink for $ls failed"
+ done
+
+ # make a script so users can type "tlarch" instead of "/usr/bin/arch"
+ # note that arch uses it's name, so this can't be a symlink or use exec
+ echo -e '#!/bin/bash\n/usr/bin/arch "$@"' > "${D}/usr/bin/tlarch"
+ chmod ugo+x "${D}/usr/bin/tlarch" || die "Creating tlarch failed"
+
+ # get some docs
+ cd ../..
+ dodoc =NEWS =README COPYING
+}
+
+pkg_postinst() {
+ echo "You may run Tom Lord's 'arch' command as 'tlarch'"
+}
diff --git a/dev-util/arch/files/digest-arch-1.0_pre5 b/dev-util/arch/files/digest-arch-1.0_pre5
new file mode 100644
index 000000000000..836b088dfe6c
--- /dev/null
+++ b/dev-util/arch/files/digest-arch-1.0_pre5
@@ -0,0 +1 @@
+MD5 5e439bbc9f93571afe942349b585cbf5 arch-1.0pre5.tar.gz 2437120