summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-03-19 03:44:17 +0000
committerZack Welch <zwelch@gentoo.org>2003-03-19 03:44:17 +0000
commit75e046bf9f83ccc98a2df4b6741634c14a3a2523 (patch)
tree20b166cd8826e257bec8a0200fa16cfe7bc84d85 /dev-util/arch
parentremoved pic (diff)
downloadgentoo-2-75e046bf9f83ccc98a2df4b6741634c14a3a2523.tar.gz
gentoo-2-75e046bf9f83ccc98a2df4b6741634c14a3a2523.tar.bz2
gentoo-2-75e046bf9f83ccc98a2df4b6741634c14a3a2523.zip
bump to latest version
Diffstat (limited to 'dev-util/arch')
-rw-r--r--dev-util/arch/ChangeLog13
-rw-r--r--dev-util/arch/arch-1.0_pre17.ebuild74
-rw-r--r--dev-util/arch/files/digest-arch-1.0_pre171
3 files changed, 85 insertions, 3 deletions
diff --git a/dev-util/arch/ChangeLog b/dev-util/arch/ChangeLog
index 277e37418164..9c7c77841f4b 100644
--- a/dev-util/arch/ChangeLog
+++ b/dev-util/arch/ChangeLog
@@ -1,11 +1,18 @@
# ChangeLog for dev-util/arch
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/arch/ChangeLog,v 1.7 2003/02/12 06:38:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/arch/ChangeLog,v 1.8 2003/03/19 03:44:17 zwelch Exp $
+
+*arch-1.0_pre17 (18 Mar 2003)
+
+ 18 Mar 2003; Zach Welch <zwelch@gentoo.org> arch-1.0_pre17.ebuild:
+ bump version to latest
+
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*arch-1.0_pre15 (19 Apr 2002)
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> :
+ changed sparc ~sparc keywords
+
19 Apr 2002; Ryan Phillips <rphillips@gentoo.org> arch-1.0_pre15.ebuild:
Bumped up version to arch-1.0_pre15.
diff --git a/dev-util/arch/arch-1.0_pre17.ebuild b/dev-util/arch/arch-1.0_pre17.ebuild
new file mode 100644
index 000000000000..c2263e17c95b
--- /dev/null
+++ b/dev-util/arch/arch-1.0_pre17.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/arch/arch-1.0_pre17.ebuild,v 1.1 2003/03/19 03:44:17 zwelch Exp $
+
+MY_P="${P//_/}"
+S="${WORKDIR}/${MY_P}/src/=build"
+DESCRIPTION="revision control system ideal for widely distributed development"
+SRC_URI="http://regexps.srparish.net/src/arch/${MY_P}.tar.gz"
+HOMEPAGE="http://regexps.srparish.net/www/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc ~mips ~hppa ~sparc arm"
+
+DEPEND="sys-apps/diffutils
+ sys-apps/fileutils
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/sh-utils
+ sys-apps/tar
+ sys-apps/textutils
+ sys-apps/util-linux
+ sys-apps/debianutils
+ sys-devel/make
+ sys-devel/patch"
+
+src_unpack() {
+ local t
+
+ unpack "${A}"
+ mkdir -p "${MY_P}/src/=build"
+
+ # patch arch to install its scripts in /usr/share/arch
+ # instead of /usr/libexec/arch (there is only shareables scripts).
+ t="${MY_P}/src/build-tools/Makefiles/rules.mk"
+
+ cp ${t} ${t}.orig
+ sed 's:/libexec:/share:g' ${t}.orig > ${t} || die "Patch failed for $t"
+}
+
+src_compile() {
+ ../configure \
+ --prefix="/usr" \
+ --with-posix-shell="/bin/bash" \
+ --with-sendmail="/usr/sbin/sendmail" || die "configure failed"
+
+ # parallel make may cause problems with this package
+ make || die "make failed"
+}
+
+src_install () {
+ local name
+
+ make install prefix="${D}/usr" \
+ || die "make install failed"
+
+ for name in ${D}/usr/share/arch/arch/*; do
+ name="`readlink ${name} | sed 's:^.*/usr/share/arch/::'`"
+ if [ "${name}" ]; then
+ ln -sf "../${name}" "${D}/usr/share/arch/arch/${name#*/}"
+ assert "Fixing symlink for ${name} failed"
+ fi
+ done
+
+ # get some docs
+ cd ${WORKDIR}/${MY_P}
+ dodoc =NEWS =README COPYING
+ dohtml -r docs
+}
+
+pkg_postinst() {
+ echo "Tom Lord's 'arch' command has been renamed upstream to 'larch'"
+ echo "to stop collision with 'arch' command."
+}
diff --git a/dev-util/arch/files/digest-arch-1.0_pre17 b/dev-util/arch/files/digest-arch-1.0_pre17
new file mode 100644
index 000000000000..ca9ae13d410c
--- /dev/null
+++ b/dev-util/arch/files/digest-arch-1.0_pre17
@@ -0,0 +1 @@
+MD5 0eab278d398e2ba93826de4ceb9cd4c3 arch-1.0pre17.tar.gz 3127569