summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-11-29 14:33:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-11-29 14:33:39 +0000
commit0f16aac28c211d20e30a35bfde2223cd254a7a25 (patch)
tree98714a7088583f057c27ebdc07270fb91a8c34ca /dev-tex/luatex
parentversion bump (diff)
downloadgentoo-2-0f16aac28c211d20e30a35bfde2223cd254a7a25.tar.gz
gentoo-2-0f16aac28c211d20e30a35bfde2223cd254a7a25.tar.bz2
gentoo-2-0f16aac28c211d20e30a35bfde2223cd254a7a25.zip
version bump
(Portage version: 2.2_rc16/cvs/Linux 2.6.27.7 x86_64)
Diffstat (limited to 'dev-tex/luatex')
-rw-r--r--dev-tex/luatex/ChangeLog7
-rw-r--r--dev-tex/luatex/luatex-0.30.3.ebuild138
2 files changed, 144 insertions, 1 deletions
diff --git a/dev-tex/luatex/ChangeLog b/dev-tex/luatex/ChangeLog
index 9cafc734ae16..bb3e05e15f33 100644
--- a/dev-tex/luatex/ChangeLog
+++ b/dev-tex/luatex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/luatex
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/luatex/ChangeLog,v 1.15 2008/11/18 15:30:35 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/luatex/ChangeLog,v 1.16 2008/11/29 14:33:39 aballier Exp $
+
+*luatex-0.30.3 (29 Nov 2008)
+
+ 29 Nov 2008; Alexis Ballier <aballier@gentoo.org> +luatex-0.30.3.ebuild:
+ version bump
18 Nov 2008; Ferris McCormick <fmccor@gentoo.org> luatex-0.30.2.ebuild:
Keyword for ~sparc, part of bug #237202, thanks to Friedrich Oslage (bluebird).
diff --git a/dev-tex/luatex/luatex-0.30.3.ebuild b/dev-tex/luatex/luatex-0.30.3.ebuild
new file mode 100644
index 000000000000..c4a66d6b1e23
--- /dev/null
+++ b/dev-tex/luatex/luatex-0.30.3.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/luatex/luatex-0.30.3.ebuild,v 1.1 2008/11/29 14:33:39 aballier Exp $
+
+EAPI="2"
+
+inherit libtool multilib eutils toolchain-funcs
+
+PATCHLEVEL="5"
+
+DESCRIPTION="An extended version of pdfTeX using Lua as an embedded scripting language."
+HOMEPAGE="http://www.luatex.org/"
+SRC_URI="http://foundry.supelec.fr/frs/download.php/699/${PN}-beta-${PV}.tar.bz2
+ mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="dev-tex/mplib[lua]
+ dev-libs/zziplib
+ media-libs/libpng
+ app-text/poppler
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${PN}-beta-${PV}/src"
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ elibtoolize
+}
+
+src_configure() {
+ # Too many regexps use A-Z a-z constructs, what causes problems with locales
+ # that don't have the same alphabetical order than ascii. Bug #244619
+ # So we set LC_ALL to C in order to avoid problems.
+ export LC_ALL=C
+ tc-export CC CXX AR RANLIB
+ export NATIVE='.'
+ mkdir -p "${WORKDIR}/${PN}-beta-${PV}/build"
+ cd "${WORKDIR}/${PN}-beta-${PV}/build"
+ ECONF_SOURCE="${S}" econf \
+ --without-cxx-runtime-hack \
+ --without-aleph \
+ --without-bibtex8 \
+ --without-cjkutils \
+ --without-detex \
+ --without-dialog \
+ --without-dtl \
+ --without-dvi2tty \
+ --without-dvidvi \
+ --without-dviljk \
+ --without-dvipdfm \
+ --without-dvipdfmx \
+ --without-dvipng \
+ --without-dvipos \
+ --without-dvipsk \
+ --without-etex \
+ --without-gsftopk \
+ --without-lacheck \
+ --without-lcdf-typetools \
+ --without-makeindexk \
+ --without-mkocp-default \
+ --without-mkofm-default \
+ --without-musixflx \
+ --without-omega \
+ --without-pdfopen \
+ --without-ps2eps \
+ --without-ps2pkm \
+ --without-psutils \
+ --without-sam2p \
+ --without-seetexk \
+ --without-t1utils \
+ --without-tetex \
+ --without-tex4htk \
+ --without-texi2html \
+ --without-texinfo \
+ --without-texlive \
+ --without-ttf2pk \
+ --without-tth \
+ --without-xdv2pdf \
+ --without-xdvik \
+ --without-xdvipdfmx \
+ --without-xetex \
+ --disable-largefile \
+ --with-system-zlib \
+ --with-system-pnglib
+}
+
+src_compile() {
+ cd "${WORKDIR}/${PN}-beta-${PV}/build/texk/web2c"
+ emake \
+ LIBMPLIBDEP="/usr/$(get_libdir)/libmplib/mplib.la" \
+ LDZZIPLIB="$(pkg-config --libs zziplib)" ZZIPLIBINC="$(pkg-config --cflags zziplib)" \
+ LIBXPDFDEP="" LDLIBXPDF="$(pkg-config --libs poppler)" \
+ LIBXPDFINCLUDE="$(pkg-config --cflags poppler)" LIBXPDFCPPFLAGS="$(pkg-config --cflags poppler)" \
+ LIBPNGINCLUDES="$(pkg-config --cflags libpng)" \
+ ZLIBSRCDIR="." \
+ luatex || die "failed to build luatex"
+}
+
+src_install() {
+ cd "${WORKDIR}/${PN}-beta-${PV}/build/texk/web2c"
+ emake bindir="${D}/usr/bin" \
+ LIBMPLIBDEP="/usr/$(get_libdir)/libmplib/mplib.la" \
+ LDZZIPLIB="$(pkg-config --libs zziplib)" ZZIPLIBINC="$(pkg-config --cflags zziplib)" \
+ LIBXPDFDEP="" LDLIBXPDF="$(pkg-config --libs poppler)" \
+ LIBXPDFINCLUDE="$(pkg-config --cflags poppler)" LIBXPDFCPPFLAGS="$(pkg-config --cflags poppler)" \
+ LIBPNGINCLUDES="$(pkg-config --cflags libpng)" \
+ ZLIBSRCDIR="." \
+ install-luatex || die "install-luatex failed"
+
+ dodoc "${WORKDIR}/${PN}-beta-${PV}/README"
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins "${WORKDIR}/${PN}-beta-${PV}/manual/"*.pdf
+ fi
+}
+
+pkg_postinst() {
+ if ! has_version '>=dev-texlive/texlive-basic-2008' ; then
+ elog "Please note that this package does not install much files, mainly the"
+ elog "${PN} executable that will need other files in order to be useful.."
+ elog "Please consider installing a recent TeX distribution"
+ elog "like TeX Live 2008 to get the full power of ${PN}"
+ fi
+ if [ "$ROOT" = "/" ] && [ -x /usr/bin/fmtutil-sys ] ; then
+ einfo "Rebuilding formats"
+ /usr/bin/fmtutil-sys --all &> /dev/null
+ else
+ ewarn "Cannot run fmtutil-sys for some reason."
+ ewarn "Your formats might be inconsistent with your installed ${PN} version"
+ ewarn "Please try to figure what has happened"
+ fi
+}