summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2013-07-04 00:11:03 +0000
committerDenis Dupeyron <calchan@gentoo.org>2013-07-04 00:11:03 +0000
commit355c6072923582a7fdcccda63153e67984420f0d (patch)
tree485907b10f19bcfd354bba8af01db6436b05bd16 /dev-tex/circuit_macros
parentRemove mask on cgminer, bug #442254 (diff)
downloadgentoo-2-355c6072923582a7fdcccda63153e67984420f0d.tar.gz
gentoo-2-355c6072923582a7fdcccda63153e67984420f0d.tar.bz2
gentoo-2-355c6072923582a7fdcccda63153e67984420f0d.zip
Version bump.
(Portage version: 2.1.12.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-tex/circuit_macros')
-rw-r--r--dev-tex/circuit_macros/ChangeLog7
-rw-r--r--dev-tex/circuit_macros/circuit_macros-7.6.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-tex/circuit_macros/ChangeLog b/dev-tex/circuit_macros/ChangeLog
index ecc258a623c4..c6019b4b5dd3 100644
--- a/dev-tex/circuit_macros/ChangeLog
+++ b/dev-tex/circuit_macros/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/circuit_macros
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/ChangeLog,v 1.1 2013/06/11 14:41:06 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/ChangeLog,v 1.2 2013/07/04 00:11:03 calchan Exp $
+
+*circuit_macros-7.6 (04 Jul 2013)
+
+ 04 Jul 2013; Denis Dupeyron <calchan@gentoo.org> +circuit_macros-7.6.ebuild:
+ Version bump.
*circuit_macros-7.5 (11 Jun 2013)
diff --git a/dev-tex/circuit_macros/circuit_macros-7.6.ebuild b/dev-tex/circuit_macros/circuit_macros-7.6.ebuild
new file mode 100644
index 000000000000..7368416cbd3d
--- /dev/null
+++ b/dev-tex/circuit_macros/circuit_macros-7.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/circuit_macros-7.6.ebuild,v 1.1 2013/07/04 00:11:03 calchan Exp $
+
+EAPI=5
+
+inherit unpacker texlive-common
+
+DESCRIPTION="M4 Macros for Electric circuit diagrams in TeX or LaTeX"
+HOMEPAGE="https://ece.uwaterloo.ca/~aplevich/Circuit_macros/"
+SRC_URI="http://mirrors.ctan.org/graphics/circuit_macros.zip -> circuit_macros-${PV}.zip"
+
+LICENSE="LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +script"
+
+DEPEND=""
+RDEPEND="|| ( app-text/texlive[graphics] app-text/texlive[pstricks] )
+ media-gfx/dpic
+ sys-devel/m4
+ script? ( app-text/texlive[graphics]
+ dev-texlive/texlive-latexextra )"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins *.m4
+ insinto /usr/share/texmf-site/tex/latex/${PN}
+ doins boxdims.sty
+ dodoc README CHANGES Makefile doc/CMman.pdf
+ rm -f doc/CMman.pdf
+ use doc && dodoc -r doc
+ use examples && dodoc -r examples
+ use script && dobin "${FILESDIR}/CM2pdf"
+ docompress -x \
+ /usr/share/doc/${PF}/Makefile \
+ /usr/share/doc/${PF}/doc \
+ /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ etexmf-update
+ use script && einfo "CM2pdf was installed to automatically create PDFs"
+}
+
+pkg_postrm() {
+ etexmf-update
+}