summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-14 16:16:56 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-14 16:16:56 +0000
commitf310ccdbf46a413caab90f3a029376bd3ae08506 (patch)
tree316bca0310020e2356f6ea8235a6b365048ea8ed /dev-tcltk
parentVersion bump (diff)
downloadgentoo-2-f310ccdbf46a413caab90f3a029376bd3ae08506.tar.gz
gentoo-2-f310ccdbf46a413caab90f3a029376bd3ae08506.tar.bz2
gentoo-2-f310ccdbf46a413caab90f3a029376bd3ae08506.zip
dev-tcltk/tkimg: Readd old version
(Portage version: 2.2.8/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tkimg/ChangeLog5
-rw-r--r--dev-tcltk/tkimg/tkimg-1.4-r7.ebuild93
2 files changed, 97 insertions, 1 deletions
diff --git a/dev-tcltk/tkimg/ChangeLog b/dev-tcltk/tkimg/ChangeLog
index 17d926bc5e08..56f5960bde14 100644
--- a/dev-tcltk/tkimg/ChangeLog
+++ b/dev-tcltk/tkimg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/tkimg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkimg/ChangeLog,v 1.63 2014/01/14 14:12:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkimg/ChangeLog,v 1.64 2014/01/14 16:16:56 jlec Exp $
+
+ 14 Jan 2014; Justin Lecher <jlec@gentoo.org> +tkimg-1.4-r7.ebuild:
+ Readd old version
14 Jan 2014; Justin Lecher <jlec@gentoo.org> -tkimg-1.4-r7.ebuild:
Drop old
diff --git a/dev-tcltk/tkimg/tkimg-1.4-r7.ebuild b/dev-tcltk/tkimg/tkimg-1.4-r7.ebuild
new file mode 100644
index 000000000000..2654a9214024
--- /dev/null
+++ b/dev-tcltk/tkimg/tkimg-1.4-r7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkimg/tkimg-1.4-r7.ebuild,v 1.8 2014/01/14 16:16:56 jlec Exp $
+
+EAPI=4
+
+VIRTUALX_USE=test
+
+inherit eutils multilib prefix toolchain-funcs virtualx
+
+MYP="${PN}${PV}"
+
+DESCRIPTION="Adds a lot of image formats to Tcl/Tk"
+HOMEPAGE="http://tkimg.sourceforge.net/"
+SRC_URI="
+ http://dev.gentoo.org/~jlec/distfiles/${P}-gentoo+bundled-tiff.patch.xz
+ mirror://sourceforge/${PN}/${PV}/${MYP}.tar.bz2"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="doc test static-libs"
+
+RDEPEND="
+ dev-lang/tk
+ >=dev-tcltk/tcllib-1.11
+ media-libs/tiff:0
+ media-libs/libpng:0
+ >=sys-libs/zlib-1.2.7
+ x11-libs/libX11
+ virtual/jpeg"
+DEPEND="${RDEPEND}
+ test? (
+ x11-apps/xhost
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )"
+
+# Fails with jpeg-turbo silently, #386253
+RESTRICT="test"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/${P}-gentoo+bundled-tiff.patch \
+ "${FILESDIR}"/${P}-jbig.patch \
+ "${FILESDIR}"/${P}-zlib-1.2.6.patch \
+ "${FILESDIR}"/${P}-libtiff.patch \
+ "${FILESDIR}"/${P}-libtiff4.patch \
+ "${FILESDIR}"/${P}-zlib127-gzgetc_fix.patch
+
+ find compat/{libjpeg,libpng,zlib,libtiff} -delete
+
+ sed \
+ -e 's:-O2 -fomit-frame-pointer::g' \
+ -e 's: -pipe::g' \
+ -i */configure || die
+
+ eprefixify */*.h
+ tc-export AR
+}
+
+src_test() {
+ Xemake test || die "Xmake failed"
+}
+
+src_install() {
+ local l bl
+
+ emake \
+ DESTDIR="${D}" \
+ INSTALL_ROOT="${D}" \
+ install
+
+ if ! use static-libs; then
+ find "${ED}"/usr/$(get_libdir)/ -type f -name "*\.a" -delete || die
+ fi
+
+ # Make library links
+ for l in "${ED}"/usr/lib*/Img*/*tcl*.so; do
+ bl=$(basename $l)
+ dosym Img1.4/${bl} /usr/$(get_libdir)/${bl}
+ done
+
+ dodoc ChangeLog README Reorganization.Notes.txt changes ANNOUNCE
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins demo.tcl
+ insinto /usr/share/doc/${PF}/html
+ doins -r doc/*
+ fi
+}