summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2004-08-08 14:52:54 +0000
committerDoug Goldstein <cardoe@gentoo.org>2004-08-08 14:52:54 +0000
commitcabcfbb848609a0564cd3062dfe8c07649e4e967 (patch)
tree4ea6bac0c0fbe00b0e028d46ebe5077a8369710f /dev-tcltk
parentremove my explicit maintainership (diff)
downloadgentoo-2-cabcfbb848609a0564cd3062dfe8c07649e4e967.tar.gz
gentoo-2-cabcfbb848609a0564cd3062dfe8c07649e4e967.tar.bz2
gentoo-2-cabcfbb848609a0564cd3062dfe8c07649e4e967.zip
compile fix to not make a tclsh window pop up
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/TkZinc/ChangeLog6
-rw-r--r--dev-tcltk/TkZinc/TkZinc-3.2.100.ebuild3
-rw-r--r--dev-tcltk/TkZinc/files/fix-makefile.patch12
3 files changed, 19 insertions, 2 deletions
diff --git a/dev-tcltk/TkZinc/ChangeLog b/dev-tcltk/TkZinc/ChangeLog
index 9761cbff25c9..e66ace42a034 100644
--- a/dev-tcltk/TkZinc/ChangeLog
+++ b/dev-tcltk/TkZinc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/TkZinc
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/TkZinc/ChangeLog,v 1.1 2004/08/08 00:41:06 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/TkZinc/ChangeLog,v 1.2 2004/08/08 14:52:54 cardoe Exp $
+
+ 08 Aug 2004; Doug Goldstein <cardoe@gentoo.org> TkZinc-3.2.100.ebuild:
+ Added fix for window popping up during build.
+ bug #56790 from Ming Zhao
07 Aug 2004; Doug Goldstein <cardoe@gentoo.org> TkZinc-3.2.100.ebuild:
New ebuild added as per request in bug #56790
diff --git a/dev-tcltk/TkZinc/TkZinc-3.2.100.ebuild b/dev-tcltk/TkZinc/TkZinc-3.2.100.ebuild
index eb631ff7c63f..1f1e356b417b 100644
--- a/dev-tcltk/TkZinc/TkZinc-3.2.100.ebuild
+++ b/dev-tcltk/TkZinc/TkZinc-3.2.100.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/TkZinc/TkZinc-3.2.100.ebuild,v 1.1 2004/08/08 00:41:06 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/TkZinc/TkZinc-3.2.100.ebuild,v 1.2 2004/08/08 14:52:54 cardoe Exp $
inherit eutils
@@ -19,6 +19,7 @@ S=${WORKDIR}/Tkzinc
src_compile() {
epatch ${FILESDIR}/without-opengl.patch
+ epatch ${FILESDIR}/fix-makefile.patch
local myconf
if use opengl ; then
diff --git a/dev-tcltk/TkZinc/files/fix-makefile.patch b/dev-tcltk/TkZinc/files/fix-makefile.patch
new file mode 100644
index 000000000000..e58ac022506a
--- /dev/null
+++ b/dev-tcltk/TkZinc/files/fix-makefile.patch
@@ -0,0 +1,12 @@
+--- Makefile.in~ 2004-05-07 17:31:55.000000000 +0800
++++ Makefile.in 2004-08-08 15:51:53.233904744 +0800
+@@ -374,7 +374,7 @@
+ # the configure script output the pkgIndex.tcl by editing configure.in.
+
+#========================================================================
+
+-pkgIndex.tcl:
++pkgIndex.tcl: $($(PACKAGE)_LIB_FILE)
+ ( echo package require Tk \; pkg_mkIndex -verbose -load Tk . $($(PACKAGE)_LIB_FILE) \; exit ) | $(TCLSH)
+
+ pkgIndex.tcl-hand: