summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-26 01:45:50 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-26 01:45:50 +0000
commitc9acebf148cf747d0c724e25eceea6e7e2e2dab4 (patch)
tree1242275b41235e1a67768c663c6b9af1fd01b81d /dev-tcltk
parentadd inherit eutils (diff)
downloadgentoo-2-c9acebf148cf747d0c724e25eceea6e7e2e2dab4.tar.gz
gentoo-2-c9acebf148cf747d0c724e25eceea6e7e2e2dab4.tar.bz2
gentoo-2-c9acebf148cf747d0c724e25eceea6e7e2e2dab4.zip
Add die following econf for bug 48950
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclx/ChangeLog6
-rw-r--r--dev-tcltk/tclx/tclx-8.3-r1.ebuild8
-rw-r--r--dev-tcltk/tclx/tclx-8.3.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/dev-tcltk/tclx/ChangeLog b/dev-tcltk/tclx/ChangeLog
index 6db7b82b5ebe..5b95c726e76f 100644
--- a/dev-tcltk/tclx/ChangeLog
+++ b/dev-tcltk/tclx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/tclx
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/ChangeLog,v 1.11 2004/04/14 11:32:38 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/ChangeLog,v 1.12 2004/04/26 01:42:31 agriffis Exp $
+
+ 25 Apr 2004; Aron Griffis <agriffis@gentoo.org> tclx-8.3-r1.ebuild,
+ tclx-8.3.ebuild:
+ Add die following econf for bug 48950
14 Apr 2004; Daniel Ahlberg <aliz@gentoo.org> tclx-8.3-r1.ebuild,
tclx-8.3.ebuild:
diff --git a/dev-tcltk/tclx/tclx-8.3-r1.ebuild b/dev-tcltk/tclx/tclx-8.3-r1.ebuild
index 27f9396bb09e..59032c2b60e6 100644
--- a/dev-tcltk/tclx/tclx-8.3-r1.ebuild
+++ b/dev-tcltk/tclx/tclx-8.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3-r1.ebuild,v 1.8 2004/04/14 11:32:38 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3-r1.ebuild,v 1.9 2004/04/26 01:42:31 agriffis Exp $
inherit flag-o-matic eutils
@@ -45,7 +45,7 @@ src_unpack() {
src_compile() {
# we have to configure and build tcl before we can do tclx
cd ${WORKDIR}/tcl8.4.2/unix
- econf
+ econf || die "econf failed"
emake CFLAGS="${CFLAGS}" || die "emake in tcl/unix failed"
local myconf="--with-tcl=${WORKDIR}/tcl8.4.2/unix --enable-shared"
@@ -53,7 +53,7 @@ src_compile() {
if [ `use X` ] ; then
# configure and build tk
cd ${WORKDIR}/tk8.4.2/unix
- econf
+ econf || die "econf failed"
emake CFLAGS="${CFLAGS}" || die
myconf="${myconf} --with-tk=${WORKDIR}/tk8.4.2/unix"
else
@@ -62,7 +62,7 @@ src_compile() {
# configure and build tclx
cd ${S}/unix
- econf ${myconf}
+ econf ${myconf} || die "econf failed"
make CFLAGS="${CFLAGS}" || die
}
diff --git a/dev-tcltk/tclx/tclx-8.3.ebuild b/dev-tcltk/tclx/tclx-8.3.ebuild
index 46a88e2df7a3..225648e58f47 100644
--- a/dev-tcltk/tclx/tclx-8.3.ebuild
+++ b/dev-tcltk/tclx/tclx-8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3.ebuild,v 1.11 2004/04/14 11:32:38 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3.ebuild,v 1.12 2004/04/26 01:42:31 agriffis Exp $
inherit flag-o-matic eutils
@@ -33,7 +33,7 @@ src_unpack() {
src_compile() {
# we have to configure and build tcl before we can do tclx
cd ${WORKDIR}/tcl8.3.3/unix
- econf
+ econf || die "econf failed"
emake CFLAGS="${CFLAGS}" || die "emake in tcl/unix failed"
local myconf="--with-tcl=${WORKDIR}/tcl8.3.3/unix --enable-shared"
@@ -41,7 +41,7 @@ src_compile() {
if [ `use X` ] ; then
# configure and build tk
cd ${WORKDIR}/tk8.3.3/unix
- econf
+ econf || die "econf failed"
emake CFLAGS="${CFLAGS}" || die
myconf="${myconf} --with-tk=${WORKDIR}/tk8.3.3/unix"
else
@@ -50,7 +50,7 @@ src_compile() {
# configure and build tclx
cd ${S}/unix
- econf ${myconf}
+ econf ${myconf} || die "econf failed"
make CFLAGS="${CFLAGS}" || die
}