summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-07-20 20:10:07 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-07-20 20:10:07 +0000
commitb7115bba3d042a192df2d2d8664f138db751d401 (patch)
tree6b48d0e4b32e1e7a82c03976eb18c4bae75c6933 /dev-tcltk
parentdon't add || die to inherit() calls (diff)
downloadgentoo-2-b7115bba3d042a192df2d2d8664f138db751d401.tar.gz
gentoo-2-b7115bba3d042a192df2d2d8664f138db751d401.tar.bz2
gentoo-2-b7115bba3d042a192df2d2d8664f138db751d401.zip
updated ebuild to install shared libraries
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/ChangeLog7
-rw-r--r--dev-tcltk/expect/expect-5.33.0.ebuild2
-rw-r--r--dev-tcltk/expect/expect-5.37.1-r1.ebuild59
-rw-r--r--dev-tcltk/expect/files/digest-expect-5.37.1-r11
4 files changed, 67 insertions, 2 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 12b30e1a8f8f..bf3a44badd13 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for dev-tcltk/expect
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.2 2002/07/09 02:37:36 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.3 2002/07/20 20:10:07 george Exp $
*expect-5.37.1 (08 July 2002)
+ 20 Jul 2002; George Shapovalov <george@gentoo.org> epect-5.37.1-r1.ebuild :
+
+ modified ebuild to install shared libraries (necessary for multixterm)
+ upping revision to force-update.
+
08 July 2002; George Shapovalov <george@gentoo.org> epect-5.37.1.ebuild :
upped version, + some cleaning up.
diff --git a/dev-tcltk/expect/expect-5.33.0.ebuild b/dev-tcltk/expect/expect-5.33.0.ebuild
index 372b685c6305..267e1d51f64a 100644
--- a/dev-tcltk/expect/expect-5.33.0.ebuild
+++ b/dev-tcltk/expect/expect-5.33.0.ebuild
@@ -19,7 +19,7 @@ DEPEND=">=dev-lang/tcl-8.2
RDEPEND="${DEPEND}"
SLOT="0"
-LICENSE=""
+LICENSE="as-is"
KEYWORDS="*"
src_compile() {
diff --git a/dev-tcltk/expect/expect-5.37.1-r1.ebuild b/dev-tcltk/expect/expect-5.37.1-r1.ebuild
new file mode 100644
index 000000000000..f4b85238b67b
--- /dev/null
+++ b/dev-tcltk/expect/expect-5.37.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1-r1.ebuild,v 1.1 2002/07/20 20:10:07 george Exp $
+
+#remove the trailing ".0" from the tarball version
+S=${WORKDIR}/${P%.1}
+
+DESCRIPTION="Expect is a tool for automating interactive applications"
+SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
+HOMEPAGE="http://expect.nist.gov/"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="BSD"
+
+DEPEND=">=dev-lang/tcl-8.2
+ X? ( >=dev-lang/tk-8.2 )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ local myconf
+ local tclv
+ local tkv
+ # Find the version of tcl/tk that has headers installed.
+ # This will be the most recently merged, not necessarily the highest
+ # version number.
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ #tkv isn't really needed, included for symmetry and the future
+ tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+
+ #configure needs to find the files tclConfig.sh and tclInt.h
+ myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl$tclv/include/generic"
+
+ if use X; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=/usr/lib"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
+
+ econf $myconf --enable-shared || die
+ emake || die
+
+}
+
+src_install () {
+
+ einstall || die
+
+ #docs
+ dodoc Changelog FAQ HISTORY NEWS README
+
+}
+
diff --git a/dev-tcltk/expect/files/digest-expect-5.37.1-r1 b/dev-tcltk/expect/files/digest-expect-5.37.1-r1
new file mode 100644
index 000000000000..6543a4578374
--- /dev/null
+++ b/dev-tcltk/expect/files/digest-expect-5.37.1-r1
@@ -0,0 +1 @@
+MD5 d570837b6dc6311036d7bdeab19f0e03 expect-5.37.1.tar.gz 517284