summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-07-09 02:37:36 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-07-09 02:37:36 +0000
commit60a386d938eec481c42c45bdae2451a8907f4110 (patch)
treeb32a1c4ca9bc9d59c3ac2a0a2d6ec16bc31e0ba7 /dev-tcltk
parentChangeLog update (diff)
downloadgentoo-2-60a386d938eec481c42c45bdae2451a8907f4110.tar.gz
gentoo-2-60a386d938eec481c42c45bdae2451a8907f4110.tar.bz2
gentoo-2-60a386d938eec481c42c45bdae2451a8907f4110.zip
version update + clean-up
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/ChangeLog10
-rw-r--r--dev-tcltk/expect/expect-5.33.0.ebuild4
-rw-r--r--dev-tcltk/expect/expect-5.37.1.ebuild59
-rw-r--r--dev-tcltk/expect/files/digest-expect-5.37.11
4 files changed, 73 insertions, 1 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 51f0f734fb25..12b30e1a8f8f 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-tcltk/expect
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.2 2002/07/09 02:37:36 george Exp $
+
+*expect-5.37.1 (08 July 2002)
+
+ 08 July 2002; George Shapovalov <george@gentoo.org> epect-5.37.1.ebuild :
+
+ upped version, + some cleaning up.
+ removed Author line, original ebuild by Tod Neidt <tneidt@fidnet.com>
+
*expect-5.33.0 (1 Feb 2002)
diff --git a/dev-tcltk/expect/expect-5.33.0.ebuild b/dev-tcltk/expect/expect-5.33.0.ebuild
index 6e232824799b..6d536dc4ca51 100644
--- a/dev-tcltk/expect/expect-5.33.0.ebuild
+++ b/dev-tcltk/expect/expect-5.33.0.ebuild
@@ -19,6 +19,10 @@ DEPEND=">=dev-lang/tcl-8.2
RDEPEND="${DEPEND}"
+SLOT="0"
+LICENSE=""
+KEYWORDS="*"
+
src_compile() {
local myconf
diff --git a/dev-tcltk/expect/expect-5.37.1.ebuild b/dev-tcltk/expect/expect-5.37.1.ebuild
new file mode 100644
index 000000000000..c49adad70be8
--- /dev/null
+++ b/dev-tcltk/expect/expect-5.37.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1.ebuild,v 1.1 2002/07/09 02:37:36 george Exp $
+
+#remove the trailing ".0" from the tarball version
+S=${WORKDIR}/${P%.1}
+
+DESCRIPTION="Expect is a tool for automating interactive applications"
+SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
+HOMEPAGE="http://expect.nist.gov/"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="BSD"
+
+DEPEND=">=dev-lang/tcl-8.2
+ X? ( >=dev-lang/tk-8.2 )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ local myconf
+ local tclv
+ local tkv
+ # Find the version of tcl/tk that has headers installed.
+ # This will be the most recently merged, not necessarily the highest
+ # version number.
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ #tkv isn't really needed, included for symmetry and the future
+ tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+
+ #configure needs to find the files tclConfig.sh and tclInt.h
+ myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl$tclv/include/generic"
+
+ if use X; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=/usr/lib"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
+
+ econf $myconf || die
+ emake || die
+
+}
+
+src_install () {
+
+ einstall || die
+
+ #docs
+ dodoc Changelog FAQ HISTORY NEWS README
+
+}
+
diff --git a/dev-tcltk/expect/files/digest-expect-5.37.1 b/dev-tcltk/expect/files/digest-expect-5.37.1
new file mode 100644
index 000000000000..6543a4578374
--- /dev/null
+++ b/dev-tcltk/expect/files/digest-expect-5.37.1
@@ -0,0 +1 @@
+MD5 d570837b6dc6311036d7bdeab19f0e03 expect-5.37.1.tar.gz 517284