summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-21 16:25:50 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-21 16:25:50 +0000
commit1e716023a00a68ffb77f18d6dd07200db686eec6 (patch)
tree6e0247e5df09ac8a349ce9e5ebc500c058749bfa /dev-scheme
parentuse dobin instead of exeinto /usr/bin/ && doexe; bump to EAPI=5 and new pytho... (diff)
downloadgentoo-2-1e716023a00a68ffb77f18d6dd07200db686eec6.tar.gz
gentoo-2-1e716023a00a68ffb77f18d6dd07200db686eec6.tar.bz2
gentoo-2-1e716023a00a68ffb77f18d6dd07200db686eec6.zip
Bump to EAPI=5 and clean the ebuild
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/stalin/ChangeLog7
-rw-r--r--dev-scheme/stalin/metadata.xml13
-rw-r--r--dev-scheme/stalin/stalin-0.11.ebuild56
3 files changed, 35 insertions, 41 deletions
diff --git a/dev-scheme/stalin/ChangeLog b/dev-scheme/stalin/ChangeLog
index 15a69736592a..26963fa414f1 100644
--- a/dev-scheme/stalin/ChangeLog
+++ b/dev-scheme/stalin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-scheme/stalin
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stalin/ChangeLog,v 1.2 2014/08/10 21:26:00 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stalin/ChangeLog,v 1.3 2015/03/21 16:25:50 jlec Exp $
+
+ 21 Mar 2015; Justin Lecher <jlec@gentoo.org> metadata.xml, stalin-0.11.ebuild:
+ Bump to EAPI=5 and clean the ebuild
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> stalin-0.11.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/dev-scheme/stalin/metadata.xml b/dev-scheme/stalin/metadata.xml
index 2a1ff0f8a0dc..06b97553c3d2 100644
--- a/dev-scheme/stalin/metadata.xml
+++ b/dev-scheme/stalin/metadata.xml
@@ -1,16 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>scheme</herd>
- <maintainer>
- <email>pchrist@gentoo.org</email>
- <name>Panagiotis Christopoulos</name>
- </maintainer>
- <longdescription lang="en">
+ <herd>scheme</herd>
+ <maintainer>
+ <email>pchrist@gentoo.org</email>
+ <name>Panagiotis Christopoulos</name>
+ </maintainer>
+ <longdescription lang="en">
Stalin is an aggressively optimizing Scheme compiler. It is the most
highly optimizing Scheme compiler, and in fact one of the most highly
optimizing compilers of any sort for any language. It was written by
Jeffrey M. Siskind.
</longdescription>
</pkgmetadata>
-
diff --git a/dev-scheme/stalin/stalin-0.11.ebuild b/dev-scheme/stalin/stalin-0.11.ebuild
index 9128073c9c6b..e3b215665e03 100644
--- a/dev-scheme/stalin/stalin-0.11.ebuild
+++ b/dev-scheme/stalin/stalin-0.11.ebuild
@@ -1,41 +1,37 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stalin/stalin-0.11.ebuild,v 1.4 2014/08/10 21:26:00 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stalin/stalin-0.11.ebuild,v 1.5 2015/03/21 16:25:50 jlec Exp $
+
+EAPI=5
inherit eutils
DESCRIPTION="An aggressively optimizing Scheme compiler"
HOMEPAGE="http://community.schemewiki.org/?Stalin"
SRC_URI="ftp://ftp.ecn.purdue.edu/qobi/${P}.tgz"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-RESTRICT="strip"
+
RDEPEND="x11-libs/libX11"
DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e 's/-O3 -fomit-frame-pointer/$(CFLAGS)/' makefile
-}
+RESTRICT="strip"
-pkg_setup() {
- ewarn "Stalin is an ugly beast, which will eat all your memory and stress your"
- ewarn "processor to levels you have never experienced. If you want to abort,"
- ewarn "please do it now. You have been warned."
+src_prepare() {
+ sed -i -e "s/-O3 -fomit-frame-pointer/${CFLAGS}/" makefile || die
}
src_compile() {
- einfo "Beginning of stalin's compilation process. It may take several minutes."
./build || die "Stalin's compilation failed"
}
src_test() {
einfo "This may take REALLY much time and requires"
einfo "possibly more than 2Gb of RAM+swap."
- cd benchmarks
+ cd benchmarks || die
./compile-and-run-stalin-old-benchmarks || die "old benchmarks failed"
#./compile-and-run-stalin-bcl-benchmarks || die "bcl bechmarks failed"
#./compile-and-run-stalin-fdlcc-benchmarks || die "fdlcc benchmarks failed"
@@ -43,32 +39,28 @@ src_test() {
src_install() {
pushd include
- dodir /usr/include/${PN}
- insinto /usr/include/${PN}
- doins gc.h gc_config_macros.h
- dodir /usr/lib/${PN}
- insinto /usr/lib/${PN}
- doins libgc.a libstalin.a stalin stalin-architecture-name \
+ doheader gc.h gc_config_macros.h
+ insinto /usr/lib/${PN}
+ doins \
+ libgc.a libstalin.a stalin stalin-architecture-name \
stalin.architectures QobiScheme.sc xlib.sc xlib-original.sc \
Scheme-to-C-compatibility.sc
- fperms 755 /usr/lib/${PN}/stalin \
- /usr/lib/${PN}/stalin-architecture-name
+ fperms 755 /usr/lib/${PN}/stalin /usr/lib/${PN}/stalin-architecture-name
popd
-(
-cat <<'EOF'
-#!/bin/bash
-exec /usr/lib/stalin/stalin -I /usr/include/stalin \
--I /usr/lib/stalin -copt -fno-strict-aliasing $@
+ cat > stalin <<- EOF
+ #!/bin/bash
+
+ exec /usr/lib/stalin/stalin -I /usr/include/stalin \
+ -I /usr/lib/stalin -copt -fno-strict-aliasing $@
+
+ EOF
-EOF
-) > stalin
- exeinto /usr/bin
- doexe stalin
+ dobin stalin
doman stalin.1
dodoc ANNOUNCEMENT MORE README
pushd benchmarks
- sed -i -e 's/..\/stalin/stalin/' make-hello
+ sed -i -e 's/..\/stalin/stalin/' make-hello || die
dodoc hello.sc make-hello
popd
}