summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-06-08 11:48:39 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-06-08 11:48:39 +0000
commit06848e3f350bd89231c3d994849d1393e44989f3 (patch)
treee9ddf0bc9d5b52834ff7858249358d238b31f257 /dev-scheme/stklos
parentCall require_php_with_use only once. Thank armin76 for the fix. (diff)
downloadgentoo-2-06848e3f350bd89231c3d994849d1393e44989f3.tar.gz
gentoo-2-06848e3f350bd89231c3d994849d1393e44989f3.tar.bz2
gentoo-2-06848e3f350bd89231c3d994849d1393e44989f3.zip
add 0.95, profit from fixes to the build system
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-scheme/stklos')
-rw-r--r--dev-scheme/stklos/ChangeLog25
-rw-r--r--dev-scheme/stklos/files/digest-stklos-0.953
-rw-r--r--dev-scheme/stklos/stklos-0.95.ebuild41
3 files changed, 68 insertions, 1 deletions
diff --git a/dev-scheme/stklos/ChangeLog b/dev-scheme/stklos/ChangeLog
index ea9e85eba37a..0f85afbe3a3f 100644
--- a/dev-scheme/stklos/ChangeLog
+++ b/dev-scheme/stklos/ChangeLog
@@ -1,6 +1,29 @@
# ChangeLog for dev-scheme/stklos
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/ChangeLog,v 1.3 2007/04/24 14:45:20 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/ChangeLog,v 1.4 2007/06/08 11:48:39 hkbst Exp $
+
+*stklos-0.95 (08 Jun 2007)
+
+ 08 Jun 2007; Marijn Schouten <hkBst@gentoo.org> +stklos-0.95.ebuild:
+ add 0.95, profit from fixes to the build system. Changes:
+ * Better support for lexical analyzer generation
+ * Added some support for fixnum operations
+ * Added here-strings support
+ * Added partial module import
+ * Macros can be local
+ * Added some peephole optimizations
+ * Added new options to the compiler
+ * Added support for reading the tar files
+ * void and eof objects are now printed back as #void and #eof
+ and can be read back
+ * New primitives
+ o signal-error
+ o md5sum
+ o md5sum-file
+ o file-prefix
+ o file-suffix
+ o condition-set!
+ * Bug fixes
24 Apr 2007; Marijn Schouten <hkBst@gentoo.org> stklos-0.82.ebuild:
add boehm-gc threads use flag checking, bug 175371
diff --git a/dev-scheme/stklos/files/digest-stklos-0.95 b/dev-scheme/stklos/files/digest-stklos-0.95
new file mode 100644
index 000000000000..26374ae6409e
--- /dev/null
+++ b/dev-scheme/stklos/files/digest-stklos-0.95
@@ -0,0 +1,3 @@
+MD5 2bbb03ad3789cafb206ce472a3292bb0 stklos-0.95.tar.gz 4188501
+RMD160 22b000861f4b571e0cfd15c2376a49def53d243f stklos-0.95.tar.gz 4188501
+SHA256 a5b98732946b71a13bcb4253179fbf41c2add8d407eb2ceb513a3e357bfc47b5 stklos-0.95.tar.gz 4188501
diff --git a/dev-scheme/stklos/stklos-0.95.ebuild b/dev-scheme/stklos/stklos-0.95.ebuild
new file mode 100644
index 000000000000..15233980dff3
--- /dev/null
+++ b/dev-scheme/stklos/stklos-0.95.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/stklos-0.95.ebuild,v 1.1 2007/06/08 11:48:39 hkbst Exp $
+
+inherit eutils
+
+DESCRIPTION="fast and light Scheme implementation"
+HOMEPAGE="http://www.stklos.org"
+SRC_URI="http://www.stklos.org/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="threads ldap gtk gnome"
+DEPEND="dev-libs/gmp dev-libs/libpcre dev-libs/boehm-gc
+ ldap? ( net-nds/openldap )
+ gtk? ( x11-libs/gtk+ )"
+# gnome? ( )" # someone using gnome should figure out what package will enable gnome support
+#silex and ``The Dominique Boucher LALR Package'' may also be deps, not in tree though
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use threads; then
+ built_with_use dev-libs/boehm-gc threads || die "boehm-gc must be built with threads use flag"
+ fi
+}
+
+src_compile() {
+#this used to be necessary
+# econf $(use_enable threads threads pthreads) $(use ldap && echo --enable-ldap) $(use !gtk && echo --disable-gtk) $(use !gnome && echo --disable-gnome)
+
+#anyone interested in lurc threads? not in tree though
+ econf $(use_enable threads threads pthreads) $(use_enable ldap) $(use_enable gtk) $(use_enable gnome) \
+ --without-gmp-light --without-provided-gc --without-provided-regexp
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}