summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-06-01 17:46:34 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-06-01 17:46:34 +0000
commit203912289876e1d003cb75faab75f4a8d8e85673 (patch)
tree6b97d4f3de665450ad8b2ac2adbf52aee77494a9 /dev-scheme/bigloo
parentia64/x86 stable wrt #180310 (diff)
downloadgentoo-2-203912289876e1d003cb75faab75f4a8d8e85673.tar.gz
gentoo-2-203912289876e1d003cb75faab75f4a8d8e85673.tar.bz2
gentoo-2-203912289876e1d003cb75faab75f4a8d8e85673.zip
add 3.0a
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-scheme/bigloo')
-rw-r--r--dev-scheme/bigloo/ChangeLog7
-rw-r--r--dev-scheme/bigloo/bigloo-3.0a.ebuild78
-rw-r--r--dev-scheme/bigloo/files/digest-bigloo-3.0a3
3 files changed, 87 insertions, 1 deletions
diff --git a/dev-scheme/bigloo/ChangeLog b/dev-scheme/bigloo/ChangeLog
index a74a526f14c9..dbceebe8f146 100644
--- a/dev-scheme/bigloo/ChangeLog
+++ b/dev-scheme/bigloo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/bigloo
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.11 2007/03/12 22:32:43 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.12 2007/06/01 17:46:34 hkbst Exp $
+
+*bigloo-3.0a (01 Jun 2007)
+
+ 01 Jun 2007; Marijn Schouten <hkBst@gentoo.org> +bigloo-3.0a.ebuild:
+ add 3.0a
12 Mar 2007; Matti Bickel <mabi@gentoo.org> bigloo-2.9a.ebuild:
~ppc added (bug #149188)
diff --git a/dev-scheme/bigloo/bigloo-3.0a.ebuild b/dev-scheme/bigloo/bigloo-3.0a.ebuild
new file mode 100644
index 000000000000..3bbc9e5657db
--- /dev/null
+++ b/dev-scheme/bigloo/bigloo-3.0a.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0a.ebuild,v 1.1 2007/06/01 17:46:34 hkbst Exp $
+
+inherit elisp-common
+
+MY_P=${PN}${PV/_p/-r}
+
+DESCRIPTION="Bigloo is a Scheme implementation."
+HOMEPAGE="http://www-sop.inria.fr/mimosa/fp/Bigloo/bigloo.html"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="emacs? ( virtual/emacs )"
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE="50bigloo-gentoo.el"
+
+IUSE="emacs"
+# fullbee"
+
+src_compile() {
+ use emacs && elisp-comp etc/*.el
+
+ # Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --libdir=/usr/lib \
+ --docdir=/usr/share/doc/${PF} \
+ --benchmark=yes \
+ --sharedbde=no \
+ --sharedcompiler=no \
+ --coflags="" || die "configure failed"
+
+# --bee=$(if use fullbee; then echo full; else echo partial; fi) \
+
+ # parallel build is broken
+ emake -j1 || die "emake failed"
+}
+
+# "make test" does something weird so default src_test() in /usr/lib/portage/bin/ebuild.sh fails the following test
+# elif emake -j1 test -n &> /dev/null; then
+# so copy straight from default src_test() all the stuff which depends on that test passing
+src_test() {
+ vecho ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ if ! emake -j1 test; then
+ hasq test $FEATURES && die "Make test failed. See above for details."
+ hasq test $FEATURES || eerror "Make test failed. See above for details."
+ fi
+}
+
+src_install () {
+# dodir /etc/env.d
+# echo "LDPATH=/usr/lib/bigloo/${PV}/" > ${D}/etc/env.d/25bigloo
+
+ # make the links created not point to DESTDIR, since that is only a temporary home
+ sed 's/ln -s $(DESTDIR)/ln -s /' -i Makefile.misc
+ emake DESTDIR=${D} install || die "install failed"
+
+ if use emacs; then
+ elisp-install ${PN} etc/*.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+# einfo "Compiling bee..."
+# emake compile-bee || die "compiling bee failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-scheme/bigloo/files/digest-bigloo-3.0a b/dev-scheme/bigloo/files/digest-bigloo-3.0a
new file mode 100644
index 000000000000..16703622d0f1
--- /dev/null
+++ b/dev-scheme/bigloo/files/digest-bigloo-3.0a
@@ -0,0 +1,3 @@
+MD5 91b86d1514658e1a254456b4e288e092 bigloo3.0a.tar.gz 11356195
+RMD160 9eb19a4f9d11c96a20ed500cb9275d7dd71039f5 bigloo3.0a.tar.gz 11356195
+SHA256 6bb4df214427592b90ce3c6ae83483f8319dca8ed2a0fecc3141ca5749ce2a7a bigloo3.0a.tar.gz 11356195