summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-28 23:46:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-28 23:46:50 +0000
commite5da9d378beaa568900f47c6e50b96f3d3c6c860 (patch)
treef8a7f8bb07d8e9323a21ca9be2cbe2bdd229317c /dev-ruby
parentmarked x86 per bug 413759 (diff)
downloadgentoo-2-e5da9d378beaa568900f47c6e50b96f3d3c6c860.tar.gz
gentoo-2-e5da9d378beaa568900f47c6e50b96f3d3c6c860.tar.bz2
gentoo-2-e5da9d378beaa568900f47c6e50b96f3d3c6c860.zip
Fix testing: add rack and mongrel to dependencies (the latter only in ruby18), and run the tests sequentially instead of all at once.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fast_xs/ChangeLog6
-rw-r--r--dev-ruby/fast_xs/fast_xs-0.8.0.ebuild19
2 files changed, 22 insertions, 3 deletions
diff --git a/dev-ruby/fast_xs/ChangeLog b/dev-ruby/fast_xs/ChangeLog
index 4745702df683..637997c22480 100644
--- a/dev-ruby/fast_xs/ChangeLog
+++ b/dev-ruby/fast_xs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/fast_xs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_xs/ChangeLog,v 1.6 2012/03/28 20:25:08 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_xs/ChangeLog,v 1.7 2012/04/28 23:46:50 flameeyes Exp $
+
+ 28 Apr 2012; Diego E. Pettenò <flameeyes@gentoo.org> fast_xs-0.8.0.ebuild:
+ Fix testing: add rack and mongrel to dependencies (the latter only in ruby18),
+ and run the tests sequentially instead of all at once.
28 Mar 2012; Brent Baude <ranger@gentoo.org> fast_xs-0.8.0.ebuild:
Marking fast_xs-0.8.0 ~ppc64 for bug 405757
diff --git a/dev-ruby/fast_xs/fast_xs-0.8.0.ebuild b/dev-ruby/fast_xs/fast_xs-0.8.0.ebuild
index e3f5ab216efc..0f8e47323202 100644
--- a/dev-ruby/fast_xs/fast_xs-0.8.0.ebuild
+++ b/dev-ruby/fast_xs/fast_xs-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_xs/fast_xs-0.8.0.ebuild,v 1.4 2012/03/28 20:25:08 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_xs/fast_xs-0.8.0.ebuild,v 1.5 2012/04/28 23:46:50 flameeyes Exp $
EAPI=4
@@ -22,7 +22,13 @@ KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
IUSE=""
ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.3.2 )"
-ruby_add_bdepend "test? ( >=dev-ruby/hoe-2.3.2 virtual/ruby-test-unit )"
+ruby_add_bdepend "test? (
+ >=dev-ruby/hoe-2.3.2
+ virtual/ruby-test-unit
+ dev-ruby/rack
+)"
+
+USE_RUBY="ruby18" ruby_add_bdepend "test? ( www-servers/mongrel )"
RUBY_PATCHES=( "${P}+ruby-1.9.patch" )
@@ -37,3 +43,12 @@ each_ruby_compile() {
emake -Cext/fast_xs_extra CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "make extension failed"
cp ext/fast_xs_extra/fast_xs_extra$(get_modname) lib/ || die
}
+
+each_ruby_test() {
+ # the Rakefile tries to run all the tests in a single process, but
+ # this breaks the monkey-patchers, we're forced to run them one by
+ # one.
+ for tu in test/test_*.rb; do
+ ${RUBY} -Ilib $tu || die "test $tu failed"
+ done
+}