summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-10-25 06:02:17 +0000
committerHans de Graaff <graaff@gentoo.org>2011-10-25 06:02:17 +0000
commitd5456db7ab5e30b5e9071cf2700a82e178fd73c5 (patch)
treecefcdeb34840b87b006885c50a799e639c53a63b /dev-ruby
parentAdded USE=static-libs requested by ago (diff)
downloadgentoo-2-d5456db7ab5e30b5e9071cf2700a82e178fd73c5.tar.gz
gentoo-2-d5456db7ab5e30b5e9071cf2700a82e178fd73c5.tar.bz2
gentoo-2-d5456db7ab5e30b5e9071cf2700a82e178fd73c5.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/minitest/ChangeLog7
-rw-r--r--dev-ruby/minitest/minitest-2.6.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/minitest/ChangeLog b/dev-ruby/minitest/ChangeLog
index 5d48692e3daf..e03d9912e16c 100644
--- a/dev-ruby/minitest/ChangeLog
+++ b/dev-ruby/minitest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/minitest
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.55 2011/10/23 08:46:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.56 2011/10/25 06:02:17 graaff Exp $
+
+*minitest-2.6.2 (25 Oct 2011)
+
+ 25 Oct 2011; Hans de Graaff <graaff@gentoo.org> +minitest-2.6.2.ebuild:
+ Version bump.
23 Oct 2011; Hans de Graaff <graaff@gentoo.org> minitest-2.6.1.ebuild:
Add missing dependency on rdoc.
diff --git a/dev-ruby/minitest/minitest-2.6.2.ebuild b/dev-ruby/minitest/minitest-2.6.2.ebuild
new file mode 100644
index 000000000000..2bac52484234
--- /dev/null
+++ b/dev-ruby/minitest/minitest-2.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-2.6.2.ebuild,v 1.1 2011/10/25 06:02:17 graaff Exp $
+
+EAPI=2
+# jruby → tests fail, reported upstream
+# http://rubyforge.org/tracker/index.php?func=detail&aid=27657&group_id=1040&atid=4097
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit."
+HOMEPAGE="http://rubyforge.org/projects/bfts"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/hoe dev-ruby/rdoc )
+ test? (
+ dev-ruby/rdoc
+ dev-ruby/hoe
+ )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Remove failing tests. Upstream claims that these are all
+ # bugs in jruby. By removing the failing tests we can at
+ # least run the remainder. See bug 321055 for details.
+ rm -f test/test_minitest_unit.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}