summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-11-07 05:57:55 +0000
committerHans de Graaff <graaff@gentoo.org>2010-11-07 05:57:55 +0000
commitcb1b2ba1e666190993f917818fcdcf3ccdccc040 (patch)
tree6840e0cd04d74c2b8443736cff56821506e7bffb /dev-ruby
parentRemove old versions. (diff)
downloadgentoo-2-cb1b2ba1e666190993f917818fcdcf3ccdccc040.tar.gz
gentoo-2-cb1b2ba1e666190993f917818fcdcf3ccdccc040.tar.bz2
gentoo-2-cb1b2ba1e666190993f917818fcdcf3ccdccc040.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/haml/ChangeLog7
-rw-r--r--dev-ruby/haml/haml-3.0.23.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 7004c8fe89ca..c1236f0c6b45 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.55 2010/10/29 15:31:41 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.56 2010/11/07 05:57:55 graaff Exp $
+
+*haml-3.0.23 (07 Nov 2010)
+
+ 07 Nov 2010; Hans de Graaff <graaff@gentoo.org> +haml-3.0.23.ebuild:
+ Version bump.
*haml-3.0.22 (29 Oct 2010)
diff --git a/dev-ruby/haml/haml-3.0.23.ebuild b/dev-ruby/haml/haml-3.0.23.ebuild
new file mode 100644
index 000000000000..b76131ae7d1e
--- /dev/null
+++ b/dev-ruby/haml/haml-3.0.23.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.0.23.ebuild,v 1.1 2010/11/07 05:57:55 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml.hamptoncatlin.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+# The html engine requires hpricot
+ruby_add_rdepend dev-ruby/hpricot
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend "
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/erubis
+ dev-ruby/rails
+ dev-ruby/ruby_parser
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ )"