summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-12 19:52:51 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-12 19:52:51 +0000
commitc7f479d07b13ec259c9f29b4dc17a3d062803925 (patch)
tree82dbe91e562b161b240e19eb281c1bcdde8b1b37 /dev-ruby
parent[bump] dev-perl/Tree-DAG_Node-1.90.0 (diff)
downloadgentoo-2-c7f479d07b13ec259c9f29b4dc17a3d062803925.tar.gz
gentoo-2-c7f479d07b13ec259c9f29b4dc17a3d062803925.tar.bz2
gentoo-2-c7f479d07b13ec259c9f29b4dc17a3d062803925.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.2.9.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 5d36f8cd5652..c99bc02f62cf 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.186 2012/10/05 18:10:40 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.187 2012/11/12 19:52:51 graaff Exp $
+
+*activesupport-3.2.9 (12 Nov 2012)
+
+ 12 Nov 2012; Hans de Graaff <graaff@gentoo.org> +activesupport-3.2.9.ebuild:
+ Version bump.
05 Oct 2012; Brent Baude <ranger@gentoo.org> activesupport-2.3.14-r1.ebuild:
Marking activesupport-2.3.14-r1 ppc64 for bug 422745
diff --git a/dev-ruby/activesupport/activesupport-3.2.9.ebuild b/dev-ruby/activesupport/activesupport-3.2.9.ebuild
new file mode 100644
index 000000000000..ecf99046d4d3
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.2.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.2.9.ebuild,v 1.1 2012/11/12 19:52:51 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/multi_json-1.0
+ dev-ruby/i18n:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/memcache-client-1.5.8
+ dev-ruby/nokogiri
+ >=dev-ruby/builder-3.0.3:3
+ )"
+
+# libxml is not strictly needed, there are tests using this code. jruby
+# uses a different xml implementation.
+USE_RUBY=${USE_RUBY/jruby/} ruby_add_bdepend "test? ( >=dev-ruby/libxml-2.0.0 )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}